LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 12-21-2012, 01:40 AM   #1
rohanp141@gmail.com
LQ Newbie
 
Registered: Dec 2012
Posts: 3

Rep: Reputation: Disabled
configure: Requested 'glib-2.0 >= 2.32.0' but version of GLib Uninstalled is 2.29.2


Hi,
I am trying to knock my head from two days to solve this problem .
I have installed Glib 2.32 , which is needed for gstreamer compiling but when I compile Gstreamer getting error :
configure: Requested 'glib-2.0 >= 2.32.0' but version of GLib Uninstalled is 2.29.2
configure: error: This package requires GLib >= 2.32.0 to compile.
configure failed

Note kg-config --modversion glib-2.0 shows: 2.34.2

but dont know why I am getting error : glib-2.0 >= 2.32.0' while compilation

Is it not getting new Glib path . I am missing any thing on it?
Please help
 
Old 12-21-2012, 02:03 AM   #2
gdejonge
Member
 
Registered: Aug 2010
Location: Netherlands
Distribution: Kubuntu, Debian, Suse, Slackware
Posts: 311

Rep: Reputation: 71
In most cases, if you want to compile from source, you'll need the development versions of the depended libraries. They normally come with the same name but with -dev or -devel attached to the name.
 
Old 12-21-2012, 04:16 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,286

Rep: Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664
Welcome to LQ.

Please try to set the new glib first in the LD_LIBRARY_PATH, like :

export LD_LIBRARY_PATH=/usr/local/lib:/usr/lib:/lib
( Or wherever you installed the "2.32.0".)

But : It may be difficult on some OS to handle two versions.

.
 
Old 12-21-2012, 05:29 AM   #4
rohanp141@gmail.com
LQ Newbie
 
Registered: Dec 2012
Posts: 3

Original Poster
Rep: Reputation: Disabled
In most cases, if you want to compile from source, you'll need the development versions of the depended libraries. They normally come with the same name but with -dev or -devel attached to the name.

I have installed all the depended libraries for Glib .
In fact Glib is build and configured successfully but I think older version of glib is still running hence getting the error : glib-2.0 >= 2.32.0' while compilation
how to update the Glib version so that when i am compiling it should take glib 2.32 and not 2.0
 
Old 12-21-2012, 05:50 AM   #5
gdejonge
Member
 
Registered: Aug 2010
Location: Netherlands
Distribution: Kubuntu, Debian, Suse, Slackware
Posts: 311

Rep: Reputation: 71
To make things clear. Did you install the new glib from a package or did you also build it from source?
 
1 members found this post helpful.
Old 12-21-2012, 07:12 AM   #6
rohanp141@gmail.com
LQ Newbie
 
Registered: Dec 2012
Posts: 3

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by gdejonge View Post
To make things clear. Did you install the new glib from a package or did you also build it from source?
I did install new Glib package
site : http://www.linuxfromscratch.org/blfs...ral/glib2.html

I configured and build glib 2.32.0
Now I am building gstreamer and for that I need Glib version 2.32.0
Already my system had glib 2.0

I am not able to compile Gstreamer even if I have installed Glib 2.32
getting error as mentioned above
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cent OS GLib 2.12.3 pkg-config --modversion glib-2.0' returned 2.22.2 Styles Linux - Distributions 1 10-09-2009 04:12 AM
conflicting glib versions and glib-config scius Linux - Software 5 06-03-2008 03:35 AM
'pkg-config --modversion glib-2.0' returned 2.16.3, but GLIB (2.14.6) pgb205 Linux - Software 7 05-17-2008 04:21 PM
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 10:12 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 07:07 PM


All times are GMT -5. The time now is 12:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration