LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-13-2005, 09:43 PM   #1
J--Lew
LQ Newbie
 
Registered: Aug 2005
Location: Calgary, Canada
Posts: 29

Rep: Reputation: 15
./configure problem, unable to find Qt... sometimes


Hey guys, just got myself a new laptop, and I'm having some troubles installing some programs from source. For example, when I attempt to install Kbfx my ./configure craps out saying:
Code:
Checking for Qt... configure: error: Qt (>= Qt 3.2) (library qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!
Now I know that I have the latest Qt libraries installed.

When I installed Yakuake, the script found Qt no problem, this is what it said:
Code:
checking for Qt... libraries /usr/lib/qt3/lib64, headers /usr/lib/qt3/include using -mt
so now that I know where Qt is installed to, how can I tell the other configure scripts where to find it??

Thanks guys
 
Old 10-13-2005, 10:41 PM   #2
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Jessie, Linux Mint 17
Posts: 7,773

Rep: Reputation: 291Reputation: 291Reputation: 291
"Checking for Qt... configure: error: Qt (>= Qt 3.2) (library qt-mt) not found."
"checking for Qt... libraries /usr/lib/qt3/lib64, headers /usr/lib/qt3/include using -mt"
"Now I know that I have the latest Qt libraries installed. "

Check the version number of Qt. Is it higher than Qt 3.2?

The other possibility is that ./configure is often ambiguous about whether it is looking for the binary or development version of a package. Check whether you also have the Qt development package installed.

---------------------------
Steve Stites
 
Old 10-14-2005, 12:12 AM   #3
scuzzman
Senior Member
 
Registered: May 2004
Location: Hilliard, Ohio, USA
Distribution: Slackware, Kubuntu
Posts: 1,851

Rep: Reputation: 47
Code:
./configure --help
usually provides some extra flags you can pass to ./configure - typically, one of the flags will allow you to point to a specific location for a set of libs (such as Qt).
 
Old 10-14-2005, 06:39 PM   #4
J--Lew
LQ Newbie
 
Registered: Aug 2005
Location: Calgary, Canada
Posts: 29

Original Poster
Rep: Reputation: 15
Thanks for the help guys, but I still can't get this to work. I made sure that I have the most up-to-date version of Qt.
I ran ./configure --help, and tried passing "./configure --with-qt-libaries=/usr/lib/qt3/lib64 --with-qt-includes=/usr/lib/qt3/include", and "./configure --with-qt-dir=/usr/lib/qt4", but I am still getting the same error. Any ideas?
 
Old 10-15-2005, 12:03 PM   #5
Agentvenom
Member
 
Registered: Sep 2005
Distribution: PCLinuxOS 2007 / Suse 10.3
Posts: 228

Rep: Reputation: 30
I know very little about compiling. But if you want to extend your path so it will look in other places just read this:

If, at any time, you want to extend your search path temporarily, just for the duration of the rest of this login session, you can add a new entry to the end at the command prompt with (for example):

$ PATH=$PATH:/usr/games (where /usr/games is where you want it to search)


If, however, you want to make a permanent change, you should do this in your personal .bash_profile, and your new path will take effect at the next login.

Maybe you could extend your search path to include the location you found QT in the other script?
 
Old 10-15-2005, 12:55 PM   #6
ioerror
Member
 
Registered: Sep 2005
Location: Old Blighty
Distribution: Slackware, NetBSD
Posts: 536

Rep: Reputation: 30
Quote:
$ PATH=$PATH:/usr/games (where /usr/games is where you want it to search)
PATH is only used to search for commands. It isn't relevant when looking for libraries during compiling.

Look in config.log, it should give some indication about what it's trying (and failing) to do.

Also, make sure you have the qt development libs/headers installed. Some distros split run time and development stuff into seperate packages.
 
Old 10-16-2005, 08:18 PM   #7
J--Lew
LQ Newbie
 
Registered: Aug 2005
Location: Calgary, Canada
Posts: 29

Original Poster
Rep: Reputation: 15
Hey thanks for all of the replies guys, but I think I found the soution if anyone else is having this problem. I forgot to mention that I am using an AMD64 processor, and everything seems to work fine when I run
Code:
./configure --enable-libsuffix=64
I just took a shot in the dark and it seemed to work fine
 
Old 10-24-2005, 09:11 AM   #8
yknott
LQ Newbie
 
Registered: Jan 2004
Posts: 4

Rep: Reputation: 0
error: Qt (>= Qt 3.0) (library qt-mt) not found (64 bit)

thanks
i was pulling my hair out over this too, and yeah i also am using the athlon64 and hence 64bit version of opensuse 10;

compiling with
--enable-libsuffix=64

worked
whereas adding all of the
--with-qt-dir=...
--with-qt-libraries=...
--with-qt-includes=...
had not helped
 
Old 11-17-2005, 09:24 AM   #9
rumbero
LQ Newbie
 
Registered: Nov 2005
Posts: 3

Rep: Reputation: 0
Hi @ ALL

I had the same problem and I fixed it with:

ln -s /usr/lib/qt-3.3 /usr/lib/qt

This works with RedHat Linux :-)

Bye

rumbero
 
Old 12-11-2005, 11:48 PM   #10
alar
Member
 
Registered: Sep 2003
Location: Canada
Distribution: CentOS 5.5, Ubuntu 10.04, Linux Mint 11 gnome 64 bit
Posts: 336

Rep: Reputation: 36
All together now

./configure --enable-libsuffix=64 --without-kde --with-qt-dir=/usr/lib/qt

It worked!!!

AMD, Gnome and symlink to /usr/lib/qt

Thanks!
 
Old 12-13-2005, 04:59 AM   #11
karry
LQ Newbie
 
Registered: Dec 2005
Posts: 1

Rep: Reputation: 0
Qt >=3.2

Hi everybody, I cannot compile due to Qt error, (>=3.2) I've tried to compile as all of you have said but I can't, I'm using suse 10. Thanks very much and regards!
 
Old 12-13-2005, 02:31 PM   #12
alar
Member
 
Registered: Sep 2003
Location: Canada
Distribution: CentOS 5.5, Ubuntu 10.04, Linux Mint 11 gnome 64 bit
Posts: 336

Rep: Reputation: 36
Can you maybe provide some more info?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with ./configure; cannot find gtk-config audiorevolution Linux - Software 8 05-21-2005 03:37 AM
K3B problem (unable to find cdrecord / cdrdao) zeadriche Linux - Newbie 3 06-04-2004 08:50 AM
./configure problem with apollon on RH 9 -> cannot find QT headers and libraries B1TW1SE Linux - Software 13 10-17-2003 08:31 PM
problem with alsa drivers, unable to run ./configure mankeponken Linux - Newbie 15 07-28-2003 04:59 AM
Unable to configure X Windows mchakkuv Linux - General 4 09-19-2001 12:28 PM


All times are GMT -5. The time now is 08:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration