LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-23-2004, 03:48 PM   #1
mykrob
Member
 
Registered: Jun 2004
Location: Jackson, TN
Distribution: Kubuntu Feisty
Posts: 606

Rep: Reputation: 31
./configure --prefix=/???


hi.
i want to install xine and the library files for xine from source, because the RPM's keep messing up my DVD playing... long story.. Anyway's after i get rid of the mess the RPM's created and go to cofigure the source, where should my prefix be for the xine-lib, and finally for xine-ui? If it matters, distro is Suse 9.1 Pro, and running KDE 3.2.1

Thanks,
-myk
 
Old 06-23-2004, 03:51 PM   #2
b0uncer
Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
do you need to specify it? I mean, most of the time you don't. the "normal" setting is enough and usually works...prefix is for those who know they need it and know where
 
Old 06-23-2004, 04:00 PM   #3
mykrob
Member
 
Registered: Jun 2004
Location: Jackson, TN
Distribution: Kubuntu Feisty
Posts: 606

Original Poster
Rep: Reputation: 31
that's the part that puzzles me. I think the lib fines have to be in a certain directory. And if i want to run xine from command line, doesnt it need to end up with its binary in a specific place? Now, mind you, i am a newb, so i may be totally wrong here...

Thanks,
-myk
 
Old 06-23-2004, 04:06 PM   #4
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 53
The simplest solution is to specify:
Code:
./configure --prefix=/usr
which puts the libs into /usr/lib. The default /usr/local/lib occasionally causes trouble (I had lots of trouble with gimp 2 despite /usr/local/lib being in the pkgconfig and ldconfig paths)


and yes, if you want to be able to run the app from the command line without typing the full path then the binary will need to be in a directory in the path. The command above will also put the binaries into /usr/bin. If you do ./configure --help you can see the specific options to put the binaries and libs into totally different places.

Last edited by Komakino; 06-23-2004 at 04:08 PM.
 
Old 06-23-2004, 04:47 PM   #5
Tuttle
Senior Member
 
Registered: Jul 2003
Location: Wellington, NZ
Distribution: mainly slackware
Posts: 1,289

Rep: Reputation: 52
Quote:
Originally posted by mykrob
that's the part that puzzles me. I think the lib fines have to be in a certain directory. And if i want to run xine from command line, doesnt it need to end up with its binary in a specific place? Now, mind you, i am a newb, so i may be totally wrong here...

Thanks,
-myk
Files are arranged on linux so that all the apps are in one set of folders (/bin, /sbin, /usr/bin etc...), and all the libs are in another (/lib, /usr/lib, /usr/local/lib etc...). By default you will find that most software, when installed from source, is setup to be installed to /usr/local/bin, /usr/local/lib etc.... (/usr/local being the default path for all youe extra software).
Any command you type into a console will be automatically found within these folder paths.

Last edited by Tuttle; 06-23-2004 at 04:49 PM.
 
Old 06-23-2004, 09:00 PM   #6
mykrob
Member
 
Registered: Jun 2004
Location: Jackson, TN
Distribution: Kubuntu Feisty
Posts: 606

Original Poster
Rep: Reputation: 31
i installed with the --prefix=/usr but cant run from the command line or find where the fileto run the program is..

Help?

thanks,
-myk
 
Old 06-24-2004, 07:19 AM   #7
Tuttle
Senior Member
 
Registered: Jul 2003
Location: Wellington, NZ
Distribution: mainly slackware
Posts: 1,289

Rep: Reputation: 52
Try configuring and installing without a prefix, this is normally the preferred way (unless specified in the INSTALL or README files supplied with the package).
I think you'll find your program has been installed to /usr/usr/local due to the extra prefix.

edit: see /etc/profile for the system-wide shell (console) defaults.

Last edited by Tuttle; 06-24-2004 at 07:25 AM.
 
Old 06-24-2004, 09:59 AM   #8
mykrob
Member
 
Registered: Jun 2004
Location: Jackson, TN
Distribution: Kubuntu Feisty
Posts: 606

Original Poster
Rep: Reputation: 31
dang, i feel silly.. Apparently i forgot a VITAL step... i was doing a few other things, and though i did "make install" but never did.. After installing, of course, it works fine..


sorry about that


thanks,
-myk
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
./configure --prefix= plan9 Slackware 5 01-03-2013 04:44 AM
a portable ./configure --prefix option spuzzzzzzz Linux - Software 2 07-27-2004 04:34 AM
kde prefix error when running ./configure hoopyfrood Linux - Software 1 04-25-2004 05:40 PM
prefix argument to ./configure luck___ Linux - Software 2 03-13-2004 02:22 AM
Slackware 8: ./configure --prefix=/opt/gnome not working vendemmian Linux - Software 2 12-14-2001 11:49 PM


All times are GMT -5. The time now is 09:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration