LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-30-2005, 10:45 PM   #1
Raftysworld
LQ Newbie
 
Registered: Jan 2005
Posts: 20

Rep: Reputation: 0
./Configure (Gaim)


Hey All,

I'm a REAL n00b, so any advice you can give to me, if you can tell me the exact syntax to use that would be great. I downloaded the latest version of Gaim and ran ./configure, it ran the process but then halted upon this error.

checking for pkg-config... /usr/bin/pkg-config
checking for silc... Package silc was not found in the pkg-config search path.
Perhaps you should add the directory containing `silc.pc'
to the PKG_CONFIG_PATH environment variable
No package 'silc' found
checking for pkg-config... (cached) /usr/bin/pkg-config
checking for GLIB - version >= 2.0.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occurred. This usually means GLIB is incorrectly installed.
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at (link)

I installed the latest pkg-config, and I have GLib 2.0+ installed (I'm running SuSE 9.2 Professional). Any advice? Thanks!

~Eric
 
Old 01-30-2005, 11:15 PM   #2
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
You need to do one of two things:
1) Find a package-based version of gaim available for your distro. Download and install that rather than trying to compile.

-or-

2) If you want to compile, then you'll need to install the development packages for glib (and perhaps other libraries). You'll have to open up Yast or whatever program is necessary for package management, find the "glib-devel" package (or something like that), install it, and then try to compile Gaim again. If the configure script fails again, look to see what library is croaks on, and repeat the process for *-devel.
 
Old 01-30-2005, 11:18 PM   #3
Raftysworld
LQ Newbie
 
Registered: Jan 2005
Posts: 20

Original Poster
Rep: Reputation: 0
I think I'll give option #1 a shot, if i can find such an RPM. Thanks for the help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to configure gaim in FC4 crimsonflame123 Linux - Software 5 08-09-2005 05:38 AM
./configure error with gaim 1.0.1 jspaceman Linux - Software 1 10-12-2004 08:04 AM
setting PKG_CONFIG_PATH variable, GAIM ./configure Hal Linux - Newbie 5 07-17-2004 04:12 PM
gaim configure can't find ssl libraries shanenin Linux - Software 2 10-18-2003 02:46 PM
gaim .60 wont configure Craneology Linux - Software 2 03-27-2003 04:12 PM


All times are GMT -5. The time now is 02:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration