LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-08-2006, 01:22 AM   #1
nodnarb
LQ Newbie
 
Registered: Jul 2004
Location: TN, USA
Distribution: Mandrake
Posts: 23

Rep: Reputation: 15
./configure error (can't find libraries)


Hi,

I been trying to install several different programs since installing mandrake 10.1 but often get errors during the "./configure" step saying it cant find a certain library. But when I go to install the rpm, I'm told everything is installed.

Ex. When I tried to install GNUnet I got everything would on fine until a few second it says "configure: error: GNUnet requires the GNU MP library (libgmp)"

Anybody have any suggestions on how do I go about fixing this problem?
 
Old 02-08-2006, 02:00 AM   #2
sohny
Member
 
Registered: Aug 2004
Location: bangalore
Distribution: Redhat,Ubuntu
Posts: 64

Rep: Reputation: 15
the problem it seems is that the configure script is trying to match the exact version of certain libraries.

ANy if u can post the error msg it would be helpful
 
Old 02-09-2006, 09:01 PM   #3
nodnarb
LQ Newbie
 
Registered: Jul 2004
Location: TN, USA
Distribution: Mandrake
Posts: 23

Original Poster
Rep: Reputation: 15
Heres the error msg:

[root@cpe-66-61-99-46 nodnarbthegreat]# urpmi ./"aim-1.5.286-1.i386".rpm
Some package requested cannot be installed:
aim-1.5.286-1.i386 (due to unsatisfied libstdc++-libc6.1-1.so.2)
Continue? (Y/n)
 
Old 02-09-2006, 09:10 PM   #4
WhiskeyTangoFoxtrot
Member
 
Registered: Oct 2005
Location: Windsor, Ontario, Canada
Distribution: Fedora Core 5,4,3 & Ubuntu 6.06, 8.10
Posts: 403
Blog Entries: 1

Rep: Reputation: 30
Try to install them from the online reposotries using the console. Fedora and Redhat for example use the yum repos and they also install all the dependencied automatically. i am not sure but there has to be one for Mdk 10.1 too ( i just installed it myself and am still looking :-S)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help setting right environment variables:configure scripts can't find libraries. z-vet Linux - Newbie 4 08-16-2004 06:10 PM
checking for Qt... configure: error: Qt (>= Qt 3.0) (headers and libraries) not found Guitarist88 Linux - Newbie 2 08-13-2004 01:15 PM
gaim configure can't find ssl libraries shanenin Linux - Software 2 10-18-2003 02:46 PM
./configure problem with apollon on RH 9 -> cannot find QT headers and libraries B1TW1SE Linux - Software 13 10-17-2003 08:31 PM
checking for Qt... configure: error: Qt >= 1.42 (libraries) not found. cblau Linux - Software 6 02-28-2003 09:34 PM


All times are GMT -5. The time now is 08:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration