LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-04-2013, 06:15 AM   #1
lohith.nayak
LQ Newbie
 
Registered: Sep 2012
Posts: 12

Rep: Reputation: Disabled
configure: error: *** Working zlib library and headers not found ***


Currently I am trying to compile glib-2.32.3.
I am using Red Hadt linux, 64bit (x86_64) machine.
I am trying to compile glib-2.32.3 for 32bit.

I did following steps for compilation,
1. tar -xvf glib-2.32.3.tar
2. cd glib-2.32.3
3. ./configure --prefix=~/tools/glib-2.32.3/linux-x86 --host=x86_64-redhat-linux-gnu CC="/tools/x64/bin/gcc" CFLAGS="-m32 -O2"

I get error,
configure: error: *** Working zlib library and headers not found ***

4. I downloaded zlib-1.2.8
5. tar -xvf zlib-1.2.8.tar.gz
6. cd zlib-1.2.8
7. ./configure --prefix=~/tools/zlib-1.2.8/linux-x86
8. make CC=/tools/x64/bin/gcc CFLAGS="-m32 -o2" install
9. export PATH=~/local/tools/zlib-1.2.8/linux-x86/lib:$PATH

I saw zlib.pc inside local/tools/zlib-1.2.8/linux-x86/lib/pkgconfig.
I added this path to the $PATH.

When I recompiled glib-2.32.3 I am getting same error.
When I did "echo $PATH" I could see "~/local/tools/zlib-1.2.8/linux086/lib".
Why zlib library is not seen to config ??
 
Old 12-04-2013, 09:32 PM   #2
evo2
LQ Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,753

Rep: Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288
Hi,

$PATH is where your shell searches for executables, it has nothing to do with where a compiler will look for header files or a linker will look for libraries.

Evo2.
 
2 members found this post helpful.
Old 12-05-2013, 03:36 AM   #3
lohith.nayak
LQ Newbie
 
Registered: Sep 2012
Posts: 12

Original Poster
Rep: Reputation: Disabled
OKay. I added library path in compiler options.
It is working fine now.
Thanks for the information.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] configure: error: *** Working zlib library and headers not found *** rishi77 Linux - Newbie 5 04-28-2012 08:51 AM
[SOLVED] trying to ./configure GLib. returns error ***Working zlib and headers not found *** u gtwaby Linux - Desktop 1 06-11-2010 12:26 PM
configure: error: Qt (>= Qt 3.0.2) (headers and libraries) not found Sargalus Linux - Software 20 02-23-2010 01:40 AM
checking for Qt... configure: error: Qt (>= Qt 3.0) (headers and libraries) not found M$ISBS Linux - Software 11 07-12-2006 10:07 PM
checking for Qt... configure: error: Qt (>= Qt 3.0) (headers and libraries) not found Guitarist88 Linux - Newbie 2 08-13-2004 01:15 PM


All times are GMT -5. The time now is 09:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration