LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-18-2009, 11:45 PM   #1
jumpmansbro
LQ Newbie
 
Registered: Jan 2009
Posts: 21

Rep: Reputation: Disabled
Talking ./configure command isn't working in command line


I'm new to Linux and I still can't figure out how to install tarball source. I get up to the './configure' step, but when I enter it, it just says "bash: ./configure: No such file or directory". Should I add something else to the command?
 
Old 01-18-2009, 11:50 PM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
You probably need to cd into the directory you created. Also, check if your distro supplies the package which may save a lot of work. If not, be sure to read the README and INSTALLATION files. Also run "./configure --help". There could be important options that you want to add when running configure.
 
Old 01-18-2009, 11:57 PM   #3
jumpmansbro
LQ Newbie
 
Registered: Jan 2009
Posts: 21

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by jschiwal View Post
You probably need to cd into the directory you created. Also, check if your distro supplies the package which may save a lot of work. If not, be sure to read the README and INSTALLATION files. Also run "./configure --help". There could be important options that you want to add when running configure.
Ubuntu does not supply the package (it's the Linux driver for QuickCam webcams, by the way) and running './configure --help' just produces the same "bash: ./configure: No such file or directory".
 
Old 01-19-2009, 12:04 AM   #4
caffeinejunky
LQ Newbie
 
Registered: Jan 2009
Location: Los Angeles
Distribution: Fedora
Posts: 1

Rep: Reputation: 0
I agree with jschiwal, you probably aren't in the same directory as the configure script. Double check to make sure you actually cd into the right location. Check permissions on the file while you're there.
 
Old 01-19-2009, 12:58 AM   #5
jumpmansbro
LQ Newbie
 
Registered: Jan 2009
Posts: 21

Original Poster
Rep: Reputation: Disabled
Alright, I'm sorry, but what directory has the configure script?
 
Old 01-19-2009, 01:45 AM   #6
chakka.lokesh
Member
 
Registered: Mar 2008
Distribution: Ubuntu
Posts: 211

Rep: Reputation: 32
did you extracted the tar file??
 
Old 01-19-2009, 02:32 AM   #7
spurious
Member
 
Registered: Apr 2003
Location: Vancouver, BC
Distribution: Slackware, Ubuntu
Posts: 558

Rep: Reputation: 31
Quote:
Originally Posted by jumpmansbro View Post
Ubuntu does not supply the package (it's the Linux driver for QuickCam webcams, by the way) and running './configure --help' just produces the same "bash: ./configure: No such file or directory".
What version of Ubuntu are you running? I'm using Hardy, and the gspca module (the driver for most webcams) is compiled and included by default. Here is a list of the webcams that gspca supports: http://tomoyo.sourceforge.jp/cgi-bin...inux/gspca.txt

To load this module, do sudo modprobe gspca in a terminal. To load it permanently, append gspca to /etc/modules.

In answer to your original question, not all source tarballs have a configure script. With some software, all you have to do is the 'make && make install' step. Other packages require that you run 'autogen.sh' in order to create the configure script. With one-file C programs, all you have to do is run 'gcc -c program.c'.
 
Old 01-19-2009, 05:14 AM   #8
jumpmansbro
LQ Newbie
 
Registered: Jan 2009
Posts: 21

Original Poster
Rep: Reputation: Disabled
I believe I'm running Intrepid, and I ran 'sudo modprobe gspca', it said "FATAL: Module gspca not found." I also cd'd into the folder and ran 'make'. There was already a "Makefile" in there, so I entered 'make install'. It just spit out a bunch of code, and ended by saying some errors.
 
Old 01-19-2009, 05:28 AM   #9
stratotak
Member
 
Registered: Sep 2005
Distribution: Today Debian . Tomorrow ..??
Posts: 386

Rep: Reputation: 39
your first step when trying to compile from source is to read the readme's in source folder..it will tell you if it needs any special commands and what packages are required to build ..did it make without errors??and if so..did you sudo make install..??
 
Old 01-19-2009, 05:42 AM   #10
jumpmansbro
LQ Newbie
 
Registered: Jan 2009
Posts: 21

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by stratotak View Post
your first step when trying to compile from source is to read the readme's in source folder..it will tell you if it needs any special commands and what packages are required to build ..did it make without errors??and if so..did you sudo make install..??
The Readme says "Just use a plain "make" to compile the driver." And 'sudo make install' produces the same results as just 'make install'.
 
Old 01-19-2009, 05:50 AM   #11
stratotak
Member
 
Registered: Sep 2005
Distribution: Today Debian . Tomorrow ..??
Posts: 386

Rep: Reputation: 39
http://qce-ga.sourceforge.net/
If thats the source your compiling ..its
make all
insmod ./quickcam.ko
 
Old 01-19-2009, 04:42 PM   #12
jumpmansbro
LQ Newbie
 
Registered: Jan 2009
Posts: 21

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by stratotak View Post
http://qce-ga.sourceforge.net/
If thats the source your compiling ..its
make all
insmod ./quickcam.ko
When I run 'make all', I just get the same text scrolling across the screen (a lot of the ones at the end say error), and then 'insmod ./quickcam.ko' just says "insmod: can't read './quickcam.ko': No such file or directory".
 
Old 01-19-2009, 05:15 PM   #13
kapilbajpai88
Member
 
Registered: Jul 2008
Location: Bangalore, India
Distribution: RHEL
Posts: 235

Rep: Reputation: 41
Smile

Hi there,
first thing that you need to check is whether you are in proper directory or not...
secondly, make sure that you have proper permissions..
thirdly, as u already came to know that Ubantu doesn't provide packages, so you need to check what other versions of ubantu flavour do support webcams in more convenient way...

regards,
Kapil.
 
Old 01-19-2009, 05:43 PM   #14
stratotak
Member
 
Registered: Sep 2005
Distribution: Today Debian . Tomorrow ..??
Posts: 386

Rep: Reputation: 39
post a smaple of those errors?do you have the build-essentials installed..kernel headers,gcc,etc..?
 
Old 01-19-2009, 10:42 PM   #15
jumpmansbro
LQ Newbie
 
Registered: Jan 2009
Posts: 21

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by stratotak View Post
post a smaple of those errors?do you have the build-essentials installed..kernel headers,gcc,etc..?
The content I receive after entering 'make all':
"make -C "/lib/modules/2.6.27-9-generic/build" SUBDIRS="/home/jump/Desktop/qc-usb-0.6.6" modules V=1 USER_OPT="-DHAVE_UTSRELEASE_H=1"
make[1]: Entering directory `/usr/src/linux-headers-2.6.27-9-generic'
test -e include/linux/autoconf.h -a -e include/config/auto.conf || ( \
echo; \
echo " ERROR: Kernel configuration is invalid."; \
echo " include/linux/autoconf.h or include/config/auto.conf are missing."; \
echo " Run 'make oldconfig && make prepare' on kernel src to fix it."; \
echo; \
/bin/false)
mkdir -p /home/jump/Desktop/qc-usb-0.6.6/.tmp_versions ; rm -f /home/jump/Desktop/qc-usb-0.6.6/.tmp_versions/*
make -f scripts/Makefile.build obj=/home/jump/Desktop/qc-usb-0.6.6
gcc -Wp,-MD,/home/jump/Desktop/qc-usb-0.6.6/.qc-driver.o.d -nostdinc -isystem /usr/lib/gcc/i486-linux-gnu/4.3.2/include -D__KERNEL__ -Iinclude -I/usr/src/linux-headers-2.6.27-9-generic/arch/x86/include -include include/linux/autoconf.h -Iubuntu/include -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -O2 -m32 -msoft-float -mregparm=3 -freg-struct-return -mpreferred-stack-boundary=2 -march=i586 -mtune=generic -ffreestanding -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -Iinclude/asm-x86/mach-default -fno-stack-protector -fno-omit-frame-pointer -fno-optimize-sibling-calls -pg -Wdeclaration-after-statement -Wno-pointer-sign -DNOKERNEL -DHAVE_UTSRELEASE_H=1 -DMODULE -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(qc_driver)" -D"KBUILD_MODNAME=KBUILD_STR(quickcam)" -c -o /home/jump/Desktop/qc-usb-0.6.6/.tmp_qc-driver.o /home/jump/Desktop/qc-usb-0.6.6/qc-driver.c
In file included from /home/jump/Desktop/qc-usb-0.6.6/qc-driver.c:47:
/home/jump/Desktop/qc-usb-0.6.6/quickcam.h:129:1: warning: "BIT" redefined
In file included from include/linux/kernel.h:15,
from include/linux/cache.h:4,
from include/linux/time.h:7,
from include/linux/videodev2.h:60,
from include/linux/videodev.h:16,
from /home/jump/Desktop/qc-usb-0.6.6/quickcam.h:95,
from /home/jump/Desktop/qc-usb-0.6.6/qc-driver.c:47:
include/linux/bitops.h:6:1: warning: this is the location of the previous definition
/home/jump/Desktop/qc-usb-0.6.6/qc-driver.c: In function ‘qc_i2c_init’:
/home/jump/Desktop/qc-usb-0.6.6/qc-driver.c:824: error: ‘struct urb’ has no member named ‘lock’
/home/jump/Desktop/qc-usb-0.6.6/qc-driver.c:825: warning: assignment from incompatible pointer type
/home/jump/Desktop/qc-usb-0.6.6/qc-driver.c: In function ‘qc_isoc_start’:
/home/jump/Desktop/qc-usb-0.6.6/qc-driver.c:1867: warning: assignment from incompatible pointer type
/home/jump/Desktop/qc-usb-0.6.6/qc-driver.c: In function ‘qc_v4l_ioctl’:
/home/jump/Desktop/qc-usb-0.6.6/qc-driver.c:2529: error: ‘struct video_device’ has no member named ‘type’
/home/jump/Desktop/qc-usb-0.6.6/qc-driver.c: At top level:
/home/jump/Desktop/qc-usb-0.6.6/qc-driver.c:3008: error: unknown field ‘type’ specified in initializer
/home/jump/Desktop/qc-usb-0.6.6/qc-driver.c:3009: error: unknown field ‘hardware’ specified in initializer
make[2]: *** [/home/jump/Desktop/qc-usb-0.6.6/qc-driver.o] Error 1
make[1]: *** [_module_/home/jump/Desktop/qc-usb-0.6.6] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.27-9-generic'
make: *** [quickcam.ko] Error 2"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
configure floppy and dvd rom without command line stanW Linux - Hardware 2 06-09-2008 04:40 AM
Who to configure eth0 to use dhco from command line waelaltaqi Linux - Networking 3 11-18-2005 06:36 PM
Configure DNS printer via CUPS command line adagbg Red Hat 0 03-09-2005 10:46 AM
Configure FC1 firewall in command line codyz062003 Linux - Security 1 12-12-2004 09:05 PM
configure x from command line? tumnus Linux - Newbie 5 02-13-2003 05:32 PM


All times are GMT -5. The time now is 06:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration