LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-20-2004, 03:58 PM   #1
bcom
LQ Newbie
 
Registered: May 2004
Posts: 7

Rep: Reputation: 0
Configure Apache with Mandrake 10


I'm pretty new to all this. I've set up a linux box on my network to run my own web server. Running Mandrake 10 Official. I'm having problems configuring apache to work properly. When I run "apachectl start" i get this error :

httpd2: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName

I am using "no-ip" to forward my dynamic ip to the following domain bcomsolutions.no-ip.info

I set the domain name to that. I'm not sure exactly what to set for the hostname. I am using apache that installed with mandrake.

Any help is greatly appreciated.
 
Old 05-20-2004, 04:03 PM   #2
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
Nothing wrong there. It is just a warning. Since you have not configured the domain name like localhost or myserver ..... it is using 127.0.0.1 which is by default the localhost ip address.

Dont worry about it.
 
Old 05-20-2004, 11:52 PM   #3
bcom
LQ Newbie
 
Registered: May 2004
Posts: 7

Original Poster
Rep: Reputation: 0
So you're saying that apache should then be started?

If this is the case, must have some configuration issues then, because when i type in my IP it says connection refused.

Is there some way I can test my config files to figure out what is wrong?
 
Old 05-21-2004, 01:03 AM   #4
xanas3712
Member
 
Registered: Apr 2004
Distribution: Slackware/Mandrake/Debian (sarge)
Posts: 266

Rep: Reputation: 30
Make sure it's bound to the eth0 interface... (or whatever your network card is)..
You should see something like this
BindAddress *

If it's commented out I believe it uses just the 127.0.0.1 loopback interface and will not work with your external ip address.

So uncomment and apachectl restart
 
Old 05-21-2004, 07:26 AM   #5
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
To test if Apache works, do try the address http://127.0.0.1 or http://localhost

One of these should work if you are running apache. For accessing your apache server through IP there could be more issues (like router settings...)
 
Old 05-24-2004, 01:23 PM   #6
bcom
LQ Newbie
 
Registered: May 2004
Posts: 7

Original Poster
Rep: Reputation: 0
OK i found the BindAddress * line, uncommented it. When i run apachectl restart i get:

Starting httpd2: Syntax error on line 77 of /etc/httpd/conf/httpd2.conf:
Invalid command 'BindAddress', perhaps mis-spelled or defined by a module not included in the server configuration
[FAILED]

Any thoughts?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Configure Apache Megasms Programming 3 11-04-2005 05:36 AM
configure apache tux66 Slackware 11 05-02-2005 03:49 PM
how to configure apache Roll Linux - Software 1 03-06-2005 11:14 AM
Configure Apache esasse Linux - Newbie 2 12-02-2004 02:51 PM
How to configure ServerName for Apache 2.0 in Mandrake? terrygao Linux - Networking 1 10-24-2004 04:59 AM


All times are GMT -5. The time now is 07:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration