LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-09-2004, 01:04 PM   #1
veritas
Member
 
Registered: Aug 2003
Location: Dallas,TX
Distribution: Ubuntu Server, Slackware, Red Hat 6.1
Posts: 241

Rep: Reputation: 30
computer not completely shutting down


When ever i use the command 'shutdown -h -t 10 now' to turn off the computer, it goes through all of the kill stuff, but when it finishes, "Power Down" displays but the text remains on the screen. I can hear the hard drive shutting off (I think), but the computer power still stays on.

What do I need to change to get my computer to shut down completely?
 
Old 02-09-2004, 01:08 PM   #2
LinuxSeeker
Member
 
Registered: Feb 2004
Location: Linuxland
Distribution: Ubuntu 5.10, KUbuntu 5.10, Mandrake 10.1 - Ubuntu 5.04 (Hoary)
Posts: 346

Rep: Reputation: 30
Try "shutdown -h now" (without these "")
 
Old 02-09-2004, 01:09 PM   #3
slackie1000
Senior Member
 
Registered: Dec 2003
Location: Brasil
Distribution: Arch
Posts: 1,037

Rep: Reputation: 45
hi !!

does your hardware supports apm/acpi??
I don't know about you, but in my case i had to recompile the kernel to get that ...
acpi was required ... and it is not included if you installed the classic "bare.i" kernel from slack 9.1 ...
if your hardware requires acpi, you have two options: recompile the kernel or reinstal the kernel from slack 9.1 cd choosing the "bare.i.acpi" kernel...
maybe you can give more information about your hardware and general setup...
take a look also at other threads.. i am sure i saw several threads about that..

Best Regards,

Slackie
 
Old 02-09-2004, 01:19 PM   #4
veritas
Member
 
Registered: Aug 2003
Location: Dallas,TX
Distribution: Ubuntu Server, Slackware, Red Hat 6.1
Posts: 241

Original Poster
Rep: Reputation: 30
LinuxSeeker: tried that before, still does the same thing.

slackie1000: I'm not at home right now, so I cant check out if my hardware supports APM, but i am almost 95% sure it does. I really want to avoid doing a new install, because i have compiled and installed so much stuff that was hard to do. So i guess i need to recompile my kernel. Are there any threads you could point me to that have info on compiling with APM?

Also, since I'm booting from a floppy, would it work if I found a precompiled kernel and just copied to the floppy, or do i still need to compile one to match my exact setup? (not really sure how kernels work)

Thanks,
Wes
 
Old 02-09-2004, 01:28 PM   #5
slackie1000
Senior Member
 
Registered: Dec 2003
Location: Brasil
Distribution: Arch
Posts: 1,037

Rep: Reputation: 45
that is the thing !!!
to compile a kernel, in my opinion, is to optimize your system performance finding all of your hardware and software requirements and put it to burn!!! Everything that is not necessary you leave out.. that why i think it will not work to get something prepared..
what you can do being relative new to this kernel world is :
try to reinstall only the kernel from the slack cd...
you can put the cd, i suppose you can boot that, and type setup ...
then you look around to the option to reinstall the kernel...
then you look for bare.i.acpi ...
this is exact the default kernel, bare.i, plus some power management capabilities..
i think this would be the faster way...
if you want to have some fun, try to recompile the kernel, saving the old, of course ...
i recommend DaOne guide ... you can do a search to find that....
just need to switch the acpi/apm capabilities at "power management setup" menu ...
before anything, check your hardware and see what is going on...
maybe, only
/sbin/modprobe apm
can save you...

Regards

Slackie

Last edited by slackie1000; 05-26-2004 at 03:02 PM.
 
Old 02-09-2004, 05:02 PM   #6
veritas
Member
 
Registered: Aug 2003
Location: Dallas,TX
Distribution: Ubuntu Server, Slackware, Red Hat 6.1
Posts: 241

Original Poster
Rep: Reputation: 30
slackie, 'modprobe apm' as root did the trick. I was on a regular user, did su, modprobe apm, tested with 'shutdown -h now' and it.. worked. Maybe this means I won't have to compile after all. Should I put this command in a startup script, or will it be automatic from now on?
 
Old 02-09-2004, 05:15 PM   #7
Lim45
Member
 
Registered: Apr 2003
Location: Northern England
Distribution: Debian Wheezy 64-bit
Posts: 128

Rep: Reputation: 15
Navigate to /etc/rc.d/, open "rc.modules" and uncomment the line "sbin/modprobe apm" It'll start up next time you reboot.
 
Old 02-09-2004, 05:17 PM   #8
veritas
Member
 
Registered: Aug 2003
Location: Dallas,TX
Distribution: Ubuntu Server, Slackware, Red Hat 6.1
Posts: 241

Original Poster
Rep: Reputation: 30
K, I'll do that. Thanks a bunch for the help everyone.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shutting Down The Computer marvelous Linux - Newbie 13 08-01-2004 02:03 AM
Shutdown not shutting down completely jrdioko Linux - Newbie 19 10-12-2003 12:47 PM
RH9 shutting computer down by itself shycalais Linux - Newbie 6 10-09-2003 08:55 AM
computer keeps shutting down mjkramer Linux - Newbie 1 10-04-2003 06:40 AM
Computer not shutting down Trebor Linux - Newbie 5 08-15-2003 05:33 AM


All times are GMT -5. The time now is 08:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration