LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-04-2005, 05:06 PM   #1
mickepe
LQ Newbie
 
Registered: Jun 2005
Posts: 2

Rep: Reputation: 0
complicated library dependencies


Hello,
I am trying to get my head around this dependency thing. Quite often it seems like I am caught in a catch 22.
Where trying to update something will require other libraries but when you try to install them they conflcit when current libraries. Iīll describe my current situation for a clearer picture.

Iīve got some beta install (apparently) of amaroK that I want to upgrade. Currently I have amarok 1.3beta2-3 and I just downloaded amarok-1.3.0_0.3-1 which I believe is newer as it requires some other newer libraries than I currently have installed.
This new version of amaroK requires gstreamer-0.8.9 or greater but I only have gstreamer-0.8.1-7.1 installed.
Then when I try and install the 0.8.9 gstreamer it conflicts with my currently installed gstreamer. Then I try and uninstall my current one. But that fails as other libraries depend on it.

How do you generally solve something like this? I find myself running into these kinds of loops quite often. As I am completly new to linux I havenīt yet grasped how to deal with issues like this..

I am running suse 9.2 with KDE 3.4 and these libraries havenīt yet showed up on any yast-source so I am trying to do it the manual way. I hope I was clear enough for you to get what I am trying to do.

Thanks for any help!
 
Old 08-04-2005, 08:52 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,889

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
I've been using SuSE for about 3 years now. I had similar problems. UNTIL I installed apt4rpm (acutally apt-get for rpm, not the server version apt4rpm).

To solve your problem, you need to install the new package, then make a whole bunch of sym-links to non-existant files with the correct names, in the correct locations. What this means, because of backwards compatilibity, you can use the new files but not the new capabilities of them.

With apt-get (for rpm), when you log onto the internet, and run 'apt-get upgrade' to get the list of the latest packages from a repository appropiate to your distro, then run 'apt-get install <packagename>', apt-get takes care of the dependencies for you, upgrading packages as required, installing new packages as required, and removing packages as required.

Apt-get is very good about giving you options on how to handle a problem.

All praise to the good folks at Debian for apt-get, and the good folks at Connectiva for the port to rpm (hope I got the credits correctly).

Makes my peepee tingle just thinking of what I can do with SuSE via apt-get for rpm.
 
Old 08-05-2005, 04:43 AM   #3
mickepe
LQ Newbie
 
Registered: Jun 2005
Posts: 2

Original Poster
Rep: Reputation: 0
oh this sounds interesting. Will have a closer look at this apt-get thing. I thought this was why YaST was there though?

Thanks for the help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Command to check library dependencies daihard Linux - Software 6 12-04-2014 10:26 PM
xscreensaver install trouble: library dependencies marquitico Linux - Newbie 4 08-26-2005 08:28 PM
library dependencies bipins1979 Linux - Software 2 03-21-2005 10:50 PM
howto compile bin with my library using all-static and shared linked standart library stpg Programming 4 06-29-2004 04:20 AM
I recieve a failed dependencies error, but I have all required dependencies Laptop2250 Linux - Software 15 02-03-2004 07:58 PM


All times are GMT -5. The time now is 06:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration