LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-15-2003, 08:13 PM   #1
illkunundrum
LQ Newbie
 
Registered: Sep 2003
Posts: 14

Rep: Reputation: 0
Smile complete and entire newbie needs help


ok this is probably too big a task for a linux newbie to take on. But how else better to learn than from the experienced and the wise linux gurus. Well gurus compared to me. Here we go...

I just installed RedHat 9.0, no problem there. Clean and pretty easy. I have been using windows forever so i have no idea how to navigate through my system, nor do i remotely understand the file structure. Ok thats not the issue though HAHA.

I want to get my wireless card up and running. I have a Dlink 520+. Ofcourse Dlink doesn't make a driver for linux. SO i went to a website which i came across via a google newsgroup search. "linux-wlan.org/" (I dunno if i'm allowed to post links, so i apologize ahead of time if i'm not allowed to)

So i downloaded the newest file, and then brought it to my linux box which i had just installed 30 mins ago. I figured out how to mount the floppy. I can finally see the files.

But i have no clue what to do to them, there is no executable akin to windows. So i am stuck at this point trying to get my box on the network and jump on the internet.

I know its alot to ask, but i would really appreciate timely help on what i should do next to install these drivers so i can get up and running.


Thanks in advance ,
EDU
edu

Last edited by illkunundrum; 09-15-2003 at 08:14 PM.
 
Old 09-15-2003, 08:15 PM   #2
TheOneAndOnlySM
Member
 
Registered: Jul 2003
Location: Dallas, TX
Distribution: Ubuntu 10.04 LTS
Posts: 987

Rep: Reputation: 30
what is the name of the file? is it an rpm or was it a tar.gz or .tgz or whatever?

once u unzip them, is there a readme or an install file readme? if so read them and see if u can somewhat understand them; come back here and tell us if u see a config file and/or a Make file
 
Old 09-15-2003, 08:26 PM   #3
illkunundrum
LQ Newbie
 
Registered: Sep 2003
Posts: 14

Original Poster
Rep: Reputation: 0
the file was "linux-wlan-ng-0.2.1-pre12tar.gz

i copied it over to what i am gonna presume is also called "the desktop" on linux. I extracted the files and the folder now resides on my desktop.

There is a "config.a" file as well as a "makefile" this icon has a screwdriver picture.

I went throught the faq, ut told me to run "make config" but i cant seem to find the file. After that it is supposed to come up with some y/n question like a wizard i suppose. Problem is "make config" is no where to be seen.
 
Old 09-15-2003, 09:07 PM   #4
illkunundrum
LQ Newbie
 
Registered: Sep 2003
Posts: 14

Original Poster
Rep: Reputation: 0
i am so lost. If anyone could help a dude out, i'd be greatly thankful.
 
Old 09-15-2003, 09:21 PM   #5
twilli227
Member
 
Registered: May 2003
Location: S.W. Ohio
Distribution: Ubuntu, OS X
Posts: 760

Rep: Reputation: 30
When you extracted the package, are both tar.gz gone from the end of the package? If so:
#cd newdir(where newdir is where the package is located)
Look for a file called INSTALL or README. Either one should give you info on installing it.
Hope this helps
 
Old 09-15-2003, 09:46 PM   #6
Gates1026
Member
 
Registered: Sep 2003
Location: Iowa
Distribution: Slackware 9.1
Posts: 155

Rep: Reputation: 30
Try this, it should work.............

I think it is much easier to use the terminal to do this

When you download the file from the internet, put it in your /home/<username>/ directory. From there you probably need to su to root
# su
Password: <type your password>

This will make you the superuser so you can do anything you want. From here type the command mv linux-wlan-ng-0.2.1-pre12tar.gz /usr/local/src (a good standard for where you should put your compiled from source packages). From /usr/local/src type exit to go back to your normal user. You should now have a $ instead of a #.

You can do this in one step or two. (if these dont work you might have to su again)
tar -xzvf linux-wlan-ng-0.2.1-pre12tar.gz

or you can do

gunzip linux-wlan-ng-0.2.1-pre12tar.gz and then
tar -xvf linux-wlan-ng-0.2.1-pre12tar.gz
either way you should get a directory called linux-wlan-ng-0.2.1-pre12. change to that directory with the cd linux-wlan-ng-0.2.1-pre12 command. From here you need to vim the README file to see specific instructions. Most compiled programs follow the format of
./configure
make
make install
but these can be different for every application you are compiling.
Let me know if this gets you where you need to go
 
Old 09-15-2003, 10:55 PM   #7
illkunundrum
LQ Newbie
 
Registered: Sep 2003
Posts: 14

Original Poster
Rep: Reputation: 0
thanks for your responses i had no idea that there was a terminal window lol. ok i got somewhere but not anything really got done. I went to the terminal and the folder in which the files where, via the cd command. Anyway i typed in "make config" and i got what i had expected to get, a few questions about the driver i want to install. Then i got this...

"Linux source directory [/usr/src/linux]:"

then i got this...

"Linux source tree /usr/src/Linux is incomplete or missing!"
"See the HOWTO for a list of FTP sites for current kernel sources"

any ideas?

Last edited by illkunundrum; 09-15-2003 at 11:42 PM.
 
Old 09-15-2003, 11:28 PM   #8
illkunundrum
LQ Newbie
 
Registered: Sep 2003
Posts: 14

Original Poster
Rep: Reputation: 0
so i followed the "/usr/src", but there is no "Linux" folder?!?
 
Old 09-16-2003, 01:59 AM   #9
Haiyadragon
Member
 
Registered: Sep 2003
Location: Gorredijk, Netherlands
Distribution: Arch Linux
Posts: 400

Rep: Reputation: 30
I'm also a newbie but I think you should install the kernel source. You can install it from your distr. cd's. It think it's on the third cd.
 
Old 09-16-2003, 03:11 PM   #10
illkunundrum
LQ Newbie
 
Registered: Sep 2003
Posts: 14

Original Poster
Rep: Reputation: 0
BINGO BANGO!!!

The box is surfing now!! YAYY FOR ME..
next issue lol

Ok i got my linux box (redhat 9.0) to get on the web. Don't ask how it just is. Question is i can't seem to find it on my router. That is the Linux box doesn't seem to show up on my router. I know that the box is using my wireless router since there isn't any other nearby and that the IP seen from the outside world is the IP given to my router. Its able to get online but is not showing itself to my router, i know i know security is no good then, but i really need to see my linux box so i can close things up.

How do i check my internal ip on my linux box?

THANKS!
 
Old 09-16-2003, 05:37 PM   #11
Gates1026
Member
 
Registered: Sep 2003
Location: Iowa
Distribution: Slackware 9.1
Posts: 155

Rep: Reputation: 30
to show your IP address on a linux machine, use the command line again i.e.terminal window. If you have /sbin in your PATH variable in /home/<yourusername>/.bash_profile then you can just type ifconfig. If not then use the full path /sbin/ifconfig
When you execute the command, you are looking for eth0. Inside all of the info that is given you want to look up inet addr:x.x.x.x (where x.x.x.x is your inside IP address). You dont need to pay attention to the lo header and its info. It is set for the loopback address......so your IP is NOT 127.0.0.1 (not sure how knowledgeable you are, so I am not trying to make you feel stupid

Does this help at all????
 
Old 09-16-2003, 08:03 PM   #12
illkunundrum
LQ Newbie
 
Registered: Sep 2003
Posts: 14

Original Poster
Rep: Reputation: 0
I can see the my ip on the machine. Don't worry about me being dumb lol, i am super newbie at this. Never touched linux till yesterday. I'm a linux tard.

Ok i got my ip, i know which it is. Issue is that my router (dlink di 614+) doesn't see it. Its strange, i even turned of all the firewall options in the linux box, thought that might interfere some how. Still no go. My router just cannot see it. It does however see the 3 other xp systems.

Also if this is of any importance. I don't think Linux knows its on the net. RHN (redhat network) cannot see the net. I checked under the hardware browser and my wireless pci card is not listed. I can use mozilla to get on though. I don't know if linux has some sort of little icon such as windows that pops up by the clock when there is internet access. Cause if it does its not there. Is there something i have to do to "register" the hardware? Then can my router see the linux box?

lol lots to learn. I am even thinking of switching over to mandrake cause i keep reading that its more newbie friendly.

Any help on this invisible ip would be appreciated
 
Old 09-17-2003, 12:30 PM   #13
illkunundrum
LQ Newbie
 
Registered: Sep 2003
Posts: 14

Original Poster
Rep: Reputation: 0
anyone ever experience this invisible ip? i need some help over here
 
Old 09-17-2003, 05:01 PM   #14
Gates1026
Member
 
Registered: Sep 2003
Location: Iowa
Distribution: Slackware 9.1
Posts: 155

Rep: Reputation: 30
Does your router use DHCP or do you have a static IP address setup on your home network? Can you list the contents of the ifconfig command? It would be easier to tell what is all going on. The link monitor that you are refering to in windows is in Linux in the form of an applet. If you are using RedHat 9.0 you can right click on an unused part of the taskbar and select "add to pannel". From there go to internet and then wireless monitor. I dont know how this all works, b/c I dont have wireless internet.

Did you setup a static IP on your linux machine or did you use DCHP when you set it up?
 
Old 09-18-2003, 08:22 PM   #15
illkunundrum
LQ Newbie
 
Registered: Sep 2003
Posts: 14

Original Poster
Rep: Reputation: 0
My router is dhcp enabled, its handing out ip's to all my systems. The linux box however is assigned an ip i setup myself. I don't know how to let linux request an ip from the router.

this is the result from running ifconfig:
------------------------------------------------
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1153 errors:0 dropped:0 overruns:0 frame:0
TX packets:1153 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:78230 (76.3 Kb) TX bytes:78230 (76.3 Kb)

wlan0 Link encap:Ethernet HWaddr 00:40:05:BB:DF:0C
inet addr:192.168.0.5 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:576 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:9 Base address:0xef40

----------------------------------------------------

this is the file i run to start the wireless pci card: (i type in <./start_net> in the appropriate directory)

-----------------------------------------------------
#!/bin/sh
DEV=wlan0
IP=192.168.0.5
NETMASK=255.255.255.0
GATEWAY=192.168.0.9
ESSID=default
echo Default rate configured as 11Mbps to not cause connection problems with non-22Mbps hardware...
RATE=11M
#CHAN=10
#commented since too many people had too many problems with
#TXPOWER=18
MODE=managed
DEBUG=0x9b

# for better debugging
set -x
#echo 8 > /proc/sys/kernel/printk

# just in case ;)
sync
sleep 1

insmod ../src/acx100_pci.o debug=$DEBUG firmware_dir=../firmware

if [ -n "$RATE" ]; then
echo Setting rate to $RATE.
iwconfig $DEV rate $RATE
fi
if [ -n "$CHAN" ]; then
echo Setting channel $CHAN.
iwconfig $DEV channel $CHAN
fi
if [ -n "$TXPOWER" ]; then
echo Setting Tx power level to $TXPOWER dBm.
iwconfig $DEV txpower $TXPOWER
sleep 1
fi
echo Trying to join or setup ESSID $ESSID.
iwconfig $DEV essid $ESSID
if [ -n "$MODE" ]; then
echo Setting mode to $MODE.
iwconfig $DEV mode $MODE
fi

# Hehe, this can be done after iwconfigs now :)
ifconfig $DEV $IP netmask $NETMASK

route add default gw $GATEWAY

# Finally, let's do some tweaking to make sure we don't have any
# buffer management problems (yeah, it's an ugly workaround!)
ifconfig $DEV mtu 576

# # fetch an IP address from DHCP
# rm -f /etc/dhcpc/dhcpcd-wlan0.pid > /dev/null
# dhcpcd -d wlan0 -t 5

# just in case ;)
sync
-------------------------------------------------------------------

thats most of the info i think.

I did do that right click on the taskbar and get the little wlan monitor, thanks for that. It shows up so apparently it does know its connected. Just my router doesn't show it.

Last edited by illkunundrum; 09-18-2003 at 08:24 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Complete Newbie to Linux Archaic MEPIS 13 07-03-2005 03:42 PM
complete newbie karmologyclinic Linux - Hardware 1 04-02-2005 05:36 PM
Complete Newbie reset Linux - Newbie 15 08-31-2003 03:21 PM
Complete newbie dat_chibi Linux - Newbie 5 12-01-2002 01:50 PM
Help Please..complete newbie. scoops98 Linux - Software 7 11-27-2001 05:36 AM


All times are GMT -5. The time now is 10:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration