LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-31-2012, 02:46 PM   #1
sam1icdr
LQ Newbie
 
Registered: Jun 2012
Location: Mandalay, Myanmar
Distribution: Debian, Fedora
Posts: 3

Rep: Reputation: Disabled
Compiz, Debian ...


hi
my device is asus ul80vt with nvidia g210m cuda.
and yesterday, i changed my os from fedora17 to debian6(stable)
i tried to install compiz on debian6.0.6 gnome2.3, so i use
Code:
sudo apt-get install compiz compizconfig-settings-manager compiz-fusion-plugins-main compiz-gnome compiz-gtk
+
Code:
sudo apt-get -f install
to install compiz
after that, i can access to compizconfig-settings-manager. but i can't use any of the settings. they are not working. Does it mean my graphic driver is not working ? how can i get compiz work ?

i had installed compiz on fedora15 once before without nvidia driver installed. it worked fine.
i noticed in fedora the file "/etc/X11/xorg.conf" file makes me trouble whenever it exist.
when i update the some drivers (virtualbox), i created a xorg.conf file. and my system won't boot up. so i used to rename it to whatever with textmode.
 
Old 10-31-2012, 07:06 PM   #2
Fred Caro
Member
 
Registered: May 2007
Posts: 999

Rep: Reputation: 166Reputation: 166
sam,
you seem to try to install packages and configure them at the same time. If you still have the cli working perhaps try " apt-get remove compiz" or "apt-get purge compiz" then just "apt-get install compiz", paying attention to what is suggested or recommened on the cli. Debian is hard to break.

Fred.
 
Old 10-31-2012, 11:16 PM   #3
sam1icdr
LQ Newbie
 
Registered: Jun 2012
Location: Mandalay, Myanmar
Distribution: Debian, Fedora
Posts: 3

Original Poster
Rep: Reputation: Disabled
hi Caro, thankz for your reply.
actually i used above command to install compiz. And they are not working.
so i thought it will work when i installed nvidia driver. i found a script on http://www.unixmen.com/script-to-ins...ith-one-click/
what a lazy of me. i copied the codes without watching them carefully and saved into .sh file and run it.
after reboot my screen is blank and a cursor at the top left of the screen and blinking.

I don't know what is happening. I can't even move to (Ctrl+Alt+F2,....)
Finally i could only use f17 bootable dvd to boot in and rename xorg.conf file.

I know know why system wont boot up when there is xorg.conf configuration file.
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildd@barber)  Sun Jun 13 12:08:56 UTC 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
And reboot the system and it is back again.


So what are your recommendations to install and configure compiz on Debian6.0.6 with or without nvidia driver.
 
Old 11-01-2012, 12:40 AM   #4
Randicus Draco Albus
Senior Member
 
Registered: May 2011
Location: Hiding somewhere on planet Earth.
Distribution: OpenBSD
Posts: 1,644
Blog Entries: 8

Rep: Reputation: 577Reputation: 577Reputation: 577Reputation: 577Reputation: 577Reputation: 577
Quote:
So what are your recommendations to install and configure compiz on Debian6.0.6 with or without nvidia driver.
The nvidia driver and Compiz are different issues. If the driver requires firmware, you will need to install it.
http://www.debian.org/releases/stabl...h06s04.html.en
As for Compiz, just install it with apt-get. I do not remember exactly which of these I installed separately, but my Compiz installation includes:
compiz
compiz-plugins
libcompizconfig0
compizconfig-settings-manager
compiz-gnome
compiz-core
python-compizconfig
libdecoration0
compiz-gtk

I have the Gnome and GTK packages in order to use GTK icons.
It should be a simple matter of install and it's ready to go. If your video card is a problem, that needs to be taken care of separately.
 
Old 11-01-2012, 04:59 AM   #5
sam1icdr
LQ Newbie
 
Registered: Jun 2012
Location: Mandalay, Myanmar
Distribution: Debian, Fedora
Posts: 3

Original Poster
Rep: Reputation: Disabled
think u Draco Albus.
so my problem will be graphic driver.
thanks for your link
I'll try to install driver.
yes.installing compiz has no problems though.
.....
 
Old 11-01-2012, 06:23 AM   #6
cmgeo
LQ Newbie
 
Registered: Oct 2011
Location: India
Distribution: Win 7, Debian Squees, Slackware
Posts: 26

Rep: Reputation: Disabled
Hello

I too wanted to run compiz on my system with Nvidia graphic chipset but couldn't. after i installed the nvidia drivers for debian on my system it worked.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Trying to get compiz and emerald to work in debian 6 timmybobo Linux - Newbie 3 11-14-2011 07:07 PM
Compiz on Debian Squeeze ZebraIzToronto Debian 3 12-19-2010 06:22 AM
Compiz on Debian Tommo Linux - Software 1 08-01-2007 03:52 PM
Is Compiz Available For Debian? carlosinfl Debian 16 06-28-2007 12:02 PM


All times are GMT -5. The time now is 11:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration