LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-26-2006, 10:51 AM   #1
Michael_aust
Member
 
Registered: Aug 2005
Location: Lancashire (United Kingdom)
Distribution: Debian Etch, on 686 machine.
Posts: 509

Rep: Reputation: 31
compiling metabar for kde 3.5 debian problem


I downloaded thr source for metabar because I couldnt find a working Deb for it. I ran the configuration script and it said it could not find the xserver files it needed so i installed xorg-dev now when running configure again i get the following error at the end;

checking for libXext... no
configure: error: We need a working libXext to proceed. Since configure
can't find it itself, we stop here assuming that make wouldn't find
them either.

I have installed all the libXext file I can find from the debian etch repos but I still get the message. Could someone explain what its asking for. I also tried with:

./configure --with-libXext-dir=/usr/X11R6/include/X11/extensions/

and various other directories I could see that libXext had installed file but it still fails.

Any ideas

This is the first time I have tried compiling anything and was assuming this would not be the most complicated of things.

Thanks in advance

Michael
 
Old 04-26-2006, 11:10 AM   #2
Michael_aust
Member
 
Registered: Aug 2005
Location: Lancashire (United Kingdom)
Distribution: Debian Etch, on 686 machine.
Posts: 509

Original Poster
Rep: Reputation: 31
ok i got the above problem sorted out now im getting the following error:

checking for libz... configure: error: not found.
Possibly configure picks up an outdated version
installed by XFree86. Remove it from your system.

Check your installation and look into config.log

I looked in synaptic but I dont have any packages of that name installed.

Any ideas?
 
Old 04-26-2006, 11:55 AM   #3
Michael_aust
Member
 
Registered: Aug 2005
Location: Lancashire (United Kingdom)
Distribution: Debian Etch, on 686 machine.
Posts: 509

Original Poster
Rep: Reputation: 31
scratch the bits above I finally got past the configure stage and make finish. Now im having problems with chekinstall, im wanting to make a deb out of the makefile. And checkinstall does the correct? I have installed checkinstall and its dependences, i puleld checkinstall from the debian packages site and then installed installwatch from testing.

when i type in checkinstall i get the following message:


debian:/home/house/Desktop/metabar# checkinstall

checkinstall 1.5.3, Copyright 2001 Felipe Eduardo Sanchez Diaz Duran
This software is released under the GNU GPL.

The package documentation directory ./doc-pak does not exist.
Should I create a default set of package docs? [y]: n

Installing with "make install"...

========================= Installation results ===========================
ERROR: ld.so: object '/usr/lib/installwatch.so' from LD_PRELOAD cannot be preloa
ded: ignored.
ERROR: ld.so: object '/usr/lib/installwatch.so' from LD_PRELOAD cannot be preloa
ded: ignored.
ERROR: ld.so: object '/usr/lib/installwatch.so' from LD_PRELOAD cannot be preloa ded: ignored.
Making install in src
make[1]: Entering directory `/home/house/Desktop/metabar/src'
make[2]: Entering directory `/home/house/Desktop/metabar/src'
/bin/sh ../admin/mkinstalldirs /usr/lib/kde3
/bin/sh ../libtool --silent --mode=install /usr/bin/install -c -p konqsidebar_ metabar.la /usr/lib/kde3/konqsidebar_metabar.la
../libtool: line 5849: 31751 Segmentation fault /usr/bin/install -c -p .lib s/konqsidebar_metabar.so /usr/lib/kde3/konqsidebar_metabar.so
make[2]: *** [install-kde_moduleLTLIBRARIES] Error 139
make[2]: Leaving directory `/home/house/Desktop/metabar/src'
make[1]: *** [install-am] Error 2
make[1]: Leaving directory `/home/house/Desktop/metabar/src'
make: *** [install-recursive] Error 1

**** Installation failed. Aborting package creation.

Cleaning up...OK

Bye.

any ideas what this means and how I can fix it?

Last edited by Michael_aust; 04-26-2006 at 12:05 PM.
 
Old 04-27-2006, 06:29 AM   #4
Michael_aust
Member
 
Registered: Aug 2005
Location: Lancashire (United Kingdom)
Distribution: Debian Etch, on 686 machine.
Posts: 509

Original Poster
Rep: Reputation: 31
i managed to get checkinstall to work. I couldnt get metabar to creat a deb but I made a few debs out of some window decorations and kde styles first time iv ever tried compiling anything
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem compiling KDE apps ssfrstlstnm Linux - Software 1 02-21-2006 05:58 PM
compiling problem of debian kernel 2.6.15 with 2.6.15-mms patch headlie Linux - Laptop and Netbook 0 01-08-2006 03:30 PM
Debian , Problem compiling from source files. v3sS0n Debian 1 11-27-2004 12:37 PM
Compiling KDE Problem AFI_Flame Linux - Software 7 05-26-2004 07:41 PM
problem with compiling kernel 2.6.0 on Debian samxiao Debian 5 12-24-2003 11:02 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration