LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-09-2004, 05:46 PM   #1
MadSkillzMan
Member
 
Registered: Jul 2004
Distribution: SuSE, Mandrake
Posts: 142

Rep: Reputation: 15
Compiling GAIM says i need GLib 2.0, yet i have GLib 2.4


Hey guys. Decided to stop bothering everyone at the OC forums and come here with my linux issues. Im new of corse, i just did a FTP install of SuSE and im really liking it. Ive learned more than i thought i ever would in the way of compiling from source.

I downloaded GAIM source off of their homepage. So it said i read the INSTALL and did the ./configure

Ok fine, but it stops and says i need GLib 2.0 or greater. Tells me the GTK site to get it from. I ALSO hit up YaST2 and downloaded all the Glib and Glibc peices on there.

Well in order to install the GLib i downloaded, which was GLib 2.4, i had to get this PKG package.

So i did the ./configure, then make, then make install, then make clean. NO problems. Did the same for GLib 2.4.

Ok so logic would dictate that GAIM should compile right? NO still stuck at the GLib 2.0 crap.


Any ideas guys?
 
Old 07-09-2004, 05:52 PM   #2
comp12345
Member
 
Registered: Feb 2004
Posts: 467

Rep: Reputation: 30
You need to install the GLib 2.0 development libraries.
 
Old 07-10-2004, 03:18 AM   #3
MadSkillzMan
Member
 
Registered: Jul 2004
Distribution: SuSE, Mandrake
Posts: 142

Original Poster
Rep: Reputation: 15
how does one obtain this?
 
Old 07-10-2004, 05:10 AM   #4
Samsara
Member
 
Registered: May 2003
Distribution: Ubuntu, Mac OS X Tiger
Posts: 481

Rep: Reputation: 32
There should be a package for it that you can select using YaST. Prolly called glib2-devel.

Regards,

Samsara
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 10:12 PM
compiling gaim using custom glib dir Boudewijn Linux - Software 5 11-30-2004 03:53 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 07:07 PM
Compiling GAIM 0.78 on Debian | GLIB 2.0 Errors muzicman82 Linux - Software 0 06-05-2004 06:41 AM
glib 2.0.0 and gaim 0.59 GT I.N.C Linux - Newbie 2 07-10-2002 01:10 AM


All times are GMT -5. The time now is 10:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration