LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 07-26-2002, 05:30 AM   #1
BlackDogg
Member
 
Registered: Jul 2002
Location: Los Angeles
Distribution: RedHat 7.3, SuSe 8.0
Posts: 71

Rep: Reputation: 15
Compiled RH7.3 to read WinXP NTFS partition, mounts in Console, but can't mount fstab


Hi everyone, I was wondering if y'all could help me out with my NTFS mounting troubles in RH7.3

I've recompiled RH7.3 to enable NTFS support Read/Only.
Then I was able to mount through console with this command.

mount -t ntfs /dev/hda5 /mnt

Checked the contents in /mnt folder, files were there, but....

then, I tried to get it to mount in LILO or in KwikDisk to be able to be mounted on the get go by me editing fstab, but it wouldn't work. I kept on getting this error.


Called: mount -tntfs /dev/hda1 /mnt/

mount: mount point /mnt does not exist

My fstab currently looks like this:

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda7 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
/dev/hda5 /mnt/ ntfs


hda5 is my NTFS partiton. I left out the syntax paramters for this last edit on fstab, but i've tried so many different syntaxes in the end, I pretty much get the same darn error everytime. Am I doing something wrong?

It works in console, so it should work in fstab correct?
 
Old 07-26-2002, 05:49 AM   #2
lynch
Member
 
Registered: Nov 2000
Location: A Mid-Atlantic state
Distribution: SuSE 8.1,Knoppix 3.2,Mandrake 9.1
Posts: 388

Rep: Reputation: 30
Probably you need to make a symlink for that or if that /mnt/ntfs is the symlink you could try:
/dev/hda5 /mnt/ntfs auto ro,noauto,user 0 0
lynch
 
Old 07-26-2002, 05:57 AM   #3
BlackDogg
Member
 
Registered: Jul 2002
Location: Los Angeles
Distribution: RedHat 7.3, SuSe 8.0
Posts: 71

Original Poster
Rep: Reputation: 15
lynch, tried that exactly the way you have it typed out. I copied and pasted straight to fstab. Saved it, and still wouldn't mount, same dangit error.
I even edited by spacing out to be even with the rest, and still same problem exists.
/dev/hda5 /mnt/ntfs auto ro,noauto,user 0 0

Thanx for the the help...Any other ideas would be appreciated.
 
Old 07-26-2002, 06:09 AM   #4
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Ok, I think I see what's wrong

You should have made a directory in /mnt whatever you'd like in my example we will use /mnt/windows:
Open a terminal

mkdir /mnt/windows
pico /etc/fstab
(at the bottom)
/dev/hda5 /mnt/windows ntfs ro,noauto,user 0 0
CTRL + X
Yes (to save)
mount -a -o remount

And that should be it I think
 
Old 07-26-2002, 06:16 AM   #5
BlackDogg
Member
 
Registered: Jul 2002
Location: Los Angeles
Distribution: RedHat 7.3, SuSe 8.0
Posts: 71

Original Poster
Rep: Reputation: 15
dang Master C, that worked out. Thanx. I've been messin around with linux for like 4 days, and I'm goin gagga over it, tried it a few years back, but was so intimidated, now though things are lookin brighter. laff.
 
Old 07-26-2002, 06:18 AM   #6
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Yeah me too, I love it. Your welcome, glad I could help
 
Old 07-26-2002, 02:40 PM   #7
BlackDogg
Member
 
Registered: Jul 2002
Location: Los Angeles
Distribution: RedHat 7.3, SuSe 8.0
Posts: 71

Original Poster
Rep: Reputation: 15
Ok I got it all mounted, but I have to click on kwikdisk everytime to mount manually. I know theres a syntax to have it mount manually in boot, what was it? auto in fstab?
 
Old 07-26-2002, 05:45 PM   #8
lynch
Member
 
Registered: Nov 2000
Location: A Mid-Atlantic state
Distribution: SuSE 8.1,Knoppix 3.2,Mandrake 9.1
Posts: 388

Rep: Reputation: 30
Heck,forgot you need to create that /mnt/ntfs directory.Sorry,BlackDogg.
You may be right on that,but I havent done that since I stopped dual booting.Check out the automount mini-howto.
lynch
 
Old 07-26-2002, 06:14 PM   #9
BlackDogg
Member
 
Registered: Jul 2002
Location: Los Angeles
Distribution: RedHat 7.3, SuSe 8.0
Posts: 71

Original Poster
Rep: Reputation: 15
Coo Coo
 
Old 07-26-2002, 10:16 PM   #10
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
If you used this line, that MasterC gave you, as a template:

/dev/hda5 /mnt/windows ntfs ro,noauto,user 0 0

Change the ' noauto ' to ' auto '. Like this:

/dev/hda5 /mnt/windows ntfs ro,auto,user 0 0
 
Old 07-26-2002, 11:06 PM   #11
BlackDogg
Member
 
Registered: Jul 2002
Location: Los Angeles
Distribution: RedHat 7.3, SuSe 8.0
Posts: 71

Original Poster
Rep: Reputation: 15
Duh, should have tried that first, thanx!
 
Old 07-26-2002, 11:16 PM   #12
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
You're welcome.
 
Old 07-29-2002, 05:36 AM   #13
BlackDogg
Member
 
Registered: Jul 2002
Location: Los Angeles
Distribution: RedHat 7.3, SuSe 8.0
Posts: 71

Original Poster
Rep: Reputation: 15
Hello all, once again I've got mount problems and this time it's in SuSe. I tried out Suse, because everyone was telling it has NTFS support of the bat. Some said it was Suse and Mandrake. Well I tried Mandrake and NTFS was there. Now that I've installed Suse, it sees the partiton, but when I try to mount it in kwikdisk, it gives me this error:

D:\drive NTFS XP partition.
Called: mount -tntfs /dev/hde5 /windows/D -o ro,noauto,user,umask=000
mount: mount point /windows/D does not exist

and this for C:\drive

Called: mount -tntfs /dev/hde1 /windows/C -o ro,noauto,user,umask=022
mount: mount point /windows/C does not exist.

I checked in my fstab file and the lines were apparent if they weren't they wouldn't be showing in Kwikdisk. Anyways I tried to console the command and this is what I get

linux:~ # mount -t ntfs /dev/hda5 /mnt
mount: wrong fs type, bad option, bad superblock on /dev/hda5,
or too many mounted file systems
(could this be the IDE device where you in fact use
ide-scsi so that sr0 or sda or so is needed?)

The lines in fstab were automatically generated by suse,

but check this out, when I console this in

nt -t ntfs /dev/hde5 /mnt

then it works, what am I missing here?

I'm sure it has somthing to do with fstab, but I don't understand it if SuSe generates the line itself. Anyways I re-edited the line to this:

/dev/hda5 /mnt/windows ntfs ro,noauto,user 0 0

and it still didn't work. keep in mind that I also created a windows dir just for testing purposes. This is so wierd, I had it working fine in RH7.3 after I had made a moudle for NTFS support, but now it's in Suse, I'm sure this is not distro related. Just a minor error somewhere.

Anyone have ideas? It just seems one little type or syntax can jack everything up.
 
Old 07-29-2002, 06:59 AM   #14
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
Quote:
D:\drive NTFS XP partition.
Called: mount -tntfs /dev/hde5 /windows/D -o ro,noauto,user,umask=000
mount: mount point /windows/D does not exist

and this for C:\drive

Called: mount -tntfs /dev/hde1 /windows/C -o ro,noauto,user,umask=022
mount: mount point /windows/C does not exist.
The errors are telling you that the mount points /windows/C and /windows/D don't exist. If the directories /windows, /C, and /D don't exist, you'll have to create them using mkdir.

Quote:
linux:~ # mount -t ntfs /dev/hda5 /mnt
mount: wrong fs type, bad option, bad superblock on /dev/hda5,
or too many mounted file systems
(could this be the IDE device where you in fact use
ide-scsi so that sr0 or sda or so is needed?)
You used hda5 instead of hde5 as you did above. That could be why it didn't work.

Quote:
The lines in fstab were automatically generated by suse,

but check this out, when I console this in

nt -t ntfs /dev/hde5 /mnt

then it works, what am I missing here?
Here you used hde5 and it worked. So, hde5 must be the correct partition.

Quote:
I'm sure it has somthing to do with fstab, but I don't understand it if SuSe generates the line itself. Anyways I re-edited the line to this:

/dev/hda5 /mnt/windows ntfs ro,noauto,user 0 0

and it still didn't work. keep in mind that I also created a windows dir just for testing purposes. This is so wierd, I had it working fine in RH7.3 after I had made a moudle for NTFS support, but now it's in Suse, I'm sure this is not distro related. Just a minor error somewhere
Try changing the hda5 to hde5.

Last edited by linuxcool; 07-29-2002 at 07:06 AM.
 
Old 07-29-2002, 02:54 PM   #15
BlackDogg
Member
 
Registered: Jul 2002
Location: Los Angeles
Distribution: RedHat 7.3, SuSe 8.0
Posts: 71

Original Poster
Rep: Reputation: 15
linux cool thanx for pointing that out. I've been up all day and night trying to figure this out....it's been a long long night.....I kept on making a directory in /mnt/windows/D, but that still didn't work. Then I realized all those other times most distros put them in /mnt/. When you pointed out my mistake i noticed in pico it's just /windows/D and /windows/C. Then I created the correct directories. SUse just puts creates the mount directories different. By the way I thought suse would create both the directories and the entry in fstab, but it only does the entries and not the directories. Is there a tool in suse 8 that does this for you, instead of manually doing the directories? I'm asking because I want to support Suse in a corporate enviroment, and it would be nice to show other people the simple way to do this one task. Oh yeah, linuxcool, I was like really out of it regarding the hda and hde, I run back and fourth on two different workstations, and the one with suse is on a highpoint interface, and I forgot, but then it was funny when i did the manual mount in console, and didn't realize I was a dumbass for not noticing.....dude what a crazy night/day. Thanx.....shoulda known better.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to mount winxp NTFS partition UltraSoul Solaris / OpenSolaris 4 06-13-2007 10:53 AM
Can I mount an ntfs partition or read one using linux? r_squared Linux - General 8 11-20-2004 01:18 PM
mount two NTFS drives in Redhat 9. One mounts, the other won't ?? drumlinuxuser Linux - Hardware 5 12-01-2003 09:32 PM
How do I mount my NTFS WinXP partition on Linux? adam88 Linux - Software 6 04-18-2003 11:11 AM
seeing my winxp (ntfs) drive from RH7.2 JoC Linux - Newbie 1 01-17-2003 11:24 AM


All times are GMT -5. The time now is 02:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration