LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-15-2005, 09:34 AM   #1
CrimsonSkyZS
LQ Newbie
 
Registered: Mar 2005
Location: USA
Distribution: Fedora Core 4
Posts: 12

Rep: Reputation: 0
Compilation Error with X.org


Hi I am getting these errors when trying to compile the latest cvs of X.org. Anyone have any ideas?

Code:
[root@localhost xc]# tail -30 world.log
XF86VMode.c:1201: error: ‚True‚ undeclared (first use in this function)
XF86VMode.c: At top level:
XF86VMode.c:1204: error: syntax error before ‚XF86VidModeGetPermissions‚
XF86VMode.c:1205: error: syntax error before ‚*‚ token
XF86VMode.c:1209: warning: return type defaults to ‚int‚
XF86VMode.c:1209: warning: function declaration isn‚t a prototype
XF86VMode.c: In function ‚XF86VidModeGetPermissions‚:
XF86VMode.c:1214: error: ‚permissions‚ undeclared (first use in this function)
XF86VMode.c:1223: error: ‚xReply‚ undeclared (first use in this function)
XF86VMode.c:1223: error: syntax error before ‚)‚ token
XF86VMode.c:1223: error: ‚xTrue‚ undeclared (first use in this function)
XF86VMode.c:1231: error: ‚True‚ undeclared (first use in this function)
{standard input}: Assembler messages:
{standard input}:125: Error: symbol `y' is already defined
{standard input}:143: Error: symbol `protocolBug' is already defined
{standard input}:149: Error: symbol `oldreq' is already defined
{standard input}:155: Error: symbol `oldreq' is already defined
{standard input}:161: Error: symbol `oldreq' is already defined
{standard input}:167: Error: symbol `oldreq' is already defined
{standard input}:191: Error: symbol `protocolBug' is already defined
{standard input}:203: Error: symbol `dotclock' is already defined
make[4]: *** [XF86VMode.o] Error 1
make[4]: Leaving directory `/root/xc/lib/Xxf86vm'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/root/xc/lib'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/root/xc'
make[1]: *** [World] Error 2
make[1]: Leaving directory `/root/xc'
make: *** [World] Error 2
[root@localhost xc]# grep '\*\*\*' world.log
make[4]: *** [XF86VMode.o] Error 1
make[3]: *** [all] Error 2
make[2]: *** [all] Error 2
make[1]: *** [World] Error 2
make: *** [World] Error 2
 
Old 12-15-2005, 11:26 AM   #2
mr_demilord
Member
 
Registered: Sep 2005
Posts: 244

Rep: Reputation: 30
Do you compile it in a separate build directory?
 
Old 12-15-2005, 01:28 PM   #3
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 52
we need the very first hint of things going south
xorg needs a config file config/cf/host.def to compile even though they say it doesn't
and you need to use at least
#define HasFreetype2 YES
#define HasFontconfig YES
the versions provided by xorg won't compile
 
Old 12-15-2005, 04:30 PM   #4
CrimsonSkyZS
LQ Newbie
 
Registered: Mar 2005
Location: USA
Distribution: Fedora Core 4
Posts: 12

Original Poster
Rep: Reputation: 0
My goal is to get hardware acceration to work on this computer. Getting the GLU Libraries and such installed (I using a GeForce 2 MX) I am following the guides on Mesa3d.org and the DRI Building Wiki and I issued this command 'make World >& world.log &' so it outputs to the world.log file. I have 3 dirs: xc (xorg cvs), drm (the cvs dri drivers), and Mesa (the cvs mesa). I also downloaded a host.def and placed it 'config/cf/host.def.' I also just added those 2 lines foo_bar said. As far as the hint of where things started throwing errors I think can be contributed to this:

Code:
rm -f XF86VMode.o
gcc -m32 -c -O2 -gstabs+ -pipe  -ansi -Wall -Wpointer-arith -Wstrict-prototypes 			  -Wmissing-prototypes -Wmissing-declarations 			  -Wredundant-decls -Wnested-externs -Wundef    -I../.. -I../../exports/include -I/usr/X11R6/include  -Dlinux -D__i386__ -D_POSIX_C_SOURCE=199309L 				-D_POSIX_SOURCE -D_XOPEN_SOURCE 				-D_BSD_SOURCE -D_SVID_SOURCE                                 -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 				 -D_GNU_SOURCE 				  -DFUNCPROTO=15 -DNARROWPROTO -DXTHREADS  -D_REENTRANT -DXUSE_MTSAFE_API    -DMALLOC_0_RETURNS_NULL     -fPIC XF86VMode.c
XF86VMode.c:38:25: error: X11/Xlibint.h: No such file or directory
In file included from ../../exports/include/X11/extensions/xf86vmstr.h:38,
                 from XF86VMode.c:39:
../../exports/include/X11/extensions/xf86vmode.h:151: error: syntax error before ‘Bool’
../../exports/include/X11/extensions/xf86vmode.h:151: warning: no semicolon at end of struct or union
../../exports/include/X11/extensions/xf86vmode.h:152: warning: type defaults to ‘int’ in declaration of ‘display’
../../exports/include/X11/extensions/xf86vmode.h:152: warning: data definition has no type or storage class
../../exports/include/X11/extensions/xf86vmode.h:153: error: syntax error before ‘root’
../../exports/include/X11/extensions/xf86vmode.h:153: warning: type defaults to ‘int’ in declaration of ‘root’
../../exports/include/X11/extensions/xf86vmode.h:153: warning: data definition has no type or storage class
../../exports/include/X11/extensions/xf86vmode.h:156: error: syntax error before ‘forced’
../../exports/include/X11/extensions/xf86vmode.h:156: warning: type defaults to ‘int’ in declaration of ‘forced’
../../exports/include/X11/extensions/xf86vmode.h:156: warning: data definition has no type or storage class
../../exports/include/X11/extensions/xf86vmode.h:157: error: syntax error before ‘time’
../../exports/include/X11/extensions/xf86vmode.h:157: warning: type defaults to ‘int’ in declaration of ‘time’
../../exports/include/X11/extensions/xf86vmode.h:157: warning: data definition has no type or storage class
../../exports/include/X11/extensions/xf86vmode.h:158: warning: type defaults to ‘int’ in declaration of ‘XF86VidModeNotifyEvent’
../../exports/include/X11/extensions/xf86vmode.h:158: warning: data definition has no type or storage class
../../exports/include/X11/extensions/xf86vmode.h:174: error: syntax error before ‘XF86VidModeQueryVersion’
../../exports/include/X11/extensions/xf86vmode.h:175: error: syntax error before ‘*’ token
../../exports/include/X11/extensions/xf86vmode.h:178: warning: type defaults to ‘int’ in declaration of ‘XF86VidModeQueryVersion’
../../exports/include/X11/extensions/xf86vmode.h:178: warning: function declaration isn’t a prototype
../../exports/include/X11/extensions/xf86vmode.h:178: warning: data definition has no type or storage class
../../exports/include/X11/extensions/xf86vmode.h:180: error: syntax error before ‘XF86VidModeQueryExtension’
../../exports/include/X11/extensions/xf86vmode.h:181: error: syntax error before ‘*’ token
../../exports/include/X11/extensions/xf86vmode.h:184: warning: type defaults to ‘int’ in declaration of ‘XF86VidModeQueryExtension’
../../exports/include/X11/extensions/xf86vmode.h:184: warning: function declaration isn’t a prototype
../../exports/include/X11/extensions/xf86vmode.h:184: warning: data definition has no type or storage class
../../exports/include/X11/extensions/xf86vmode.h:186: error: syntax error before ‘XF86VidModeSetClientVersion’
../../exports/include/X11/extensions/xf86vmode.h:187: error: syntax error before ‘*’ token
../../exports/include/X11/extensions/xf86vmode.h:188: warning: type defaults to ‘int’ in declaration of ‘XF86VidModeSetClientVersion’
../../exports/include/X11/extensions/xf86vmode.h:188: warning: function declaration isn’t a prototype
../../exports/include/X11/extensions/xf86vmode.h:188: warning: data definition has no type or storage class
../../exports/include/X11/extensions/xf86vmode.h:190: error: syntax error before ‘XF86VidModeGetModeLine’
../../exports/include/X11/extensions/xf86vmode.h:191: error: syntax error before ‘*’ token
../../exports/include/X11/extensions/xf86vmode.h:195: warning: type defaults to ‘int’ in declaration of ‘XF86VidModeGetModeLine’
../../exports/include/X11/extensions/xf86vmode.h:195: warning: function declaration isn’t a prototype
../../exports/include/X11/extensions/xf86vmode.h:195: warning: data definition has no type or storage class
../../exports/include/X11/extensions/xf86vmode.h:197: error: syntax error before ‘XF86VidModeGetAllModeLines’
../../exports/include/X11/extensions/xf86vmode.h:198: error: syntax error before ‘*’ token
../../exports/include/X11/extensions/xf86vmode.h:202: warning: type defaults to ‘int’ in declaration of ‘XF86VidModeGetAllModeLines’
../../exports/include/X11/extensions/xf86vmode.h:202: warning: function declaration isn’t a prototype
../../exports/include/X11/extensions/xf86vmode.h:202: warning: data definition has no type or storage class
../../exports/include/X11/extensions/xf86vmode.h:204: error: syntax error before ‘XF86VidModeAddModeLine’
../../exports/include/X11/extensions/xf86vmode.h:205: error: syntax error before ‘*’ token
../../exports/include/X11/extensions/xf86vmode.h:209: warning: type defaults to ‘int’ in declaration of ‘XF86VidModeAddModeLine’
My host.def file:
Code:
#define XFree86CustomVersion "Minimal DRI build from X.org tree"

/* Compiler options */
#define DefaultGcc2i386Opt -O2 -gstabs+ -pipe

/* DDX drivers to build: trim this list to your needs */
#define XF86CardDrivers tdfx i810 mga ati glint vga sis savage via

/* DRI drivers are built from Mesa CVS */
#define DriDrivers /**/
#define DevelDRIDrivers /**/

/* Build development (insecure) DRI-aware 2D drivers */
#define BuildDevelDRIDrivers YES

/* Only shared libGL */
#define NormalLibGlx NO

/* Link the drivers against static libexpat to make binary snapshots
 * more usable and to reduce build problems on Linux machines without
 * expat.
 */
#if defined(LinuxArchitecture) && !defined(AMD64Architecture)
# define ExpatLibrary		StaticLibrary($(BUILDLIBDIR),expat)
# define NormalLibExpat 	YES
#endif

/* Optionally turn these on for debugging */
/* #define GlxBuiltInTdfx YES */
/* #define GlxBuiltInI810 YES */
/* #define GlxBuiltInMga YES */
/* #define GlxBuiltInR128 YES */
/* #define GlxBuiltInRadeon YES */
#define DoLoadableServer YES

/* Optionally turn this on to change the place where you install the build.
 * Warning: trailing blanks will cause build failures.
 */
/* #define ProjectRoot /usr/X11R6-XORG */

/* Don't install anything outside the ProjectRoot directory */
#define NothingOutsideProjectRoot YES

/* #define UsrLibDir /usr/X11R6/lib */

/* Optionally build the Xnest, Xvfb and Xdmx servers */
#define XnestServer NO
#define XVirtualFramebufferServer NO
#define BuildDmx NO

/*
 * Build as little as possible (usually no need to change anthing here)
 */
#define BuildServersOnly YES
#define BuildLibraries NO
#define BuildLibrariesForXServers NO
#define BuildLibrariesForConfigTools NO
#define BuildXIE NO
#define BuildPexExt NO
#define XF86AFB NO
#define XprtServer NO
#define BuildXprint NO
/* HasFontconfig avoids installing a new libfontconfig with its own
 * configuration files. This way you keep your font configuration without
 * copying configuration files around after make install. */
#define HasFontconfig YES

/*
 * Don't change anything below or the build will fail.
 */
#define BuildXF86DRI YES
#define BuildXDriInfo YES
#define BuildGLXLibrary YES
#define BuildXdmcpLib YES
#define BuildXInputLib YES
#define BuildXvLibrary YES
#define BuildXF86VidModeLibrary YES
#define BuildXvMCLibrary YES
#define BuildExpatLibrary YES
#define SharedLibFont NO
#define HasFreetype2 YES  <-added these
#define HasFontconfig YES  <-added these
#if DoLoadableServer
#undef XF1Bpp
#undef XF4Bpp
#define XF1Bpp NO
#define XF4Bpp NO
#endif
 
Old 12-15-2005, 05:44 PM   #5
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 52
hmmmmmmm
check that the file Xlibint.h is there in xc/lib/X11

i don't know how the wiki says do it but try

Starting from the xc directory
pushd config/util
make -f Makefile.ini lndir
as root
cp -v lndir /usr/bin/
as regular user
popd
mkdir ../xcbuild
cd ../xcbuild
lndir ../xc
now do your make world

if there is something screwed up in the cvs you might have to mess around with links to that include Xlibint.h
it kind of looks like it's looking for it in xc/lib/Xxf86vm/X11
might try
ln -s ./lib/X11/Xlibint.h ./lib/Xxf86vm/X11/Xlibint.h
or something to that efect
 
Old 12-15-2005, 10:47 PM   #6
CrimsonSkyZS
LQ Newbie
 
Registered: Mar 2005
Location: USA
Distribution: Fedora Core 4
Posts: 12

Original Poster
Rep: Reputation: 0
/root/xcbuild/lib/X11/Xlibint.h
/root/xc/lib/X11/Xlibint.h

the file is there. And now my xserver wont start, and I am not exactly sure why, because I've done more things in the past couple days and have forgotten how to back track so I need to fix this. I performed those commands I did them as root, I couldn't exactly figure out how to do them as regular user, and I don't really understand your last part. I guess it's back to google.com.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel compilation error: Error 15: File not found Niceman2005 Linux - General 9 10-04-2007 04:45 AM
Compilation error elgitaro Programming 1 03-15-2005 12:50 AM
Error during Compilation vipinsharma Programming 0 05-20-2004 11:40 AM
Sqwebmail compilation error ... [maildirsearchC.o] Error 1 boogie_maan Linux - Software 0 10-26-2002 08:21 PM
compilation error guppy Linux - Newbie 1 06-15-2001 04:41 AM


All times are GMT -5. The time now is 06:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration