LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-28-2010, 02:51 AM   #1
wieselflink
LQ Newbie
 
Registered: May 2010
Location: schmidhofen, deep south germany
Distribution: Deborah & Ian - Lenny
Posts: 5

Rep: Reputation: 0
Question Compare 2 Debian Installtions - how ?


Hi,

it only a feature, not a bug - really

At my Tower i have connected a Web-Cam and it works fine

At my Notebook i have connected the same Web-Cam and N O T H I N G works.

For me as a beginner the 2 installations seem to be the same, B U T some thing must be different !
And i do not know how to find the diff ? ?

On both is a installation with the same /etc/apt/sources.list file like :


# deb cdrom:[Debian GNU/Linux testing _Squeeze_ - Official Snapshot i386 xfce+lxde-CD Binary-1 20090713-06:23]/ squeeze main
deb cdrom:[Debian GNU/Linux testing _Squeeze_ - Official Snapshot i386 xfce+lxde-CD Binary-1 20090713-06:23]/ squeeze main
deb http://ftp.de.debian.org/debian/ squeeze main
deb http://ftp-stud.fht-esslingen.de/debian/ squeeze main
deb-src http://ftp-stud.fht-esslingen.de/debian/ squeeze main
deb http://security.debian.org/ squeeze/updates main
deb-src http://security.debian.org/ squeeze/updates main
deb http://www.bashterritory.com/pytube/releases/ /

The lsusb command shows on both the same like :

Bus 001 Device 011: ID 04f2:a13d Chicony Electronics Co., Ltd
Bus 001 Device 010: ID 04e8:1623 Samsung Electronics Co., Ltd
Bus 001 Device 005: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

But of course the lsmod command gives very different answres and it is very long, so i will only show for now some things, that i hope that will be helpfull :

Tower :
. . .
usbhid 31568 0
uvcvideo 49308 0
hid 34528 1 usbhid
videodev 31040 1 uvcvideo
snd_usb_audio 72088 0
v4l1_compat 11416 2 uvcvideo,videodev
snd_usb_lib 13528 1 snd_usb_audio
nls_utf8 1488 1
nls_cp437 5320 1
. . . .

Laptop :
. . .
Module Size Used by
usbhid 35904 0
snd_usb_audio 70272 0
hid 33184 1 usbhid
snd_usb_lib 13472 1 snd_usb_audio
ff_memless 4392 1 usbhid
uvcvideo 45800 0
snd_hwdep 6212 1 snd_usb_audio
compat_ioctl32 1312 1 uvcvideo
ipv6 235396 14
nls_utf8 1760 1
nls_cp437 5568 1
vfat 9152 1
fat 40864 1 vfat
nls_base 6820 4 nls_utf8,nls_cp437,vfat,fat
fuse 42908 1
usbvideo 21924 0
loop 12748 0
radio_maestro 6208 0
videodev 27520 3 uvcvideo,usbvideo,radio_maestro
v4l1_compat 12260 2 uvcvideo,videodev
. . .

Thankyou for any ideas that will help to get a function on the laptop
 
Old 05-28-2010, 03:07 AM   #2
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
The notebook and tower installs are likely to be different. How have you been attempting to use the webcam in each case?

Do I understand you that your tower install enabled the webcam out of the box?

I'm guessing that chicony electronics usb device is the webcam.
These seem to use the UVC driver. I see that driver and v4l and the rest are in both machines - but that you have a device (radio-maestro) using videodev on the laptop that the tower does not have. What is this?

Also look for clues in dmesg.

Last edited by Simon Bridge; 05-28-2010 at 03:11 AM.
 
Old 05-29-2010, 02:57 PM   #3
wieselflink
LQ Newbie
 
Registered: May 2010
Location: schmidhofen, deep south germany
Distribution: Deborah & Ian - Lenny
Posts: 5

Original Poster
Rep: Reputation: 0
Question webcam works at tower - but NOT at teh laptop

Dear Simon Bridge,

thanks for your answer !

I try to explain a bit better.

1) the laptop is installed some time ago, without needing or having this webcam

2) the tower was installed some time more ago, even without needing or having having a webcam.

3) NOW i was in holiday for two weeks, and the old man is happy now about a girlfriend, a very, very nice one.

4) only saying nice things to my sweetheart, by using the mikro is NOT so nice , having a webcam is much mor nicer, because she see what choke i am doing , an i see her :-)

5) So i asked a friend and he gave me his old webcam, saying -> i do not know if it is working under LINUX, i am a opened window user , but test it, and after that we can speak about the price.

6) So i connected the web-cam first to the tower( I'm guessing that chicony electronics usb device is the webcam. ) - YES - that is the HP Product KQ245AA #ABB, installed cheese and some other apps, and it is working fine at the t o w e r

6) Next day i started my Compaq Armada E500 and connected the web-cam to usb, installed the same appps, like cheese and others, but at my laptop, NOTHING works

If i know the difference between the two installations, maybe i can copy the needed files manually, but first i MUST know, WHAT is different !

So thatīs my question, or if you have a better idea, so please eyplain me - thanks in advance
 
Old 05-30-2010, 02:30 AM   #4
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Quote:
Originally Posted by weiselflink
If i know the difference between the two installations, maybe i can copy the needed files manually, but first i MUST know, WHAT is different !
Well I told you the difference I could see:
Quote:
Originally Posted by Me
you have a device (radio-maestro) using videodev on the laptop that the tower does not have
So what is this thing and why does it want the video driver?
Are you using the correct HW in the webcam software settings? (Imagine you had two cameras plugged in at once - how would your software know which one you want to use?)
 
Old 06-01-2010, 12:02 AM   #5
wieselflink
LQ Newbie
 
Registered: May 2010
Location: schmidhofen, deep south germany
Distribution: Deborah & Ian - Lenny
Posts: 5

Original Poster
Rep: Reputation: 0
Lightbulb

Hallo Simon Bridge,

thanks for your answer and let me say this :

1) I have only O N E webcam, N O T two
2) First i plugged into the tower
3) Second after unplugging from the tower, i plugged into the laptop !

After asking some others, maybe this is a idea for getting a solution :

If i plug in something new, hal / dev or something else will recognize the new hardware - lsusb shows me on BOTH computers that there is something new - isnīt it ?

Next step to use this thing, in this case the web-cam, some modules must be loaded - right ?

So if there is a description stored in a file on my computer like - if this kind of new hardware is plugged in, load this module and that module and another one, maybe a fourth one and at least maybe a fifth one, isnīt it ?

If i know the name, or you tell me the name of that file, i can compare this both files, maybe there is a difference, or i can write into this file something like :

IF this kind of web-cam is plugged in :
LOAD first this module, second this module, third this module, fourth this module and so on. . . . . . .

Can you tell me please the name and location of this file where this description is into ?

Better idea ?

thanxs
 
Old 06-01-2010, 10:03 AM   #6
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Quote:
1) I have only O N E webcam, N O T two
I got that thanks :frown: however:

... according to your loaded modules, your tower box has only the webcam using the video subsystem. Your laptop has the webcam and another device. This is what is different.

Your assumptions about how the hardware detection system works is in error - it does not work like that.

Quote:
Better idea ?
Yes. But I need answers to those questions.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to compare a value p_raju Linux - General 6 05-31-2008 11:03 AM
Manually downloading base installtions wine help myfokkinnick@yahoo.i Linux - Games 1 05-16-2006 03:10 AM
compare debian w/ fedora scng Debian 2 09-27-2004 08:00 AM
How do Debian 3.0 r1 compare with RedHat Linux 9.0 explorer1979 Debian 3 10-05-2003 02:25 AM
If Compare Slackware and Debian ? nutshell Linux - General 13 06-30-2002 04:35 PM


All times are GMT -5. The time now is 09:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration