LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-18-2009, 10:58 PM   #1
anis_huq
LQ Newbie
 
Registered: Nov 2006
Posts: 29

Rep: Reputation: 0
Commands not working in Red Hat Linux Enterprise 5


Weird things happening,
I wanted to see the drives and used the fdisk -l command (in "su" mode). But it says "Bad Command". Also I remember unix had a command uname -X which also isn't working.

Also Red Hat Linux Enterprise 5 doesn't go into "Suspend" mode?

Whats going on??? Can anyone tell me?

Bye.
 
Old 08-18-2009, 11:02 PM   #2
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Typically, in RedHat systems, you have to take on the root environment to run certain commands without the full path. This is because the PATH environment variable is set differently for root vs. regular users.

In a terminal, enter "su -" to take on root's privileges **and** environment
 
Old 08-18-2009, 11:40 PM   #3
scottro11
Member
 
Registered: Jun 2009
Location: NYC
Posts: 260

Rep: Reputation: 58
I have a little page on this. (It was changed in Fedora, around the time of F10, I think).

http://home.roadrunner.com/~computer...su/rhpath.html
 
Old 08-19-2009, 12:33 AM   #4
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,240

Rep: Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324
Do what Pixellany said, then

fdisk -l

uname -a

here's the Deployment Guide for RHEL 5: http://www.linuxtopia.org/online_boo...ion/index.html ; recommended.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SUID and SGID not working on Red Hat Enterprise Linux ES release 4 Bob Lawson Linux - Security 2 11-28-2008 08:49 AM
LXer: Red Hat to launch Red Hat Enterprise Linux 5 before March LXer Syndicated Linux News 0 12-30-2006 09:03 AM
Login Screen not working. Red Hat Enterprise Linux 3 WS Dan37290 Linux - Enterprise 0 11-03-2006 05:07 PM
auditd and laus not working on Red Hat Enterprise V4 gizzy37 Linux - Enterprise 2 07-25-2005 03:46 PM


All times are GMT -5. The time now is 12:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration