LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-17-2013, 05:24 PM   #1
peterjsmith65
LQ Newbie
 
Registered: Sep 2013
Posts: 1

Rep: Reputation: Disabled
command usermod not found


I want to modify my own primary group so that the second group becomes the first, but when I enter the command usermod -g secondgroup userid I get the message "command usermod not found"
 
Old 09-17-2013, 05:38 PM   #2
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,508

Rep: Reputation: 2102Reputation: 2102Reputation: 2102Reputation: 2102Reputation: 2102Reputation: 2102Reputation: 2102Reputation: 2102Reputation: 2102Reputation: 2102Reputation: 2102
Are you running this command as root? usermod lives in /usr/sbin, a directory reserved for special commands that is usually not included in regular users' PATH.
 
Old 09-18-2013, 03:05 AM   #3
kooru
Senior Member
 
Registered: Sep 2012
Posts: 1,385

Rep: Reputation: 273Reputation: 273Reputation: 273
Hi and welcome to LQ!
As said by suicidaleggroll, probably you're running the command as normal user, instead of root.
 
1 members found this post helpful.
Old 09-18-2013, 04:56 AM   #4
jitendra.sharma
Member
 
Registered: Mar 2013
Location: ahmedabad
Distribution: CentOS, Ubuntu, Debian
Posts: 92
Blog Entries: 1

Rep: Reputation: Disabled
just try -
$sudo usermod
 
Old 09-18-2013, 07:41 AM   #5
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
Quote:
Originally Posted by jitendra.sharma View Post
just try -
$sudo usermod
Depends on whether sudo is enabled. Some distros do not enable it on user's accounts by default. If not, try this:
Code:
su -
(enter root's password)
then your usermod command.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
usermod -p command deepak_message Linux - Server 3 07-20-2011 12:47 PM
usermod command,is it correct? cola Linux - Newbie 7 06-02-2010 05:17 AM
Problem with usermod command pushpendra Linux - Desktop 3 05-27-2010 06:03 AM
usermod : command problem eboy98 Linux - Newbie 1 08-22-2008 12:21 PM
command usermod not found bowie101 Linux - Newbie 5 11-25-2005 05:38 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration