LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 06-28-2005, 09:01 PM   #1
lordshipmayhem
Member
 
Registered: Sep 2003
Location: Toronto
Distribution: Mandriva Powerpack 2007
Posts: 87

Rep: Reputation: 15
command not found error


I'm trying to learn how to set up programs using the old .tar method. I decide to try with a fairly simple game, "Bubble Shooter", which Absolutist has ported to Linux. (The Readme for this sucker assures me that it'll run in a number of distros, including my own Mandrake.)

http://absolutist.com/linux/bubbles/bshooter.tgz

So far, so good.

The Readme file contains the following instructions:

1) copy the file to a directory of your choice
2) unpack the archive:
tar xzvf bshooter.tgz
3) go into BubbleShooter directory and run the game:
cd BubbleShooter;
bubbles

Seems simple enough. (Yes, you could be describing the person starting this thread...)

So I copy the file into usr/share/bubbleshoot (error #1: now I have a directory usr/share/bubbleshoot/BubbleShooter, when if I'd just copied it into usr/share it would have been enough... but then, this IS a learning exercise). In the BASH shell, I su into root, copy-and-paste the tar command from the Readme file to be sure I don't mistype anything, and execute the command. So far, so good - everything seems to be set up as advertised in the Readme file. I then cd into BubbleShooter and type "bubbles".

bash: bubbles: command not found

And I did what wrong, please?

I'm sure whatever it is, it's probably pretty simple and so obvious most "howto"'s skip this...

Last edited by lordshipmayhem; 06-28-2005 at 09:03 PM.
 
Old 06-28-2005, 09:17 PM   #2
bigdog0007
LQ Newbie
 
Registered: May 2005
Location: NC
Posts: 26

Rep: Reputation: 15
Try going to the directory and typing in ./bubbles
 
Old 06-28-2005, 10:10 PM   #3
lordshipmayhem
Member
 
Registered: Sep 2003
Location: Toronto
Distribution: Mandriva Powerpack 2007
Posts: 87

Original Poster
Rep: Reputation: 15
And that worked. Thanks a lot!!

Usually I find, the problem has a simple solution.
 
Old 06-28-2005, 10:12 PM   #4
nevarlen
Member
 
Registered: Feb 2005
Distribution: Debian 3.x & Fedora Core 3, Debie on IBM Thinkpad
Posts: 68

Rep: Reputation: 15
If the above did not help, make sure to chmod +x the bubbles file you are trying to fire up. Once you get it working , it is also a good idea to create an alias for bubbles to that link to the /path/to/bubbles so next time you do not have to cd into that directory to get it working..
hope this helps..
----------------------------------------------------------------
looks like you type faster than I do..glad it worked though..

Last edited by nevarlen; 06-28-2005 at 10:14 PM.
 
Old 06-28-2005, 10:15 PM   #5
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,805

Rep: Reputation: 324Reputation: 324Reputation: 324Reputation: 324
Bash is a very powerful scripting language, among other things. But, it's also dimwitted. You have to tell it where the executable file is located.

There are two ways to do that.

1) give the full path to the executable: as in /usr/share/bubbleshoot/BubbleShoot, and away it goes.

2) use shorthand. cd to the directory in which the executable is located, and tell bash 'it's in this directory', using bash shorthand: ./

The ./ tell bash the executable is in the pwd (present working directory: that's where you are when you cd to a directory).

3) the final option. the executable is not in your path (see /etc/ld.so.config to see which directories are in ALL users paths). Just edit that file to add the path to a directory which contains an executable you want all user to be able to use. There's a way to temporarily (i.e. this login) add a path to your users privileges: something like 'export PATH=$PATH:/usr/share/bubbleshoot/BubbleShoot', which adds the BubbleShoot executable to your path for this login only. Add it to /etc/ld.so.config to make it permanent, for all users.

After you edit that file, it probably won't work. And you'll think I don't know what I'm talking about. Until you restart the X server, or reboot. That's because, when you edit a config file, the changes don't take effect until you do 1 of 3 things: reboot, restart the X server (ctrl-alt-backspace), or........

issue the bash command: source /etc/ld.so.conf. That tells bash to reload the config file. Or, you could use the shorthand version of the same command: . /etc/ld.so.conf. Notice the dot followed by a space before /etc/ld.so.conf. The dot (.) is bash-speak for 'source'. They have the same meaning: reload the config.

Last edited by bigrigdriver; 06-28-2005 at 10:28 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
command not found error cdsnithi Linux - Software 2 07-06-2005 01:26 PM
c++ command not found error... ? Cheka Linux - Newbie 2 01-29-2005 04:43 PM
command not found error message dcarlis Linux - Newbie 3 10-21-2004 08:30 PM
rpm error-> patch: command not found Bosnja Linux - Software 5 01-30-2004 01:59 PM
bash: command not found error ksgill Linux - Newbie 10 07-01-2003 04:47 PM


All times are GMT -5. The time now is 07:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration