LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   command gedit "/etc/apt/sources.list" not working (http://www.linuxquestions.org/questions/linux-newbie-8/command-gedit-etc-apt-sources-list-not-working-470176/)

secret_force 08-02-2006 02:52 PM

command "gedit /etc/apt/sources.list" not working
 
I want to change my sources.list however this happens when I type in the terminal
ernst@ernst-desktop:~$ sudo gedit /etc/apt/sources.list
sudo: gedit: command not found


Any idea?

I use kubuntu 6.06

jeelliso 08-02-2006 03:03 PM

sudo by itself will not run anything that requires the X server. Try "gksudo gedit /etc/apt/sources.list".

~Justin

IsaacKuo 08-02-2006 03:05 PM

gedit is a GNOME application, and kubuntu doesn't come with GNOME by default. You can install gedit if you want, or you can use kwrite (a KDE editor), or you can learn how to use vi (a popular but somewhat arcane console based text editor).

Of these options, learning to use vi may be the best in the long run. Vi isn't TOO unfriendly once you get used to it, and it's available even when booted up to the most minimal of emergency text console modes.

Nylex 08-02-2006 03:05 PM

Do you actually have gedit installed? It's the editor for GNOME and Kubuntu has KDE installed, so you may not have it. Edit: there are other editors you can use: Kate (which comes with KDE), Emacs, nano/pico to name a few.

oskar 08-02-2006 04:28 PM

"kdesu kate"

is what you want

You shouldn't get in the habit of sudo-ing graphical applications in kde. gnome can usually handle it.
use kdesu for everything off - command-line.

And you should use kate in kde instead of gedit.


BTW, it's "gksu" in gnome, not "gksudo".


All times are GMT -5. The time now is 04:05 AM.