LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   collect2: ld returned 1 exit status (http://www.linuxquestions.org/questions/linux-newbie-8/collect2-ld-returned-1-exit-status-743279/)

Ritendra 07-28-2009 12:25 AM

collect2: ld returned 1 exit status
 
Hi,
while building my image i got this linking error:

cc -L/backed/ritendra/Build/xl-build/phc-libpgutil -L/backed/ritendra/Build/xl-build/phc-libnetops -L/backed/ritendra/Build/xl-build/phc-libpsoap -L/backed/ritendra/Build/xl-build/phc-libpginitutils -L/backed/ritendra/Build/xl-build/phc-netsnmp/build/snmplib/.libs -L/backed/ritendra/Build/xl-build/phc-libradius -I/backed/ritendra/Build/xl-build/phc-libtlv -L/backed/ritendra/Build/xl-build/lib/phc-libpsoap -L/backed/ritendra/Build/xl-build/lib/phc-libpgutil -o psg_failover psg_failover.o -lpgutil -lpgutil
psg_failover.o(.text+0x22): In function `main':
: undefined reference to `psg_sharedmemory'
psg_failover.o(.text+0x52f): In function `initialization':
: undefined reference to `pginit_utils_get_next_config_entry'
psg_failover.o(.text+0x706): In function `initialization':
: undefined reference to `psg_passive_client'
psg_failover.o(.text+0x798): In function `send_arp_requestto_psg':
: undefined reference to `ioctl_initialization'
psg_failover.o(.text+0x9b0): In function `monitoring':
: undefined reference to `send_http_request'
psg_failover.o(.text+0x9e4): In function `monitoring':
: undefined reference to `send_icmp_request'
psg_failover.o(.text+0xa0a): In function `monitoring':
: undefined reference to `psg_active_server'
psg_failover.o(.text+0xa30): In function `monitoring':
: undefined reference to `psg_dummy_auth'
psg_failover.o(.text+0xaa1): In function `monitoring':
: undefined reference to `psg_passive_client'
collect2: ld returned 1 exit status
make[1]: *** [psg_failover] Error 1
make[1]: Leaving directory `/backed/ritendra/Build/xl-build/phc-failover'
make: *** [all] Error 1



Please help me....

fpmurphy 07-29-2009 09:54 AM

You failed to include one or more libraries (i.e. -llibrary.) What I do not understand is why you have so many library directory directives (-Llibrary_directory)

knudfl 07-30-2009 07:39 AM

Welcome to LQ.

And which application are you building ?
Which command is used to get the shown result ?
Also please tell which Linux OS, you are using.

http://www.linuxquestions.org/linux/...Ask_a_Question
http://linuxsilo.net/docs/smart-questions_en.html
.....


All times are GMT -5. The time now is 11:55 PM.