LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-11-2004, 06:26 AM   #1
CJB
Member
 
Registered: Dec 2003
Location: Hong Kong
Distribution: Mandrake 9.2, Windows XP, Fedora Core 1
Posts: 47

Rep: Reputation: 15
Question Clock


I had Windows XP on my computer and have since installed Mandrake 9.2.

During the install I had to set the time / timezone information which I did. The problem I have is that when I booted up Windows the time had changed by several hours so I corrected it. Then when I boot up Mandrake the time has been changed by the same number of hours. So I corrected it in Mandrake. But when I boot up Windows....I think you can see the problem.

How do I get round this?

Thanks.
 
Old 01-11-2004, 07:11 AM   #2
scott_R
Member
 
Registered: Jul 2003
Location: Brighton, Michigan, USA
Distribution: Lots of distros in the past, now Linux Mint
Posts: 746

Rep: Reputation: 31
I think you're changing your bios clock instead of the way your OS reads it. Windows reads the bios time. It's easy to miss the option in an initial setup, but mandrake asks if your system time is based on local time or GMT. If you select GMT when setting the time, it offsets the clock by whatever your timezone difference is. There are a number of scenarios you can imagine, but basically, you're telling Windows to read your bios one way, and Linux to read it another way.

So, to get it correct, you'll need to run whatever timezone program you use, and make sure this option is set the same way in both OSs. In control center/system, you can adjust your clock. After you pick your timezone, it will ask you if your bios is set for GMT or local time. In windows, make sure your settings are similar.
 
Old 01-11-2004, 09:47 AM   #3
CJB
Member
 
Registered: Dec 2003
Location: Hong Kong
Distribution: Mandrake 9.2, Windows XP, Fedora Core 1
Posts: 47

Original Poster
Rep: Reputation: 15
Thumbs up

OK Got it

The clock in BIOS was set to the local time here in HK. When I set the time in Mandrake, I put in the local HK time and entered it. A window popped up asking if my clock was set to GMT. Previously I had put yes - I put in 'no' this time and it worked. Having come from the UK originally, this is a mistake easily made as obviously the time is GMT.

Thanks for your help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
System clock correct, hardware clock wrong karlovac Linux - General 5 01-16-2009 08:19 PM
Various clock issues: Clock shows wrong time only in Knoppmyth, & CMOS time change ? davidbix General 1 04-05-2006 10:58 PM
system clock,hardware clock varunbihani Linux - Newbie 2 07-23-2005 10:04 AM
Dot Clock / Pixel Clock Freaksta Linux - Hardware 1 05-05-2004 09:21 PM
system clock vs. CMOS clock dtamajka Linux - General 7 12-11-2003 06:56 PM


All times are GMT -5. The time now is 07:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration