LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-05-2011, 10:18 AM   #1
sansone
LQ Newbie
 
Registered: Jun 2011
Posts: 4

Rep: Reputation: Disabled
CIFS VFS: No response...


Hi, my kern.log reports many events like these:

...
May 31 20:36:38 main kernel: [12596.700620] CIFS VFS: No response to cmd 4 mid 8270
May 31 20:36:38 main kernel: [12596.700806] CIFS VFS: Send error in Close = -11
May 31 20:36:55 main kernel: [12613.623723] CIFS VFS: No response for cmd 6 mid 8274
May 31 20:36:55 main kernel: [12613.623842] CIFS VFS: No response for cmd 50 mid 8275
May 31 20:37:16 main kernel: [12634.680159] CIFS VFS: No response for cmd 6 mid 8279
May 31 20:37:16 main kernel: [12634.680279] CIFS VFS: No response for cmd 50 mid 8280
May 31 20:37:38 main kernel: [12655.706690] CIFS VFS: No response for cmd 6 mid 8285
May 31 20:37:38 main kernel: [12655.706812] CIFS VFS: No response for cmd 50 mid 8286
May 31 20:37:38 main kernel: [12655.946296] CIFS VFS: No response for cmd 50 mid 8287
May 31 20:37:38 main kernel: [12655.946413] CIFS VFS: No response for cmd 50 mid 8288
May 31 20:37:43 main kernel: [12661.334499] CIFS VFS: No response for cmd 50 mid 8289
...

I'm 99% sure they're generated by Courier-imap trying to access emails stored in my QNAP NAS.
The shared folder of my NAS is mounted in fstab with:
...
//192.168.168.10/mail /mnt/mail cifs username=virtual,password=miapw,iocharset=utf8,nos erverino,uid=5000,gid=5000,_netdev,mapchars 0 0
...

Ubuntu 10.10 running on VMWare with Postfix + Courier-IMAP + MySQL.

I've read about similar problems on the Net solved disabling the optimistic locking of cifs. This trick didn't solve my problem.

Any idea ?

Thanks.
 
Old 06-05-2011, 10:55 AM   #2
carltm
Member
 
Registered: Jan 2007
Location: Canton, MI
Distribution: CentOS, SuSE, Red Hat, Debian, etc.
Posts: 703

Rep: Reputation: 97
I used to see these and switched to using autofs. With autofs
a new connection is sought if the existing connection breaks.
It's likely that a temporary glitch is breaking the connection
and the traditional mount doesn't know how to reestablish it.
 
Old 06-06-2011, 03:33 AM   #3
sansone
LQ Newbie
 
Registered: Jun 2011
Posts: 4

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by carltm View Post
I used to see these and switched to using autofs.
I tried but I received an error of mounting not allowed because wrong type of fs, "superblock" not valid (I'm translating so the messages could be sligthly different). dmesg says "autofs: called called with bogus options".
 
Old 06-06-2011, 07:57 AM   #4
carltm
Member
 
Registered: Jan 2007
Location: Canton, MI
Distribution: CentOS, SuSE, Red Hat, Debian, etc.
Posts: 703

Rep: Reputation: 97
If you want, post your autofs files. Just take out your password. ;-)
 
Old 06-06-2011, 10:37 AM   #5
sansone
LQ Newbie
 
Registered: Jun 2011
Posts: 4

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by carltm View Post
If you want, post your autofs files. Just take out your password. ;-)
Here follows the line from /etc/fstab:

//192.168.168.10/mail /mnt/mail cifs username=virtual,password=mypassword,iocharset=utf8,noserverino,uid=5000,gid=5000,_netdev,mapchars 0 0

If I switch to autofs instead of cifs I got that error message.

Thanks for your help.
 
Old 06-06-2011, 08:22 PM   #6
carltm
Member
 
Registered: Jan 2007
Location: Canton, MI
Distribution: CentOS, SuSE, Red Hat, Debian, etc.
Posts: 703

Rep: Reputation: 97
I'm trying to follow your logic. First you said you're getting "No response"
errors when you use mount. I mentioned autofs, and you said when you ran it
you received an error about "bogus options." I asked you to post the autofs
files, and you show an entry for /etc/fstab, which is used for mount and not
for autofs.

Hmmm. Are we talking about the same thing? Autofs is a daemon with its own
configuration files.
 
Old 06-07-2011, 07:11 AM   #7
sansone
LQ Newbie
 
Registered: Jun 2011
Posts: 4

Original Poster
Rep: Reputation: Disabled
Hi, you are right, I didn't know autofs, I wrongly supposed it was a parameter like cifs ("type" of mount).

I've read something now about it, I followed some "How To" but...I failed!

If you can please guide me step by step considering that I already installed autofs, smbclient and smbfs.
I wanna reach my nas' mail share through /mnt/mail exactly like I already do with the usual mount described above.
I guess you should tell me exactly what to write inside auto.master and the other auto.xxx files.

Thanks in advance for your patience.
 
Old 06-07-2011, 07:40 AM   #8
carltm
Member
 
Registered: Jan 2007
Location: Canton, MI
Distribution: CentOS, SuSE, Red Hat, Debian, etc.
Posts: 703

Rep: Reputation: 97
It would really be better if you find how to make this work.
If you get stuck at a particular step or get an error message
I'd be glad to point you in the right direction.

You could start by posting the files you used and giving a
good description of what went wrong.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
CIFS VFS: cifs_mount failed w/return code = -11 srini406 Linux - Newbie 2 04-27-2010 08:27 AM
how to fixed this error: CIFS VFS: Send error in read = -11 charlcliu Linux - Newbie 0 04-13-2009 01:16 PM
Samba issue when doing shutdown (CIFS VFS...) netjack Linux - General 3 04-05-2009 08:57 AM
CIFS VFS: Send error in FindClose = -9 punt Linux - Networking 3 07-13-2007 12:00 AM
Problem mounting a samba share "CIFS VFS: Send error in SETFSUnixInfo = -5" mrcoffee11 Linux - Software 1 11-07-2006 06:29 PM


All times are GMT -5. The time now is 04:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration