LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-07-2014, 01:44 PM   #1
RRepster
Member
 
Registered: Dec 2002
Location: aksarben
Distribution: Several
Posts: 117

Rep: Reputation: 15
CIFS automount issue


similar issue enough to not make an entire new thread:
I have an xp box and a RasberryPi running Rasbian (debian based) connected to each other, no internet, no routers etc. I need to automount the shared directory on the windows box: //10.1.1.2/Photos
I can mount it by hand each time by:
sudo mount -t cifs -o username=adam,password=adam //10.1.1.2/Photos /home/pi/photos
that mounts just fine and files are viewable in /home/pi/photos. But putting it in fstab that way doesn't work.
(Yes I have googled constantly so please don't say that, due to constant samba changes its nearly useless).
From the Ubuntu wiki I found this option:
//10.1.1.2/Photos cifs username=adam,password=adam,iocharset=utf8,sec=ntlm 0 0
that method required creating /media/windowsshared file
mount -a passes but navigating to /media/windowsshared shows nothing in there.
I am at my wits end here. Thank you obi-wan-kenobi you're my only hope.

Rob

Last edited by RRepster; 12-07-2014 at 01:45 PM. Reason: forgot to mention peer to peer connection
 
Old 12-09-2014, 10:06 PM   #2
Teufel
Member
 
Registered: Apr 2012
Distribution: Gentoo
Posts: 530

Rep: Reputation: 128Reputation: 128
Quote:
Originally Posted by RRepster View Post
From the Ubuntu wiki I found this option:
//10.1.1.2/Photos cifs username=adam,password=adam,iocharset=utf8,sec=ntlm 0 0
that method required creating /media/windowsshared file
mount -a passes but navigating to /media/windowsshared shows nothing in there.
/media/windowsshared should be a directory, not a file. Though it might be a typo in your message.
For me mounting from fstab by "mount" command doesn't work as well due to permissions, even if I trying to mount share as root.
So I use my workaround, a little executable script that assigned to hotkey. This is what I have in that script:
Code:
echo "password" | sudo -S mount -t cifs //192.168.1.11/share /mnt/share -o nosuid,nodev,password="password",sec=ntlm,workgroup=WORKGROUP,ip=192.168.1.11
The only way to get it working for me is mounting share with piping password to sudo.
Options "workgroup" and "ip" must be specified too.
May be it will help you.

Last edited by Teufel; 12-09-2014 at 10:07 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] strange fstab cifs automount issue aagaag Linux - Newbie 3 08-31-2014 11:56 AM
cifs automount not happening -- and an incomplete workaround pwabrahams Linux - Networking 5 07-31-2009 04:39 PM
Can't automount CIFS as normal user SlowCoder Linux - General 4 05-14-2007 03:43 PM
CIFS issue rlh989 Linux - Networking 1 01-26-2007 07:44 PM


All times are GMT -5. The time now is 01:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration