LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Chose udev for services... udev starts twice... hotplug fails (http://www.linuxquestions.org/questions/linux-newbie-8/chose-udev-for-services-udev-starts-twice-hotplug-fails-833202/)

flipjarg 09-19-2010 12:26 PM

Chose udev for services... udev starts twice... hotplug fails
 
The other day I was setting up my system after a clean install. I noticed udev was not selected in the services under the Admin > Services menu in Gnome. So I selected it. The next time I booted up, I noticed udev started right away. Then I noticed it said: udev is already started... booting continued and I noticed hotplug failed. So now I have no keyboard or mouse/touchpad capabilities.

How can I fix this? I assume I have to change that config file so udev does not try to start twice... any ideas?

Thanks!

flipjarg 09-19-2010 01:28 PM

[solved]
 
Since I have a bluetooth mouse, I used the assistive technologies on screen keyboard to login. Then I went to the System > Admin > Services menu and de-selected udev. Typed my password in with the onscreen keyboard and restarted.

All is well again.

David the H. 09-19-2010 01:49 PM

Glad you could figure it out.

For the record though, in cases like this you should generally be able to reboot into single-user mode, where you can then reconfigure your services manually.

If you have keyboard access, you can also usually use ctrl+alt+[F1-F6] to get into a console, where you can log in as root. The major graphical login managers also have options for shutting down the x-server and going into console mode.

This page has a decent rundown on how to do that in various distributions. Be sure to check out the comments for more tips.

http://linuxhelp.blogspot.com/2006/0...during_01.html


All times are GMT -5. The time now is 09:20 PM.