LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-23-2015, 08:41 AM   #1
Hansie
LQ Newbie
 
Registered: Feb 2015
Posts: 2

Rep: Reputation: Disabled
Question chkconfig --add not working


Hi friends ,
i am new to linux , i have a script , to auto start/stop a application whenever linux reboot.
when i do chkconfig --add scriptname , it do not add to chkconfig list.
when i do chkconfig --list scriptname , it gives me info , "service chkconfig enabled , please add by running command chkconfig --add scriptname."

OS is Redhat 6.3
i had tested on another server redhat 6.5 , it is working fine on it.

Thanks in advance
 
Old 02-23-2015, 11:50 AM   #2
smallpond
Senior Member
 
Registered: Feb 2011
Location: Massachusetts, USA
Distribution: CentOS 6 (pre-systemd)
Posts: 2,667

Rep: Reputation: 710Reputation: 710Reputation: 710Reputation: 710Reputation: 710Reputation: 710Reputation: 710
Does the script have one of the two chkconfig headers?
Code:
# chkconfig: <levels> <start> <stop>
# description: <some description>
or
Code:
### BEGIN INIT INFO
<lsb entries>
### END INIT INFO
 
Old 02-26-2015, 08:32 AM   #3
Hansie
LQ Newbie
 
Registered: Feb 2015
Posts: 2

Original Poster
Rep: Reputation: Disabled
sorry for the late reply

i dont have this lines in the code

### BEGIN INIT INFO
<lsb entries>
### END INIT INFO

But on the other server it is working fine it is linux 6.5 (working server)
on the server which is not working it is linux 6.3

Last edited by Hansie; 02-26-2015 at 08:34 AM. Reason: late reply
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can I add a delay for mysql in chkconfig? mmorton89 Linux - Newbie 14 10-09-2012 03:39 AM
[SOLVED] chkconfig --add doesn't let me add x201s Linux - Newbie 2 03-14-2011 10:47 PM
[SOLVED] chkconfig: cannot add new service. deostroll Linux - Server 5 03-09-2010 02:09 AM
chkconfig --add auditd mccartjd Linux - Newbie 6 05-21-2008 04:28 PM
chkconfig --add noir911 Linux - General 3 11-23-2006 02:26 AM


All times are GMT -5. The time now is 11:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration