LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-04-2013, 01:55 AM   #1
srijivdimri
Member
 
Registered: Jun 2013
Location: India.
Posts: 35

Rep: Reputation: Disabled
checking for NM_UTILS... configure: error: Package requirements


Hi Experts,

I am trying to install NetworkManager for Openconnect vpn s/w on RedHat. I downloaded the NetworkManager-openconnect-0.99(2).tar.gz, untar it and got the NetworkManager-openconnect-0.99 . When I go under this directory, I see:-

aclocal.m4 autom4te.cache config.guess config.sub depcomp intltool-merge.in MAINTAINERS missing nm-openconnect-service.name.in src
AUTHORS ChangeLog config.h.in configure install-sh intltool-update.in Makefile.am mkinstalldirs po
autogen.sh compile config.log configure.in intltool-extract.in ltmain.sh Makefile.in nm-openconnect-service.conf properties

When I do .configure, it comes up with an error message:-

"checking for NM_UTILS... configure: error: Package requirements (NetworkManager >= 0.7.0 libnm-util libnm_glib libnm_glib_vpn) were not met:

No package 'NetworkManager' found
No package 'libnm-util' found
No package 'libnm_glib' found
No package 'libnm_glib_vpn' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables NM_UTILS_CFLAGS
and NM_UTILS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
"

If I open Autogen.sh via vim, I see that I need to install gnome-common. I installd the package for the same using yum install gnmome-common.noarch. But still getting the same error.

Please advice on the same.

Your inpus would be highly appreciated.

Thanks and Regards,
Srijiv Dimri
 
Old 07-04-2013, 03:29 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,683

Rep: Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284
NetworkManager-openconnect-0.99 : A future version.
( Fedora 19 : version 0.97* ).

I.e. please use a version that will accept your version of NetworkManager-devel.
→ → # yum install NetworkManager-devel

* No package 'NetworkManager' found : /usr/lib/pkgconfig/NetworkManager.pc
.. provided by NetworkManager-devel.

Which version is your OS ? → $ cat /etc/*release*

-
 
Old 07-04-2013, 08:51 AM   #3
srijivdimri
Member
 
Registered: Jun 2013
Location: India.
Posts: 35

Original Poster
Rep: Reputation: Disabled
Hi,

Thanks for looking into this.

The OS version is :-
[root@MCXALGO2 ~]# cat /etc/*release*
cat: /etc/lsb-release.d: Is a directory
Red Hat Enterprise Linux Server release 6.1 (Santiago)
Red Hat Enterprise Linux Server release 6.1 (Santiago)
cpe:/o:redhat:enterprise_linux:6server:ga:server

Please let me know if anything else is required from my end.
 
Old 07-04-2013, 09:48 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,683

Rep: Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284
# 3. OK, RHEL 6.x : NetworkManager-openconnect-0.8.1 can be used.
http://archives.fedoraproject.org/pu...1.fc14.src.rpm

# yum install \
NetworkManager-devel openconnect-devel NetworkManager-glib-devel
Code:
$ rpmbuild -bb NetworkManager-openconnect.spec
.
.
Wrote: /home/knudfl/rpms/RPMS/i686/NetworkManager-openconnect-0.8.1-1.el6.i686.rpm
.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error compiling Mesa-8.0.4: Package requirements (glproto >= 1.4.14) were not met gewmba Linux - Newbie 2 10-12-2012 03:30 PM
configure: error: Package requirements Sargalus Linux - Software 15 03-24-2010 03:13 PM
GQ LDAP client - Package requirements error fortez Linux - Software 2 11-14-2009 11:13 AM
configure: error: Library requirements (gtk+-2.0 >= 2.0.5) not met; cottonfever Linux - Newbie 2 08-18-2006 04:18 PM
checking for X...configure:error dumbsheep Linux - Newbie 4 02-01-2005 02:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration