LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-04-2006, 08:47 PM   #1
dohcacr
LQ Newbie
 
Registered: Mar 2006
Posts: 7

Rep: Reputation: 0
Changing Screen Resolution in Ubuntu 5.10


This is like typing while looking through a keyhole. My current screen resolution is 640x480 and the only choice that is available in system/preferences/screen resolution is 640x480. I would like to change it to 1024x768. How do I do it? Thanks in advance for your help. This screen size is driving me nuts.

Chuck
 
Old 04-04-2006, 11:29 PM   #2
vmlinuz.gz
Member
 
Registered: Nov 2005
Posts: 123

Rep: Reputation: 15
Find your way to the /etc/X11/ directory and look for a file named XF86Config-4, Xorg.conf, or something similar. Edit the file (you may wish to make a backup first, just in case) and go down to Section "Screen". Add "1024x768" (including quotation marks) next after every instance of "Modes" in that section (right next to where it should say "640x680"). Now, save the file and restart X (CTRL + ALT + Backspace). Return to your system / preferences / screen resolution and see if there are any more options available.
 
Old 04-05-2006, 08:40 AM   #3
dohcacr
LQ Newbie
 
Registered: Mar 2006
Posts: 7

Original Poster
Rep: Reputation: 0
Well, I kind of hosed it up. I found the xorg.conf file, but it already had the 1024x768 in it, although that resolution was not selectable. I decided I would try the monitor and screen section from my xorg.conf file on my pclinuxos installation(which works great), so I cut and paste the sections into my ubuntu xorg.conf file and restart the system. Well, now the xserver won't start. Now it's really time to see if I can turn a significant problem into a real disaster.

Last edited by dohcacr; 04-05-2006 at 08:41 AM.
 
Old 04-05-2006, 10:20 AM   #4
smiley_lauf
Member
 
Registered: Jan 2006
Location: NY
Distribution: Fedora 15 x64
Posts: 344

Rep: Reputation: 30
Hi There
Firstly, what grpahics driver (hardware) do you have? ATI, NVidea or other?

Ubuntu has one of the most intuitve xserver configuration out there (just my 2c first).
At the command prompt type

Code:
sudo dpkg-reconfigure xserver-xorg
Select the options that apply to you. I normally choose the all defaults, and at the driver scetion I choose VESA and select the resoltuions I know will work with VESA driver (in your case choose highest 1024x768, BUT if you have ATI or other card then u will need a prop driver to emulate that resolution..but that later). At the point where it asks you to autodetect display It will ask you twice, choose YES at the first, and NO at the second. It will ask you to overwrite the xorg.conf file, choose YES, do not worry it makes a backup of the old file (with the date and time as appendix).

reboot.

Now you should come to a GUI login. If not then your resolutions were too high for the VESA, so go thru reconfigure as above and choose one less than 1024x768 res. You should be able to get into GUI now.

Try and find out what graphics card you have and we can take it from there?

HTH.
smiley
 
Old 04-05-2006, 10:28 AM   #5
lugoteehalt
Senior Member
 
Registered: Sep 2003
Location: UK
Distribution: Debian
Posts: 1,215
Blog Entries: 2

Rep: Reputation: 49
See no harm in trying ctrl+alt+K.P_+ (numpad +).
 
Old 04-05-2006, 12:01 PM   #6
dohcacr
LQ Newbie
 
Registered: Mar 2006
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by smiley_lauf

Try and find out what graphics card you have and we can take it from there?

HTH.
smiley
The video controller is embedded on the motherboard. It's a Nvidia nforce2. I'll try the "sudo dpkg-reconfigure xserver-xorg" command when I get home tonight. Thanks for the suggestion.
 
Old 04-05-2006, 12:14 PM   #7
onjoo
Member
 
Registered: Jan 2005
Location: Finland
Distribution: Suse 10, Suse-factory , RHEL4, SLES9, SLED10
Posts: 380

Rep: Reputation: 30
I've seen many posts on the subject at http://ubuntuforums.org/
Try search there..

You need to write your monitor syncs in the xorg.conf or else resolution will stuck to the minimum.
Check if monitors vert and horiz are missing

Should look something like this:
Section "Monitor"
Identifier "xyz"
HorizSync 30-100
VertRefresh 50-150
 
Old 04-05-2006, 12:39 PM   #8
dohcacr
LQ Newbie
 
Registered: Mar 2006
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by onjoo
I've seen many posts on the subject at http://ubuntuforums.org/
Try search there..

You need to write your monitor syncs in the xorg.conf or else resolution will stuck to the minimum.
Check if monitors vert and horiz are missing

Should look something like this:
Section "Monitor"
Identifier "xyz"
HorizSync 30-100
VertRefresh 50-150
I have a emachines e15t active matrix tft monitor. The only specs I've been able to run down are that it's "native mode" is 1024X768 @ 60hz. Would you expect to find sync frequencies in a xorg.conf for a lcd monitor?
 
Old 04-05-2006, 12:48 PM   #9
vmlinuz.gz
Member
 
Registered: Nov 2005
Posts: 123

Rep: Reputation: 15
If changing your Xorg.conf didn't work then I recommend that you look around for the latest drivers for your video card and install them.
 
Old 04-05-2006, 01:19 PM   #10
dohcacr
LQ Newbie
 
Registered: Mar 2006
Posts: 7

Original Poster
Rep: Reputation: 0
Well, I think the xorg file deserves revisiting to check the sync freq. If that looks ok, I'll reconfigure the xserver as suggested above, and if that fails I'll look for another driver (or SimplyMEPIS)
 
Old 04-05-2006, 06:23 PM   #11
smiley_lauf
Member
 
Registered: Jan 2006
Location: NY
Distribution: Fedora 15 x64
Posts: 344

Rep: Reputation: 30
https://wiki.ubuntu.com/BinaryDriverHowto/Nvidia

This should come in handy. MEPIS my other Debian Os, also great!
 
Old 04-05-2006, 07:12 PM   #12
dohcacr
LQ Newbie
 
Registered: Mar 2006
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by onjoo
I've seen many posts on the subject at http://ubuntuforums.org/
Try search there..

You need to write your monitor syncs in the xorg.conf or else resolution will stuck to the minimum.
Check if monitors vert and horiz are missing

Should look something like this:
Section "Monitor"
Identifier "xyz"
HorizSync 30-100
VertRefresh 50-150
............and you were 100% correct! Thank you everyone for all your help and suggestions.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem changing the video adapter setting and changing the screen resolution habiblove Linux - General 3 02-18-2006 06:10 PM
changing screen resolution.. kurrupt Debian 4 10-24-2004 01:45 PM
Changing screen resolution? Anth3m Linux - Newbie 14 10-28-2003 09:42 AM
Changing the screen resolution? Stillwell Linux - Newbie 2 09-28-2003 05:30 PM
Changing screen resolution remymartin Linux - Newbie 3 01-10-2002 06:07 PM


All times are GMT -5. The time now is 02:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration