LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-10-2004, 01:49 PM   #1
drknow
Member
 
Registered: Jan 2004
Distribution: Shrike (RH9)
Posts: 73

Rep: Reputation: 15
Changing resolution with KDE


Ive tried changing my resolution in KDE from 800x600 to 1024x768, and it says to restart X and the changes will be applied, but when i do, it is still at 800x600. How do I change it???
 
Old 01-10-2004, 02:04 PM   #2
Whitehat
Senior Member
 
Registered: Feb 2003
Location: The Cold North
Distribution: SuSE 9.1
Posts: 1,289

Rep: Reputation: 46
You can change the Section in your XF86Config file to match this one:

Subsection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection


This is from Slackware and it is located in the file /etc/X11/XF86Config. I believe it's in the same place in Redhat.

Peace,
Whitehat
 
Old 01-10-2004, 03:50 PM   #3
drknow
Member
 
Registered: Jan 2004
Distribution: Shrike (RH9)
Posts: 73

Original Poster
Rep: Reputation: 15
Ok, its not working at all. I changed my XF86Config to look like that(it was already about like that), and then I saved and restarted. Then I changed my resolution to 1024x768, and restarted again....It showed up in 800x600 AGAIN. I looked in XF86Config and it changed depth 16(which is the depth i am using) to look like:
Depth 16
Modes "800x600" "640x480"
Viewport 0 0
EndSubsection


So it ERASED the 1024x768 value. What is going on here...I cant stand 800x600.
 
Old 01-10-2004, 07:50 PM   #4
drkfir5
Member
 
Registered: Jan 2004
Distribution: SuSE 9.0
Posts: 41

Rep: Reputation: 15
I would suggest killing the XServer then cunning SAX2 fom a command line. Disable any resolutios below 1064x768. Save and Exit. This should solve your problem.
 
Old 01-11-2004, 03:07 AM   #5
tearinox
Member
 
Registered: Aug 2003
Location: you dont want to know
Distribution: Gentoo 2004.2, Slackware 10, Windows XP, Windows 2003 Server
Posts: 348

Rep: Reputation: 30
Just adding on to drkfir5's post, this should be what it looks like when your done:

Subsection "Display"
Depth 8
Modes "1024x768"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 16
Modes "1024x768"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 24
Modes "1024x768"
ViewPort 0 0
EndSubsection


BTW: I believe pressing ctrl+alt+"+" or ctrl+alt+"-" (stuff in quotes you DO press) will increase or decrease size.
 
Old 01-11-2004, 03:36 PM   #6
drknow
Member
 
Registered: Jan 2004
Distribution: Shrike (RH9)
Posts: 73

Original Poster
Rep: Reputation: 15
Okay...I tried that, but when I reboot, it says that screens were found, but none of them were valid or something like that. Then it says no screens found. Ive tried using the ctrl alt "+" thing, but I cant get it to do anything. Im getting so frustrated here. Somebody please help me .
 
Old 01-11-2004, 04:05 PM   #7
drknow
Member
 
Registered: Jan 2004
Distribution: Shrike (RH9)
Posts: 73

Original Poster
Rep: Reputation: 15
Here is the log file from my last boot...note that I did not try to change the resolution before this boot, but look at all of the "cant use default" errors. Could this be a monitor setting problem???

(II) Loading /usr/X11R6/lib/modules/libddc.a
(II) Module ddc: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
(WW) NVIDIA(0): Failure reading EDID parameters for display device CRT-0
(II) NVIDIA(0): Monitor0: Using hsync range of 31.50-37.90 kHz
(II) NVIDIA(0): Monitor0: Using vrefresh range of 50.00-70.00 Hz
(II) NVIDIA(0): Clock range: 12.00 to 400.00 MHz
(II) NVIDIA(0): Not using default mode "640x350" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "320x175" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "640x400" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "320x200" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "720x400" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "360x200" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "640x480" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "320x240" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "640x480" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "320x240" (vrefresh out of range)
(II) NVIDIA(0): Not using default mode "640x480" (hsync out of range)
(II) NVIDIA(0): Not using default mode "320x240" (hsync out of range)
(II) NVIDIA(0): Not using default mode "800x600" (hsync out of range)
(II) NVIDIA(0): Not using default mode "400x300" (hsync out of range)
(II) NVIDIA(0): Not using default mode "800x600" (hsync out of range)
(II) NVIDIA(0): Not using default mode "400x300" (hsync out of range)
(II) NVIDIA(0): Not using default mode "800x600" (hsync out of range)
(II) NVIDIA(0): Not using default mode "400x300" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1024x768" (bad mode clock/interlace/doublescan)
(II) NVIDIA(0): Not using default mode "512x384" (bad mode clock/interlace/doublescan)
(II) NVIDIA(0): Not using default mode "1024x768" (hsync out of range)
(II) NVIDIA(0): Not using default mode "512x384" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1024x768" (hsync out of range)
(II) NVIDIA(0): Not using default mode "512x384" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1024x768" (hsync out of range)
(II) NVIDIA(0): Not using default mode "512x384" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1024x768" (hsync out of range)
(II) NVIDIA(0): Not using default mode "512x384" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1152x864" (hsync out of range)
(II) NVIDIA(0): Not using default mode "576x432" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1280x960" (hsync out of range)
(II) NVIDIA(0): Not using default mode "640x480" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1280x960" (hsync out of range)
(II) NVIDIA(0): Not using default mode "640x480" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1280x1024" (hsync out of range)
(II) NVIDIA(0): Not using default mode "640x512" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1280x1024" (hsync out of range)
(II) NVIDIA(0): Not using default mode "640x512" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1280x1024" (hsync out of range)
(II) NVIDIA(0): Not using default mode "640x512" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1600x1200" (hsync out of range)
(II) NVIDIA(0): Not using default mode "800x600" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1600x1200" (hsync out of range)
(II) NVIDIA(0): Not using default mode "800x600" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1600x1200" (hsync out of range)
(II) NVIDIA(0): Not using default mode "800x600" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1600x1200" (hsync out of range)
(II) NVIDIA(0): Not using default mode "800x600" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1600x1200" (hsync out of range)
(II) NVIDIA(0): Not using default mode "800x600" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1792x1344" (hsync out of range)
(II) NVIDIA(0): Not using default mode "896x672" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1792x1344" (hsync out of range)
(II) NVIDIA(0): Not using default mode "896x672" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1856x1392" (hsync out of range)
(II) NVIDIA(0): Not using default mode "928x696" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1856x1392" (hsync out of range)
(II) NVIDIA(0): Not using default mode "928x696" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1920x1440" (hsync out of range)
(II) NVIDIA(0): Not using default mode "960x720" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1920x1440" (hsync out of range)
(II) NVIDIA(0): Not using default mode "960x720" (hsync out of range)
(II) NVIDIA(0): Not using default mode "832x624" (hsync out of range)
(II) NVIDIA(0): Not using default mode "416x312" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1152x768" (hsync out of range)
(II) NVIDIA(0): Not using default mode "576x384" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1152x864" (hsync out of range)
(II) NVIDIA(0): Not using default mode "576x432" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1400x1050" (hsync out of range)
(II) NVIDIA(0): Not using default mode "700x525" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1400x1050" (hsync out of range)
(II) NVIDIA(0): Not using default mode "700x525" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1400x1050" (hsync out of range)
(II) NVIDIA(0): Not using default mode "700x525" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1400x1050" (hsync out of range)
(II) NVIDIA(0): Not using default mode "700x525" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1600x1024" (hsync out of range)
(II) NVIDIA(0): Not using default mode "800x512" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1920x1200" (hsync out of range)
(II) NVIDIA(0): Not using default mode "960x600" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1920x1440" (hsync out of range)
(II) NVIDIA(0): Not using default mode "960x720" (hsync out of range)
(II) NVIDIA(0): Not using default mode "2048x1536" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1024x768" (hsync out of range)
(II) NVIDIA(0): Not using default mode "2048x1536" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1024x768" (hsync out of range)
(II) NVIDIA(0): Not using default mode "2048x1536" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1024x768" (hsync out of range)
(**) NVIDIA(0): Validated modes for display device CRT-0:
(**) NVIDIA(0): Default mode "800x600": 40.0 MHz, 37.9 kHz, 60.3 Hz
(**) NVIDIA(0): Default mode "640x480": 25.2 MHz, 31.5 kHz, 60.0 Hz
(**) NVIDIA(0): Default mode "800x600": 36.0 MHz, 35.2 kHz, 56.2 Hz
(**) NVIDIA(0): Default mode "400x300": 20.0 MHz, 37.9 kHz, 60.3 Hz (D)
(**) NVIDIA(0): Default mode "400x300": 18.0 MHz, 35.2 kHz, 56.3 Hz (D)
(**) NVIDIA(0): Default mode "320x240": 12.6 MHz, 31.5 kHz, 60.1 Hz (D)
(II) NVIDIA(0): Virtual screen size determined to be 800 x 600
(==) NVIDIA(0): DPI set to (75, 75)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/X11R6/lib/modules/libfb.a
(II) Module fb: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 ANSI C Emulation, version 0.2
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Loading /usr/X11R6/lib/modules/libramdac.a
(II) Module ramdac: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.6
 
Old 01-11-2004, 04:06 PM   #8
drknow
Member
 
Registered: Jan 2004
Distribution: Shrike (RH9)
Posts: 73

Original Poster
Rep: Reputation: 15
Oh, sorry for not putting up the whole thing....I couldnt find a place to add an attatchment. I think that is the cause of the problem though.
 
Old 01-11-2004, 05:41 PM   #9
drknow
Member
 
Registered: Jan 2004
Distribution: Shrike (RH9)
Posts: 73

Original Poster
Rep: Reputation: 15
Come on people.....Im ripping my hair out over this. If you can give me any kind of hint to fix this, please do.
 
Old 01-11-2004, 06:05 PM   #10
drknow
Member
 
Registered: Jan 2004
Distribution: Shrike (RH9)
Posts: 73

Original Poster
Rep: Reputation: 15
Alright...I figured it out on my own. It was in fact my monitor settings. I looked on the internet and found the refresh rate at 1024x768 to be 60hz, so i set the monitor type to generic 1024x768@60hz and IT WORKED. So thanks for nothing people....lol
 
Old 01-11-2004, 06:08 PM   #11
drkfir5
Member
 
Registered: Jan 2004
Distribution: SuSE 9.0
Posts: 41

Rep: Reputation: 15
OK. When you start up SAX2 there should be a a drop-down tab that says something like: Change Configuration and Tune Mode. goto Change Configuration.

Look up on the web the necessary specs. for you monitor. Specifically, the hsync and vsync rates.

Set the monitor as it should be with 16-bit color and 1024x768. The selected resolution should appear in yellow. Deselect all setting except the 1024x768. Press the Test button and then tune the monitor as necessary (i.e. move the image this-way, that-way make it bigger, etc.) then press save settings.
Quit afterward then startx.

God willing and hopefully, it should work.

If it does not, however you should consider that you monitor or video card is not up to the challenge of supplying higher resolution settings. Let us know.
 
Old 01-11-2004, 06:12 PM   #12
drkfir5
Member
 
Registered: Jan 2004
Distribution: SuSE 9.0
Posts: 41

Rep: Reputation: 15
Just ignore my above post.... guy figured it out while I was posting I guess...
 
Old 01-11-2004, 06:35 PM   #13
drknow
Member
 
Registered: Jan 2004
Distribution: Shrike (RH9)
Posts: 73

Original Poster
Rep: Reputation: 15
Thanks anyways man. Im sure thats another way I could have done it
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem changing the video adapter setting and changing the screen resolution habiblove Linux - General 3 02-18-2006 06:10 PM
Changing my Screen Resolution in KDE Swimmerim21 Linux - Newbie 2 07-10-2005 06:25 PM
Need help changing resolution jtdwyer Fedora 2 05-20-2005 01:12 AM
Changing KDE Log-in Resolution OverlordManny Linux - Software 5 11-15-2004 06:22 PM
Changing Resolution in KDE Ryuji Yamazaki Slackware 4 11-04-2004 09:40 AM


All times are GMT -5. The time now is 12:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration