LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-14-2003, 03:45 AM   #1
unitcoed
LQ Newbie
 
Registered: Jun 2003
Distribution: RedHat 9, Slackware Live, Slackware 9
Posts: 16

Rep: Reputation: 0
changing permisson settings to /mnt/ devices?


I partitioned my Harddisk so that I could have all my music on one partition, documents and files on the other, and my Linux OS on the other..

The strange thing is, I can add/delete files in the music partition, but the other parition for documents cannot be modified (files can only be viewed)....

I logged into the ROOT, went to the /mnt/ directory and attempted to change the folder owner to my user, but it says that I don't have permission to do so . (the owner of the folder is the root)

Is there anyway I can change permission settings in the terminal so that my user can modify folders in this folder?
 
Old 06-14-2003, 03:49 AM   #2
carlywarly
Member
 
Registered: Feb 2003
Location: Sunny Southport, again.
Distribution: PCLinuxOS 0.93 and 0.92, Vector sometimes
Posts: 825

Rep: Reputation: 30
You may well have to modify your /etc/fstab file, so post it here and it should be possible to alter it to let you do what you want.
 
Old 06-14-2003, 06:33 AM   #3
lokee
Member
 
Registered: Feb 2003
Distribution: Gentoo
Posts: 381

Rep: Reputation: 30
In your /etc/fstab file, make sure the partition isn't loaded with the 'ro' option,
then put this option: 'umask=0003', it will set all file permissions to 'rwxrwxr-x'.
 
Old 06-14-2003, 07:35 AM   #4
unitcoed
LQ Newbie
 
Registered: Jun 2003
Distribution: RedHat 9, Slackware Live, Slackware 9
Posts: 16

Original Poster
Rep: Reputation: 0
/dev/hda6 /mnt/shared vfat rw,auto,noexec,user,uid=kris 0 0
/dev/hda4 /mnt/music vfat rw,auto,noexec,user,uid=kris 0 0

err.. there isn't an 'ro' option but there is 'rw'...

Should I add the unmask=003 option?

by the way, thanks for the quick replies
-Kris
 
Old 06-14-2003, 09:21 AM   #5
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,378

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
003 is for rwxrwxr--, 002 is for what you suggested. so add umask=000 or umask=002 to the options line yes. (you then won't really need that uid= option...)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
changing devices in RAID 5 malo_umoran Slackware 3 03-31-2005 01:56 AM
Mnt Devices AlmostArtafact Linux - Software 4 12-08-2003 01:15 PM
My Devices in /mnt appear to not be working... Genesis Linux - Hardware 4 06-22-2003 09:58 AM
Changing US keyboard settings to Spain (SP) settings or Mexico. zLinuxz Linux - General 4 12-01-2002 12:49 AM
why cannot i depmod,lsmod as root,it says i have no permisson. whepin Linux - General 2 12-26-2001 07:07 AM


All times are GMT -5. The time now is 07:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration