LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-03-2005, 11:31 PM   #1
tgreiner
LQ Newbie
 
Registered: Jan 2005
Posts: 20

Rep: Reputation: 0
Changing Permissions in Root


I'm running a dual boot system with Redhat 9.0 and Windows XP. The system has two 250GB hard drives -- one for windows and one for linux. I also have an external hard drive that connects via USB or firewire.

I want to be able to see the VFAT disks while running in Linux (one is the windows harddrive and one is an external disk).

While logged in as Root I have been able to mount both drives and can read and write to both of them. I am even able to place a desktop link to both drives. So far, so good.

Then when I log in as a user, the desktop links are gone. The drives are still mounted (because they are listed in fstab) although I need to get to them within /mnt. But the drives are Read Only. I cannot write to them.

So, I log back in as root and try to change the permissions on these drives. The premissions says they belong to root and to the group root. However, when I try to change the permissions I get the response: "These permissions cannot be changed by root."

I've tried the right click to access "properties" and the went to the permissions tab. I've tried chmod while running terminal. All give me versions of the same error message. Root cannot change these permissions.

So, if root cannot change the permissions, who can? How can I get access to these disks when I am something other than the Superuser?

Thanks for your help.
 
Old 02-03-2005, 11:57 PM   #2
Ace07
Member
 
Registered: Feb 2005
Distribution: Fedora Core 3 (2.6.10_1.741)
Posts: 72

Rep: Reputation: 15
@the permissions problem: I would tend to guess that you created the folders in the /mnt folder using root, and thus, they can only be accessed by root. A mounted file system's permissions cannot be changed by any user I think (someone correct me if I am wrong). I suggest you try to unmount them, change the permissions to the physical folders, and mount them again using the "rw" option.

mount /dev/hda1 /mnt/windows/ -o rw

@changing to read-only: Are you sure you specified the "rw" option in fstab? List your /etc/fstab file so I can figure out if anything looks wierd.
 
Old 02-03-2005, 11:58 PM   #3
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,240

Rep: Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324
Here you go:
http://www.linuxquestions.org/questions/history/282478
 
Old 02-04-2005, 10:58 AM   #4
tgreiner
LQ Newbie
 
Registered: Jan 2005
Posts: 20

Original Poster
Rep: Reputation: 0
Works like a charm. You guys are great.

Now for the real newbie question: How would I have found the answer to this, or a similar question, without this service? I have serveral linux books -- two of the really big fat ones on Red Hat, plus about six of the smaller ones -- and none of them discuss fstab in a way that would have led me to this answer.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
changing permissions of document root and cgi-bin abtimoteo Ubuntu 2 08-13-2005 10:36 AM
Changing permissions Mladek Linux - Software 7 07-09-2003 09:57 AM
Changing Permissions linuxfond Linux - Newbie 11 07-01-2003 03:48 PM
Permissions Changing ew2003 Linux - Newbie 1 04-29-2003 05:30 PM
Changing root@localhost to root@domain.com Stingreen Linux - General 14 12-17-2002 07:21 PM


All times are GMT -5. The time now is 10:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration