LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-27-2003, 02:29 PM   #1
linuxfond
Member
 
Registered: Jan 2003
Location: Belgium
Distribution: Mandrake 9.2
Posts: 475

Rep: Reputation: 30
Changing Permissions


I have a "misterious" problem.

There is a folder, owned by ROOT. It is chmoded 777 because I can not write to it otherwise.

It is /mnt/windzoo/linux_backups/ on my 2nd hard drive.

Now I can not change either owner nor permissions even if I log in as root. The shell tells: Read-only!

Bah! 777 is certainly not read-only, and I don't see why I could chmod it the 1st time, and not the 2nd time.
Can anyone reveal the mystery? I could not find anything in the man. How to change the ownership of my backup dir, and set correct permissions (755).
Thanks, Lu
 
Old 06-27-2003, 03:05 PM   #2
masand
LQ Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
see the permissions for this partion in fstab,see if the partion is mounted as read-only
 
Old 06-30-2003, 07:27 AM   #3
linuxfond
Member
 
Registered: Jan 2003
Location: Belgium
Distribution: Mandrake 9.2
Posts: 475

Original Poster
Rep: Reputation: 30
I see. This is the corresponding fstab entry:

/dev/hda5 /mnt/windows vfat iocharset=iso8859-1,codepage=850,umask=0 0 0

To mount it in a read-write mode I should add:
/dev/hda5 /mnt/windows vfat defaults iocharset=iso8859-1,codepage=850,umask=0 0 0

Is that right?
 
Old 06-30-2003, 07:30 AM   #4
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
The space in there will cause some error, remove the space between defaults and io, change it to a comma with no space:
/dev/hda5 /mnt/windows vfat defaults,iocharset=iso8859-1,codepage=850,umask=0 0 0

HTH

Cool
 
Old 06-30-2003, 07:31 AM   #5
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
no, it should be rw by default anyway. no reason it would actually be read only, unless "mount" does actually say it is mounted as such. having that defulat there by itself will screw the line up as there will be too many parameters (comma not a space if you want to try that anyway)
 
Old 06-30-2003, 07:32 AM   #6
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
And now that I properly read over the thread (as I should have) I suggest you add another zero and a 2 to the end:
/dev/hda5 /mnt/windows vfat defaults,iocharset=iso8859-1,codepage=850,umask=002,rw 0 0

Along with a rw to say "read and write".



Cool
 
Old 06-30-2003, 10:18 AM   #7
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
I'm not sure you can change it's premissions. It a windows partition and the fat32 filesystem doesn't support permissions. If you type "ls -l" it will show you a long listing of a directory (including the permissions). These are pretty much garbage (ie ignored) when looking at a windows partition from linux. So you can actually write to that partition but changing permissions is ignored because they can't get written down anywhere.
 
Old 07-01-2003, 06:49 AM   #8
linuxfond
Member
 
Registered: Jan 2003
Location: Belgium
Distribution: Mandrake 9.2
Posts: 475

Original Poster
Rep: Reputation: 30

Guys, you could not get me more confused... So, can I change vfat permissions or I can't?
 
Old 07-01-2003, 07:16 AM   #9
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Not with a chmod, but during the mount portion of it you can. You can use the umask in the options section to specify the permissions you wish to set.

Cool
 
Old 07-01-2003, 10:34 AM   #10
linuxfond
Member
 
Registered: Jan 2003
Location: Belgium
Distribution: Mandrake 9.2
Posts: 475

Original Poster
Rep: Reputation: 30
All right, you mean:

umask=002,rw 0 0

Is that the way?
The whole entry will be:
/dev/hda5 /mnt/windows vfat defaults,iocharset=iso8859-1,codepage=850,umask=002,rw 0 0



Last edited by linuxfond; 07-01-2003 at 10:36 AM.
 
Old 07-01-2003, 11:17 AM   #11
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
defaults is going to confuse everything, remove defaults since you are specifying so much. defaults is what you use when you aren't specifying options. For more options info see the man page for mount.



Cool
 
Old 07-01-2003, 03:48 PM   #12
linuxfond
Member
 
Registered: Jan 2003
Location: Belgium
Distribution: Mandrake 9.2
Posts: 475

Original Poster
Rep: Reputation: 30
OK. Thanks everybody!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing Permissions jong357 Linux - General 5 01-25-2005 03:39 PM
Changing Many Permissions at Once food188 Linux - General 3 11-02-2003 09:17 AM
changing permissions... ashesh Linux - General 3 08-16-2003 12:32 AM
Changing permissions Mladek Linux - Software 7 07-09-2003 09:57 AM
Permissions Changing ew2003 Linux - Newbie 1 04-29-2003 05:30 PM


All times are GMT -5. The time now is 07:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration