LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-24-2011, 08:33 AM   #1
yogesh.dhake
LQ Newbie
 
Registered: Aug 2011
Location: Mumbai,India
Posts: 9

Rep: Reputation: Disabled
changing keyboardmap from command line


I am using Fedora12 on desktop.
I tried to change keymap from systm->preferences->keyboard->layout.
This changes my keymap successfully.
I want to perform above activity using command line for my powerpc target. My powerpc target environment do not have KDE,GNOME or any x-windowing support.Can any one help me? which command and which files to be overlooked for this?
 
Old 08-24-2011, 08:46 AM   #2
scottro11
Member
 
Registered: Jun 2009
Location: NYC
Posts: 260

Rep: Reputation: 58
Possibly setxkbmap, though that's usually used for language--for example, on a US keyboard, if I go setxkbmap gb I get the British monetary pound sign for shift+4. If I then go setxkbmap us it goes back to #.


In most cases, the files would be in /usr/share/X11/xkb but I'm not sure what you need under there. However, the man page indicates that you can use -keycodes or -keymap as an option, and under that xkb directory are both keycodes and keymap and both have Macintosh listed as an option.
 
Old 08-24-2011, 09:32 AM   #3
yogesh.dhake
LQ Newbie
 
Registered: Aug 2011
Location: Mumbai,India
Posts: 9

Original Poster
Rep: Reputation: Disabled
hi scottro11,
thanks for reply.

sorry i want to load keybaord layout.
Also I do not have any X server functionalities on my target.
 
Old 08-24-2011, 11:27 PM   #4
LBM
Member
 
Registered: Aug 2010
Location: Denmark
Distribution: Debian
Posts: 88

Rep: Reputation: 0
Maybe this is working?
http://www.howtoforge.com/changing-l...-distributions
 
Old 08-25-2011, 07:56 AM   #5
yogesh.dhake
LQ Newbie
 
Registered: Aug 2011
Location: Mumbai,India
Posts: 9

Original Poster
Rep: Reputation: Disabled
thanks for reply.
system-config-keybaord not works on my target. It shows command not found.

additionally i tried setup command which is not working on my target. It shows command not found.

Also i tried loadkeys on my target but it loads only keymap for jp106 when i try "loadkeys jp106".
When I connect japanese keyboard, it seems that keyboard layout has not changed(e.g on JIS keyboard we have doublequote(") at 2,but when I press shift+2,it still shows me @ symbol. This shows that my keylayout is still US keyboard layout) My problem is how will i change keyboard layout from command line? Is there anything else I need to do on my target other than "loadkeys"?

Hi all, kindly note that my target environment do not have x windowing system.
 
Old 08-25-2011, 09:59 AM   #6
lithos
Senior Member
 
Registered: Jan 2010
Location: SI : 45.9531, 15.4894
Distribution: CentOS, OpenNA/Trustix, testing desktop openSuse 12.1 /Cinnamon/KDE4.8
Posts: 1,144

Rep: Reputation: 217Reputation: 217Reputation: 217
Hi,

I suppose you need this or this
help
 
Old 08-25-2011, 10:48 AM   #7
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
The keymaps are in /usr/share/kbd/keymaps/ you can load one with the "loadkeys" command.

Markus
 
Old 08-25-2011, 10:50 AM   #8
yogesh.dhake
LQ Newbie
 
Registered: Aug 2011
Location: Mumbai,India
Posts: 9

Original Poster
Rep: Reputation: Disabled
Thanks Lithos,

My keyboard file located at /etc/sysconfig has below stuff before changing
KEYTABLE="us"
MODEL="pc105+inet"
LAYOUT="us"
KEYBOARDTYPE="pc"

First I have loaded japanese keymap as follows
# loadkeys jp106

Secondly I changed only KEYTABLE="jp106" but I have not seen any change in the language.

So Finaly ,I changed it to below
KEYTABLE="jp106"
MODEL="pc105+inet"
LAYOUT="jp106"
KEYBOARDTYPE="pc"

I then reboot the system.

While rebooting system asked it's changing the folder names? y/n
I selected y

Now when i open the terminal it's not showing any changes related to Japanese keyboard layout.
What is extra thing i need to do?
 
Old 08-25-2011, 10:52 AM   #9
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
you'll need the whole path
Code:
loadkeys /usr/share/kbd/keymaps/i386/qwerty/jp106.map.gz
Markus
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing default language from command line stinky_tofu Red Hat 8 12-30-2008 02:55 PM
mail command - changing from line Murdock1979 Linux - Server 4 05-19-2008 03:54 PM
changing priority class from the command line stellarmarine1 Linux - General 5 08-21-2004 09:32 PM
Changing Wallpaper from Command Line b_suny Linux - General 2 06-27-2004 06:52 AM
Changing video resolution from command line? lhouk Linux - General 4 04-15-2004 03:16 PM


All times are GMT -5. The time now is 04:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration