LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-18-2014, 07:05 AM   #1
umeshgupta1987
LQ Newbie
 
Registered: Oct 2010
Posts: 14

Rep: Reputation: 0
Changing IP but not visible in ifconfig


Hi Friends,

I have installed SuSE Linux Enterprise server 10 on VM Ware workstation. I have changed ip, so that i can access it via my host machine. but IP changes are not reflected in ifconfig output.


-----
testmachine:~ # ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:62 errors:0 dropped:0 overruns:0 frame:0
TX packets:62 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4128 (4.0 Kb) TX bytes:4128 (4.0 Kb)

testmachine:~ # cd /etc/sysconfig/network
testmachine:/etc/sysconfig/network # ls -ltr
total 65
drwx------ 2 root root 48 May 3 2007 providers
-rw-r--r-- 1 root root 239 May 4 2007 ifroute-lo
-rw-r--r-- 1 root root 27470 May 4 2007 ifcfg.template
drwxr-xr-x 2 root root 208 Nov 28 2012 ifservices.template
drwxr-xr-x 2 root root 1272 Nov 28 2012 scripts
drwxr-xr-x 2 root root 88 Nov 28 2012 if-up.d
drwxr-xr-x 2 root root 88 Nov 28 2012 if-down.d
-rw-r--r-- 1 root root 6736 Jan 18 16:20 dhcp
-rw-r--r-- 1 root root 24 Jan 18 17:02 routes.YaST2save
-rw-r--r-- 1 root root 283 Jan 18 17:02 ifcfg-eth-id-00:0c:29:bb:a9:3f
-rw-r--r-- 1 root root 141 Jan 18 17:04 ifcfg-lo
-rw-r--r-- 1 root root 9254 Jan 18 17:05 config
testmachine:/etc/sysconfig/network # cat ifcfg-eth-id-00:0c:29:bb:a9:3f
BOOTPROTO='static'
BROADCAST=''
ETHTOOL_OPTIONS=''
IPADDR='192.168.0.10'
MTU=''
NAME='VMWare 82545EM Gigabit Ethernet Controller (Copper)'
NETMASK='255.255.255.0'
NETWORK=''
REMOTE_IPADDR=''
STARTMODE='auto'
UNIQUE='rBUF.5dU8kR7eh2C'
USERCONTROL='no'
_nm_name='bus-pci-0000:02:01.0'
testmachine:/etc/sysconfig/network # service network restart
Shutting down network interfaces:
eth1 device: Intel Corporation 82545EM Gigabit Ethernet Controller (Copper) (rev 01)
No configuration found for eth1
Nevertheless the interface will be shut down. done
Shutting down service network . . . . . . . . . . . . . done
Hint: you may set mandatory devices in /etc/sysconfig/network/config
Setting up network interfaces:
lo
lo IP address: 127.0.0.1/8 done
eth1 device: Intel Corporation 82545EM Gigabit Ethernet Controller (Copper) (rev 01)
No configuration found for eth1 unused
Setting up service network . . . . . . . . . . . . . . done
testmachine:/etc/sysconfig/network # ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:72 errors:0 dropped:0 overruns:0 frame:0
TX packets:72 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4780 (4.6 Kb) TX bytes:4780 (4.6 Kb)

testmachine:/etc/sysconfig/network #
-----

Please help me on this!!

Regards

Umesh
 
Old 01-18-2014, 07:32 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,331
Blog Entries: 55

Rep: Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529Reputation: 3529
Quote:
Originally Posted by umeshgupta1987 View Post
(..) IP changes are not reflected in ifconfig output. (..)

Code:
              No configuration found for eth1                         unused
Notice that warnings have a distinct meaning: do not to ignore them.

In this case you don't have a "/etc/sysconfig/network/ifcfg-eth1" configuration file as in
Code:
cp /etc/sysconfig/network/ifcfg-eth-id-00:0c:29:bb:a9:3f /etc/sysconfig/network/ifcfg-eth1
service network restart
 
1 members found this post helpful.
Old 01-22-2014, 02:27 PM   #3
umeshgupta1987
LQ Newbie
 
Registered: Oct 2010
Posts: 14

Original Poster
Rep: Reputation: 0
Smile

thanks mate.. That worked..

Regards

Umesh
 
  


Reply

Tags
suse10


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Why "-bash: ifconfig : command not found" when typing "$ifconfig" dangdtvn Linux - Server 9 09-20-2013 07:01 AM
cscope usage options not visible, but the search results are visible balemarthy Linux - Newbie 1 02-15-2012 03:46 PM
How to use samba implementing some files can visible and some files can not visible willie118 Linux - Server 7 09-18-2007 01:27 AM
connecting /sbin/ifconfig to bash command ifconfig flammable2 Fedora 4 11-12-2005 08:58 AM
changing your NIC settings via ifconfig? bpk Linux - Networking 1 06-11-2004 05:39 PM


All times are GMT -5. The time now is 06:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration