LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-20-2005, 08:38 AM   #1
mikeymorgan
Member
 
Registered: Mar 2005
Location: Devon, England
Distribution: Slackware 10.1, Ubuntu 5.04
Posts: 109

Rep: Reputation: 15
Changing Fstab in ubuntu to mount vfat drive


hey, how do i change the fstab so that i can mount a FAT partition in ubuntu. Also i was wondering how to change the default OS in GRUB to boot windows 1st (dont hurt me!)
 
Old 06-20-2005, 09:55 AM   #2
elsheikhmh
Member
 
Registered: Aug 2004
Location: Cairo, Egypt
Distribution: Slackware
Posts: 101

Rep: Reputation: 15
/etc/grub.conf
default=0

notice the order of windows in os list, change default to it (-1)

mustafa
 
Old 06-20-2005, 09:56 AM   #3
mikeymorgan
Member
 
Registered: Mar 2005
Location: Devon, England
Distribution: Slackware 10.1, Ubuntu 5.04
Posts: 109

Original Poster
Rep: Reputation: 15
thanks
 
Old 06-20-2005, 10:15 AM   #4
mikeymorgan
Member
 
Registered: Mar 2005
Location: Devon, England
Distribution: Slackware 10.1, Ubuntu 5.04
Posts: 109

Original Poster
Rep: Reputation: 15
it doesnt seem to be in /etc
maybe it would help if when i installed it i said to install it on the 1st hard drive?
 
Old 06-20-2005, 10:21 AM   #5
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
AFAIK Ubuntu used /boot/grub/menu.lst for the bootloader configuration (instead of /etc/grub.conf).

For that FAT drive, please provide the output of 'fdisk -l'. In general it could look like this:
Code:
/dev/hdxy   /<mountpoint>   vfat   auto,users,umask=0  0 0
 
Old 06-20-2005, 10:23 AM   #6
mikeymorgan
Member
 
Registered: Mar 2005
Location: Devon, England
Distribution: Slackware 10.1, Ubuntu 5.04
Posts: 109

Original Poster
Rep: Reputation: 15
cheers
 
Old 06-20-2005, 10:37 AM   #7
mikeymorgan
Member
 
Registered: Mar 2005
Location: Devon, England
Distribution: Slackware 10.1, Ubuntu 5.04
Posts: 109

Original Poster
Rep: Reputation: 15
---------------------------------------------------------------------------------------
Disk /dev/hda: 80.0 GB, 80060424192 bytes
255 heads, 63 sectors/track, 9733 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 9732 78172258+ 7 HPFS/NTFS

Disk /dev/hdb: 20.4 GB, 20496236544 bytes
255 heads, 63 sectors/track, 2491 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 1870 2491 4996215 c W95 FAT32 (LBA)
/dev/hdb2 1 124 995998+ 82 Linux swap / Solaris
/dev/hdb3 * 125 1869 14016712+ 83 Linux

Partition table entries are not in disk order
---------------------------------------------------------------------------------------

is what i get (Hdb1 is the FAT32 drive i wanna mount)

Last edited by mikeymorgan; 06-20-2005 at 10:39 AM.
 
Old 06-20-2005, 11:04 AM   #8
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
First you need to create a moutpoint:

Code:
sudo mkdir /mnt/hdb1
Now add the following line to /etc/fstab
Code:
/dev/hdb1    /mnt/hdb1   vfat    defaults,users,umask=0  0 0
These parameter should work. 'users' means that all users are allowed to mount and unmount the drive, 'umask' controls the default permissions.
 
Old 06-20-2005, 11:10 AM   #9
mikeymorgan
Member
 
Registered: Mar 2005
Location: Devon, England
Distribution: Slackware 10.1, Ubuntu 5.04
Posts: 109

Original Poster
Rep: Reputation: 15
ive tried to change the fstab, but it only opens as read-only and i cant access the root user via ubuntu with is absolutley pathetic. I might go back to slack for the 4th time unless someone tells me please how to access the root user in ubuntu.
 
Old 06-20-2005, 04:56 PM   #10
elsheikhmh
Member
 
Registered: Aug 2004
Location: Cairo, Egypt
Distribution: Slackware
Posts: 101

Rep: Reputation: 15
[google]
1. Ubuntu disables the root user account by default. To enable it, open up a console and type sudo and then your regular user's password. Then type passwd root to set the root user's password. You should now be able to log in as root.

OR

2. To set the root password use this command
sudo passwd
It will first prompt for a password, this is your user's password. Then it will ask you the password to set for root. After you set the password, you can then login as root or su to root.
[/google]
 
Old 06-20-2005, 04:57 PM   #11
elsheikhmh
Member
 
Registered: Aug 2004
Location: Cairo, Egypt
Distribution: Slackware
Posts: 101

Rep: Reputation: 15
actually, the topic is at

http://www.linuxforums.org/forum/ptopic44799.html

long live GOOGLE!

i don't know what would the life be without google?!

Last edited by elsheikhmh; 06-20-2005 at 04:58 PM.
 
Old 06-23-2005, 06:44 AM   #12
mikeymorgan
Member
 
Registered: Mar 2005
Location: Devon, England
Distribution: Slackware 10.1, Ubuntu 5.04
Posts: 109

Original Poster
Rep: Reputation: 15
How would you change GRUB though?
 
Old 06-23-2005, 07:23 AM   #13
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
Not sure what you mean. Didn't we discuss this above already?
Edit /boot/grub/menu.lst:
Code:
sudo gedit /boot/grub/menu.lst
Or do you want to change grub to lilo?
 
Old 06-23-2005, 07:50 AM   #14
prasanta
Member
 
Registered: Mar 2005
Location: India
Distribution: Debian
Posts: 368

Rep: Reputation: 37
For setting the default os to be windows you have to edit your /boot/grub/menu.lst file as root. It should look somewhat like this...

default 0

title Windows 95/98/NT/2000
root (hd0,0)
makeactive
chainloader +1

title Linux
root (hd0,1)
kernel /vmlinuz root=/dev/hda2 ro

I hope that this would help you.

-Prasanta
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't mount flash drive with vfat? maq Linux - Hardware 2 04-10-2005 04:57 PM
mount/fstab issues, vfat filename conventions: 8.3 vs long tisource Linux - Software 2 03-23-2005 09:22 PM
Changing ownership of vfat mount maamold Linux - Software 2 02-25-2005 02:27 AM
What fstab mount setting do you use to get full access to a vfat drive? BarkingBonefish Linux - Newbie 4 03-12-2004 12:36 AM
want user to be able to mount vfat (fstab ?) qwijibow Linux - Software 4 11-13-2003 10:43 AM


All times are GMT -5. The time now is 09:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration