LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-11-2003, 01:00 PM   #1
pmh6310
LQ Newbie
 
Registered: Jun 2003
Location: Dallas, Tx
Distribution: Red Hat 8.0
Posts: 8

Rep: Reputation: 0
Cool changing default WM


Ok,

Here's the thing....I installed redhat 8.0 and have determined that both Gnome and KDE are just a little too much. I hear its not a good idea to totally remove them but I wish to use a more lightweight WM such as Fluxbox. I was wondering what files I need to change to make Fluxbox my default WM and not Gnome. Thanks.
 
Old 06-11-2003, 01:27 PM   #2
tangle
Senior Member
 
Registered: Apr 2002
Location: Smithville, TN
Distribution: Slackware
Posts: 1,745

Rep: Reputation: 71
make or edit the file .xinitrc file in the user's home directory so it looks like this.
exec fluxbox
You might need to set the path to the script that will start fluxbox, such as:
exec /usr/share/fluxbox.
 
Old 06-11-2003, 01:54 PM   #3
pmh6310
LQ Newbie
 
Registered: Jun 2003
Location: Dallas, Tx
Distribution: Red Hat 8.0
Posts: 8

Original Poster
Rep: Reputation: 0
well I have already edited the .xinitrc file to include the line

exec /usr/local/bin/fluxbox

but when Linux boots up I still only have the options to use KDE or Gnome from the login menu. And if I try to launch fluxbox while I'm running Gnome it fails because it says a WM is already running (which makes sense) but I want to boot straight into fluxbox or at least have the option to select it from the login screen. thanks for your help.
 
Old 06-11-2003, 02:04 PM   #4
hanzerik
Member
 
Registered: Jan 2002
Location: Cheyenne Wyoming
Distribution: Debian/Raspbian/Mint
Posts: 717

Rep: Reputation: 32
edit /etc/inittab

change this:
from id:5:initdefault:

To: id:3:initdefault:

This will make the system boot up into a console, At the console, login as your user with username/password. Then Type startx
 
Old 06-11-2003, 03:15 PM   #5
pmh6310
LQ Newbie
 
Registered: Jun 2003
Location: Dallas, Tx
Distribution: Red Hat 8.0
Posts: 8

Original Poster
Rep: Reputation: 0
Hey thanks that worked
 
Old 06-11-2003, 05:00 PM   #6
hanzerik
Member
 
Registered: Jan 2002
Location: Cheyenne Wyoming
Distribution: Debian/Raspbian/Mint
Posts: 717

Rep: Reputation: 32
No Prob
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing default OS in Grub .95 gautcha Linux - Newbie 8 05-03-2005 11:30 PM
Changing the default language... njschroe SUSE / openSUSE 5 04-24-2005 01:44 PM
Changing default editor Tony Empire Linux - Software 5 12-27-2004 12:45 PM
HELP: changing default OS to boot.... kevingpo Fedora - Installation 4 12-13-2004 01:41 PM
Changing default Browser Crashed_Again Linux - General 3 01-29-2003 09:31 PM


All times are GMT -5. The time now is 04:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration