LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-05-2005, 11:31 PM   #1
gautcha
LQ Newbie
 
Registered: Apr 2005
Distribution: Fedora Core 3
Posts: 7

Rep: Reputation: 0
Changing default OS in Grub .95


I am dualbooting Fedora Core 3/Windows XP and I just loaded the Fedora side of my dualboot and forgot to tell Grub to default to Windows XP (So my wife does'nt have to mess with selecting) and I would like to change it to default to Windows unless prompted to load Fedora. Can someone explain (in total noob terms) how to do this please?
 
Old 04-05-2005, 11:35 PM   #2
vharishankar
Senior Member
 
Registered: Dec 2003
Posts: 3,161
Blog Entries: 4

Rep: Reputation: 135Reputation: 135
Change the line
Code:
default=x
Where x is the option number in /etc/grub.conf file or /boot/grub/menu.lst file.
 
Old 04-05-2005, 11:38 PM   #3
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,045

Rep: Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914
Have a look in your grub.conf. There will be a default=? line. Below this will be (at least) two "title" line.
First title line is default=1, second is default=2, ...
Whatever the default specifies is what gets selected if nothing happens within the timeout period - you can change that too if you want.

Set as appropriate, and you're in business.
 
Old 04-06-2005, 12:18 AM   #4
gautcha
LQ Newbie
 
Registered: Apr 2005
Distribution: Fedora Core 3
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks for the help, problem solved.
 
Old 04-25-2005, 06:25 PM   #5
ronish
LQ Newbie
 
Registered: Apr 2005
Posts: 2

Rep: Reputation: 0
I am a complete noob to linux. Can anyone please give me a step by step instruction how to change the default boot in grub please.

When I write /boot/grub/menu.lst in the terminal, I get permission denied error. So I wrote "su" and it asked for the password. I typed the password and it still gives me the permission denied error.....
 
Old 05-01-2005, 05:06 AM   #6
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,045

Rep: Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914
ronish - what distro are you using ???.

Try looking for a "root terminal" option, and use that.
Also try using "su -" instead of "su". Might make a difference - maybe ...
 
Old 05-03-2005, 11:42 PM   #7
ronish
LQ Newbie
 
Registered: Apr 2005
Posts: 2

Rep: Reputation: 0
hi thanks for replying. im using redhat 9. heres a pics of wot i typed. [img=http://img116.echo.cx/img116/7854/screenshot1fo.th.png]

i know i may have missed something. i just need to get to the grub.conf so i can change the default to boot windows.
 
Old 05-04-2005, 12:23 AM   #8
tuxrules
Senior Member
 
Registered: Jun 2004
Location: Chicago
Distribution: Slackware64 -current
Posts: 1,144

Rep: Reputation: 56
Two things...first you tried to execute a text file instead of opening it by this command

#/boot/grub/menu.lst instead you should do this

#gedit /boot/grub/menu.lst

gedit is a gnome text editor...you can use anyother.

Second, as far as I know grub.conf file is not contained in /etc directory...it is contained in /boot/grub directory.

Now menu.lst and grub.conf are essentially same files with different names so you must have either one of them but not both...


I hope this clears out our confusion
 
Old 05-04-2005, 12:30 AM   #9
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,045

Rep: Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914Reputation: 1914
Looks like an easy one - you need to edit the file. You are trying to execute it.
After the su -, try
Code:
vim /boot/grub/menu.lst
Hopefully RH9 supports that full-screen editor (I'll check tonight when I get home).
Do your updates, then save as normal.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting password on grub, wha to do after changing default values in /boot/grub/menu. sarajevo Linux - Security 1 08-17-2005 09:01 PM
changing the default in grub hari78 Linux - Newbie 2 06-03-2005 11:43 AM
changing grub default boot sbcdivision63 Red Hat 5 11-09-2003 01:55 AM
changing default WM pmh6310 Linux - Newbie 5 06-11-2003 06:00 PM
changing grub boot default tumnus Linux - Newbie 2 02-04-2003 04:53 PM


All times are GMT -5. The time now is 08:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration