LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-12-2010, 02:46 PM   #1
konzo
Member
 
Registered: Dec 2008
Location: Bulgaria
Distribution: Debian / Slackware / Ubuntu
Posts: 230

Rep: Reputation: 33
Change to GUI as default login


I want to make my system load in GUI to login. I set Login Manager in KDE, and found in google inittab. There maybe I have to change run level from 3 to 4 (X11 with KDE), but I am not sure to change the file. I am afraid to broke my system.

Do I have to change run level in inittab to boot in GUI?

Other way is to make image of the partition and to try it...
 
Old 01-12-2010, 02:48 PM   #2
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Yes, inittab is usually the way to do what you want.

Edit the file as root, and look for a line like this:

Code:
id:3:initdefault:
And change the 3 to a 4:

Code:
id:4:initdefault:
Sasha
 
Old 01-12-2010, 02:51 PM   #3
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
Easiest way is to edit it with kwrite, in the terminal enter:
Code:
kdesu kwrite /etc/inittab
(enter root password)
and change the 3 to 4 in this line:
Code:
# Default runlevel. (Do not set to 0 or 6)
id:3:initdefault:
Faster typers! I'm sick of 'em!

Last edited by brianL; 01-12-2010 at 02:53 PM.
 
Old 01-12-2010, 03:28 PM   #4
konzo
Member
 
Registered: Dec 2008
Location: Bulgaria
Distribution: Debian / Slackware / Ubuntu
Posts: 230

Original Poster
Rep: Reputation: 33
Life isn't easy

Thank you both!
 
Old 01-12-2010, 03:30 PM   #5
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Life's not easy, no; but that runlevel fix was, huh?

Happy trails.

Sasha
 
Old 01-12-2010, 03:36 PM   #6
konzo
Member
 
Registered: Dec 2008
Location: Bulgaria
Distribution: Debian / Slackware / Ubuntu
Posts: 230

Original Poster
Rep: Reputation: 33
Yeah it was, but it log me automatically. I was thinking that I will have to type user and password. I just want to omit startx.

There is no full happiness
 
Old 01-12-2010, 03:42 PM   #7
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
That's something you need to configure in the "Settings" manager somewhere. I am surprised that it defaulted to logging you in automatically , but it certainly isn't the way I would leave it.

Using KDE, Go into the settings manager (usually as root, using `kdesu` from a console) and check the settings for your Login Splash and/or Login Manager. It should be relatively easy to find these settings if you poke around enough.

I'm no longer using KDE, or if I were, I'd trace the steps for you. If you cannot find the right items to fix this, let us know. Someone will help.

Sasha
 
1 members found this post helpful.
Old 01-12-2010, 04:57 PM   #8
konzo
Member
 
Registered: Dec 2008
Location: Bulgaria
Distribution: Debian / Slackware / Ubuntu
Posts: 230

Original Poster
Rep: Reputation: 33
Don't know why, but kdesu don't work in my machine. Anyway I know what you are saying. Auto-login was not default - I am too curious and click every option. Now I fix it and everything is ok.

First time is always hard.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
change the default login santana Ubuntu 2 04-24-2007 04:32 PM
Can't login after language change in GUI costask Linux - Software 0 04-26-2004 05:04 AM
Change Default FTP login Bertha Linux - General 2 03-09-2004 03:46 PM
How can i change the default GUI ? zokter Linux - Newbie 2 09-27-2003 08:08 PM
how to change default X login manager? NeoAnderson Linux - General 6 08-24-2002 11:33 PM


All times are GMT -5. The time now is 07:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration