LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-16-2004, 12:50 PM   #1
scottman
Member
 
Registered: Jul 2004
Location: USA
Distribution: Slackware, FreeBSD, LFS
Posts: 72

Rep: Reputation: 15
Change suspend mode defaults


I need to either stop my computer from entering sleep and suspend mode after idle time,
or vastly increase the default time. I have read the limited information available on acpi,
and found nothing about how to change these. I now know how to PUT my computer into
sleep mode with /proc, but still now clue how to change the darn things that's doing it after
10 minutes.

I need a bash solution, this is causing me problems at run level 3. Here's more details:
-Boot up slackware to run level 3
-View LFS book with lynx
-<alt>-f2 to another shell and chroot to do LFS compiling
-Start a long compile. I try not to interfere with this, as I've had problems
using any other shells while this was going on.
-After 10 or so minutes, my screen goes blank, and my cpu enters sleep or suspend mode.
-I enter a key that wouldn't effect the compile (<alt>-f2 again or something)
-Screen comes back up, compiling is stopped dead in its tracks.
-A single tear rolls down my face.

(I didn't know which forum to put this, as it's more a Slackware issue than LFS, so I
threw it in newbie since it regards basic system setup)
 
Old 09-16-2004, 06:00 PM   #2
gypsy_rabbi
Member
 
Registered: Sep 2004
Distribution: Ubuntu
Posts: 109

Rep: Reputation: 15
Stupid question: what happens if you just kill acpid? Or stop it from coming up at boot?
 
Old 09-16-2004, 06:55 PM   #3
scottman
Member
 
Registered: Jul 2004
Location: USA
Distribution: Slackware, FreeBSD, LFS
Posts: 72

Original Poster
Rep: Reputation: 15
Definately worth trying :P

Do you know how I would kill it from the command line without looking up the pid?
That way I could do it only when I'm working on LFS, vice shutting down the startup script

Thanks gypsi
 
Old 09-16-2004, 07:27 PM   #4
gypsy_rabbi
Member
 
Registered: Sep 2004
Distribution: Ubuntu
Posts: 109

Rep: Reputation: 15
Ah, I see, not a stupid question after all!

To kill it, something like:
kill $(ps -ef | grep acpid | grep sbin | awk '{print $2}')

To stop it from coming up at boot (in Slack):
chmod ugo-x /etc/rc.d/rc.acpid

GR
 
Old 09-17-2004, 12:27 AM   #5
scottman
Member
 
Registered: Jul 2004
Location: USA
Distribution: Slackware, FreeBSD, LFS
Posts: 72

Original Poster
Rep: Reputation: 15
Great, thanks
 
Old 09-20-2004, 11:08 AM   #6
scottman
Member
 
Registered: Jul 2004
Location: USA
Distribution: Slackware, FreeBSD, LFS
Posts: 72

Original Poster
Rep: Reputation: 15
Well, I ended up killing acpid and it didn't do the trick. It turns out that by compiling
acpid support into my kernel I was allowing it to also perform acpid tasks as well as
the daemon. The following line in my /etc/rc.d/rc.M is what was doing it.

/bin/setterm -blank 15 -powersave powerdown -powerdown 60

This is set before acpid is even loaded, turns out it's bash talking directly to the kernel.
The -blank option is how you change the time in minutes. I guess acpid just allows another
way for programs to communicate with acpid through /proc.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
turn off suspend mode messiahnet Linux - Software 1 05-09-2005 10:16 AM
How can I change display mode from character mode to graph mode wuzhong Linux - Hardware 1 08-08-2004 09:36 AM
help turning off suspend mode billman424 Linux - Laptop and Netbook 1 03-27-2004 05:03 AM
SUSE won't go into stand-by/suspend mode pmwalter Linux - Newbie 1 02-17-2004 01:12 PM
comp. goes to suspend mode every minute psionides Linux - Laptop and Netbook 0 10-06-2003 01:34 PM


All times are GMT -5. The time now is 11:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration