LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-04-2012, 03:57 AM   #1
kizznewbie
LQ Newbie
 
Registered: Oct 2012
Posts: 5

Rep: Reputation: Disabled
Unhappy Change RPC.RQUOTAD's port in Red Hat Linux 6.0


Hi Guys!
Please help me to change the RPC.RQUOTAD's port number in Red Hat Linux 6.0
I have tried to
Add the following two lines to the /etc/services file
Quote:
rquotad 4003/tcp

rquotad 4003/udp
and configure NFS services to use fixed ports by Opening /etc/sysconfig/nfs
my /etc/sysconfig/nfs file:
Code:
LOCKD_TCPPORT=32803
LOCKD_UDPPORT=32769
MOUNTD_PORT=892
RQUOTAD_PORT=4003
STATD_PORT=662
STATD_OUTGOING_PORT=2020
and then restart the nfs service, portmap service but the rquotad's port number still didn't change...
when i type "rpc.rquotad -p" i recieve this error: "invalid option -p"
please help me
thanks for any help
have a nice day

Last edited by kizznewbie; 10-04-2012 at 06:55 AM.
 
Old 10-04-2012, 05:54 AM   #2
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,260

Rep: Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328
The first qn is which port num do you want it to use; you've got 2 different ones there...
The default as per /etc/services is
Code:
rquotad         875/tcp                         # rquota daemon
rquotad         875/udp                         # rquota daemon
which matches the default setting in /etc/sysconfig/nfs.

Unless you've got a VERY good reason, I'd leave it as that.
If you insist on changing it, make sure you change both(!) files to match.

Assuming you have iptables on, you'll have to amend that to match as well.
 
Old 10-04-2012, 07:10 AM   #3
kizznewbie
LQ Newbie
 
Registered: Oct 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by chrism01 View Post
The first qn is which port num do you want it to use; you've got 2 different ones there...
The default as per /etc/services is
Code:
rquotad         875/tcp                         # rquota daemon
rquotad         875/udp                         # rquota daemon
which matches the default setting in /etc/sysconfig/nfs.

Unless you've got a VERY good reason, I'd leave it as that.
If you insist on changing it, make sure you change both(!) files to match.

Assuming you have iptables on, you'll have to amend that to match as well.
Hi Chris
I need to configure port number of RPC.rquotad because i need to configure firewall for NFS services to use fixed port!
I have made both file matched like u said but the port number still is a random number
I read this : http://www.lowth.com/LinWiz/nfs_help.html , it show that rquotad's port number is a random number so it doesn't have default value.
Anyway, thanks u a lot
 
Old 10-04-2012, 07:37 AM   #4
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,260

Rep: Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328
Please don't edit your orig post; it makes nonsense of my comment; please revert it to the original.
You need to edit the files, not your post.

In any case, setting those values there should work. Of course, you'll have to restart the nfs daemon etc.
 
Old 10-05-2012, 02:37 AM   #5
kizznewbie
LQ Newbie
 
Registered: Oct 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by chrism01 View Post
Please don't edit your orig post; it makes nonsense of my comment; please revert it to the original.
You need to edit the files, not your post.

In any case, setting those values there should work. Of course, you'll have to restart the nfs daemon etc.
sorry about this, i mean i change thoses files in the linux machine so i edit my post too. my files were edited and linux machine was restart too but the quotad's port number still didn't change...where's my problem...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] rpc.rquotad is using port number 993 Mr. ameya sathe Linux - Server 5 02-10-2013 12:07 AM
Is there rpc.rquotad in SUSE 10 ? fanner Linux - Software 0 05-26-2008 05:07 AM
RedHat 9 . rpc.rquotad info wombatz Linux - Networking 2 06-01-2004 09:13 PM
NFS quotas rpc rquotad wlfdgcrkz Linux - Software 0 06-08-2003 03:08 PM
How to change the port assignment in Red Hat Linux 8 dibakar Linux - Networking 1 04-06-2003 11:15 PM


All times are GMT -5. The time now is 07:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration