LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-03-2013, 02:55 PM   #1
GJQ
Member
 
Registered: Jun 2009
Location: Malaysia
Distribution: Ubuntu 11.04
Posts: 93

Rep: Reputation: 17
Change network NIC speed and making it permanent in Linux Mint 14 64 bit


Dear LQ members
I am running Linux Mint 14 64 bit on my system.Each time I set my NIC to 100mps Full Duplex using sudo ethtool -s eth0 speed 100 duplex full. It work but when I try to have it permanent in etc/network/interfaces with an add in command.My network NIC will not work after a restart.

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback
pre-up /usr/sbin/ethtool -s eth0 speed 100 duplex full
(This is add in command to have it permanent)

After a restart,my network NIC will be down and after deleting the command and restart the pc, the network will be up again.Can I know which part of the command is wrong and do I need to create any other things to have it permanent

Thank you
 
Old 08-05-2013, 12:13 AM   #2
malekmustaq
Senior Member
 
Registered: Dec 2008
Location: root
Distribution: Slackware & BSD
Posts: 1,613

Rep: Reputation: 433Reputation: 433Reputation: 433Reputation: 433Reputation: 433
Quote:
Can I know which part of the command is wrong and do I need to create any other things to have it permanent
If it worked by the terminal then it should work when hardcoded into the the config file.
Only... here in the given example it is evident that the add-in command is just misplaced. The init scripts in the /etc/init.d folder may have pointed to another *.conf file or, maybe, the script itself bears its own config variables. (I am no longer using Mint, there is no guaranty if I pretend to point to you which conf file.)

You may try use "find" or "grep" all over the /etc to locate the proper configuration file to your iface.

Hope this hint can help you.

Good luck.
 
Old 08-05-2013, 09:33 AM   #3
GJQ
Member
 
Registered: Jun 2009
Location: Malaysia
Distribution: Ubuntu 11.04
Posts: 93

Original Poster
Rep: Reputation: 17
Hi malekmustaq
Thank you for your reply but I don't really understand what you have mention.A step by step will be very welcome. Anyway thank you for your good hearted reply.
 
Old 08-10-2013, 12:34 AM   #4
GJQ
Member
 
Registered: Jun 2009
Location: Malaysia
Distribution: Ubuntu 11.04
Posts: 93

Original Poster
Rep: Reputation: 17
Dear LQ member
Is there anyone able to help me to set my network card speed to 100mps full duplex instead of Auto Negotiation each time after reboot in Linux Mint 14 64bit? Below is the config file from Terminal

user@user-System-Product-Name ~ $ sudo ethtool eth0
[sudo] password for user:
Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Supported pause frame use: No
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Advertised pause frame use: Symmetric Receive-only
Advertised auto-negotiation: Yes
Link partner advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Link partner advertised pause frame use: Symmetric
Link partner advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: MII
PHYAD: 0
Transceiver: internal
Auto-negotiation: on <------- (Set this permanent to OFF instead of doing it each time I reboot the system)
Supports Wake-on: pumbg
Wake-on: g
Current message level: 0x00000033 (51)
drv probe ifdown ifup
Link detected: yes
user@user-System-Product-Name ~ $ sudo ethtool -s eth0 autoneg off
user@user-System-Product-Name ~ $ sudo ethtool -s eth0 speed 100 duplex fulluser@user-System-Product-Name ~ $ sudo ethtool eth0
Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Supported pause frame use: No
Supports auto-negotiation: Yes
Advertised link modes: Not reported
Advertised pause frame use: No
Advertised auto-negotiation: No
Speed: 100Mb/s
Duplex: Full
Port: MII
PHYAD: 0
Transceiver: internal
Auto-negotiation: off
Supports Wake-on: pumbg
Wake-on: g
Current message level: 0x00000033 (51)
drv probe ifdown ifup
Link detected: yes
user@user-System-Product-Name ~ $

The below file is from etc/network/interfaces

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback
pre-up /usr/sbin/ethtool -s eth0 speed 100 duplex full <---- If I add this to my etc/network/interfaces, my network will be down after I restart the system and I will have delete it and restart my system then my network will be up again.


Please all help if possible. Step by step solution is very welcome

Thank you
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Mint 14 64 bit new install does not drop down cooling fan rpm speed james2b Linux Mint 7 04-01-2013 06:23 AM
Making permanent changed in /etc/network/interfaces file nlarsensmith Linux - Networking 1 01-20-2008 05:52 PM
making WiFi settings in /etc/network/interfaces permanent Lleb_KCir Linux - General 3 05-11-2005 12:22 AM
Making MTU change permanent Firestarter75 Mandriva 2 02-16-2005 07:20 PM
rmmod - making the change permanent? DiBosco Linux - General 0 06-20-2004 06:32 AM


All times are GMT -5. The time now is 03:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration