LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Change monitor resolution in Fedora 13 64 bit VirtualBox virtual machine (http://www.linuxquestions.org/questions/linux-newbie-8/change-monitor-resolution-in-fedora-13-64-bit-virtualbox-virtual-machine-818264/)

garyl 07-06-2010 08:53 AM

Change monitor resolution in Fedora 13 64 bit VirtualBox virtual machine
 
I have installed a Fedora 13 64 bit virtual machine using VirtualBox software. Host platform is a Dell XPS 64 bit machine. The default screen resolutoin is 800x600. The Dell monitor is one of the wide screen models driven by Nvidia. The host OS is Windows 7 64 bit.

I need to set the resolution to 1366x768. I have made edits to the xorg.conf file and grub. After reboot, the screen initially enlarges to 1366x768, but then returns to the 800x600 resolution when the OS boot up page appears. I've had the same problem with Ubuntu 10.04. I was able to correct the problem in a Windows XP guest VM by resetting the Windows XP screen resolution in the usual way.

Is this a VirtualBox problem, a virtual machine problem in general, a problem with Nvidia driving wide screen monitors, or a Linux problem? Sun Microsystems does not recommend using the Nvidia drivers (after all else failed, I tried this anyway and the result was that the Linux OS failed to boot, so I deleted the VM and started over). Anyone have a solution?

adamk75 07-07-2010 07:38 PM

VirtualBox virtualizes its own video card, so Fedora doesn't see the physical GPU. Did you install the virtualbox guest additions? I believe that will get your guest OS to use whatever resolution you have the virtualbox window set to (and give you a fullscreen option).

Adam

garyl 07-12-2010 07:39 AM

Installing the "guest additions" packages to the Fedora 13 virtual machine I created using VirtualBox resolved the monitor resolution issue. For my laptop, I edited the file /etc/X11/xorg.conf by adding the following:

Modes "1440x900"
to the Section "Screen" as follows:

Section "Screen"
SubSection "Display"
Depth 24
Modes "144x900"
EndSubSection

Also, the full screen option works as expected, taking up the monitor screen.

Considering that most would consider having full screen monitor resolution to be an essential feature, it is unexpected that it is not provided by the VirtualBox installation software. Until receiving the question asking if I had installed the "guest additions", I did not realize that I had more reading to do in the VirtualBox installation quide. I assumed that something called "guest additions" was there to add optional functions rather than essential ones. Now that I'm on the VirtualBox forum, I'll include it as a suggestion to the developers that in a future release, they combine "guest additions" into the installation wizard application.

Thanks for the assistance!

adamk75 07-12-2010 07:56 AM

And how do you know that "most" would consider that an essential feature?

By the way, there's also an "Install Guest Additions" option in the Devices menu.

Adam

hedron 07-12-2010 08:05 AM

My understanding is that the guest additions can't be included in the main package because they include drivers that the client OS needs to install. You can't install a driver into the virtual box program itself. That doesn't even make sense. Though, maybe I am missing something.

adamk75 07-12-2010 08:08 AM

I think the OP means that the VirtualBox should prompt you to install the driver after you've setup the guest OS.

Adam

Abhishek1986 01-04-2011 02:45 PM

I have installed Guest Additions and have also enabled 3D Hardware Acceleration from Virtual Box VM settings. Still I am getting only one screen resolution option (800X600) and also, am not able to change Color Schemes, as I am getting an error "3D Hardware Acceleration is not available". Anyone has a solution? Why the Fedora system is not able to detect 3D Hardware acceleration?

adamk75 01-04-2011 03:14 PM

What's the output of 'glxinfo'?

Adam

Abhishek1986 01-05-2011 12:32 AM

My bad! I didn't install Guest Addition properly, so was getting that error. It's working fine now after a re-install. Thanks.

mike95376 02-05-2016 10:18 AM

Actually I ran into this problem after a fresh install of Fedora.
I installed the Guest Box Additions but it did not help.
The key was to run 'dnf update' after the OS install.
It needed newer Xorg rpms.
You also need to install gcc to be able to build anything.
dnf install gcc
Then reinstall the Guest Box Additions.
As root
cd /run/media/{username}/VBOXADDITIONS...
sh VBoxLinuxAdditions.run

Read your output carefully.

BW-userx 02-05-2016 07:22 PM

Quote:

Originally Posted by garyl (Post 4025140)
I need to set the resolution to 1366x768. I have made edits to the xorg.conf file and grub. After reboot, the screen initially enlarges to 1366x768, but then returns to the 800x600 resolution when the OS boot up page appears. I've had the same problem with Ubuntu 10.04. I was able to correct the problem in a Windows XP guest VM by resetting the Windows XP screen resolution in the usual way.

ON HOST:
I've use these two commands, the first one allows one to select any rez-O-lution on the fly.

Code:

VBoxManage setextradata global GUI/MaxGuestResolution any
 
VBoxManage setextradata "Ubuntu64" "GraphicsMode" "1366x768x32"

Remember to use the exact name you gave your VBSession. I usally just go into the directory with all of my sessions then copy paste them so I get them right.

IN CLIENT:

UNDER devices last selection
insert Guest Addtions CD...
select that, if you do not have it mine prompted me to download it. put it in my home dir /home/userx/.config/VirtualBox

then when it mounts it, I open up a term cd to it

Code:

/home/userx/.config/VirtualBox
copy the .run program to my root /
because it is on a "CD" iso actually.
then change permissions
chmod +x Guestaddtions.run
then run it... it takes care of itself
reboot the session.
you now have access to USB and outside folders

ON HOST:
Now to get your USB to work open up a term, on the host, then plug in what ever it is you want to use in VBox session off your USB, then type in this command lsusb you'll see something like this
Code:

                        [RIGHT HERE]
                    first set:second set
Bus 002 Device 003: ID 1058:0827 Western Digital Technologies, Inc.

the bold numbers are what you need. open up your settings for your session then under USB.

IN CLIENT:
the little usb plug with a dot on it, click it. "new Filter 1" now click on the second one with a dot on it. now you need to get your numbers.

the first set go into the Vender ID, the second set go into the Product ID. the rest is user information you can add whatever, or just leave it blank.

save it then start up your session .

ON HOST:
plug in your device. open up filemanager (In Client) you should see it, I do.

need not to worry about your mouse VBox takes care of that by another means.

John VV 02-06-2016 01:20 AM

you are aware that this is a 6 year necro post ? right ?

and for the now LONG dead and unsupported Fedora 13

BW-userx 02-06-2016 07:18 AM

Look how long it took you to tell the masses.... thanks 4 the fyi...
but still a lot of good information was added to it.. so it not all bad. :D


All times are GMT -5. The time now is 06:27 PM.