LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-11-2009, 05:57 AM   #1
macubex
Member
 
Registered: Apr 2009
Posts: 43

Rep: Reputation: Disabled
Change access permission of file system


In the properties of file system, owner,group and others are given as 'unknown'. Access for all is 'read-only'. How do I change the permissions so that I can edit stuff in file system?
 
Old 04-11-2009, 08:31 AM   #2
Retrievil_Knievil
Member
 
Registered: Mar 2004
Location: Stavanger, Norway
Distribution: Gentoo, Slackware/SLAX, Knoppix, CentOS, IPCop & DSL
Posts: 138

Rep: Reputation: 21
What file system do you use? Sounds like you either have it mounted read-only or as if the user/group id numbers have changed on your system.

Without knowing what distribution/file system you are using, it's not easy to know..

Could you post your /etc/fstab file?
 
Old 04-11-2009, 10:37 AM   #3
macubex
Member
 
Registered: Apr 2009
Posts: 43

Original Poster
Rep: Reputation: Disabled
I'm using debian(gnome). Ext3 file system. Here is the contents of fstab file.


# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda1 / ext3 errors=remount-ro 0 1
/dev/hda5 none swap sw 0 0
/dev/hdd /media/cdrom0 udf,iso9660 user,noauto 0 0

Last edited by macubex; 04-11-2009 at 02:50 PM.
 
Old 04-11-2009, 02:51 PM   #4
macubex
Member
 
Registered: Apr 2009
Posts: 43

Original Poster
Rep: Reputation: Disabled
Still not soved
 
Old 04-12-2009, 06:14 AM   #5
Retrievil_Knievil
Member
 
Registered: Mar 2004
Location: Stavanger, Norway
Distribution: Gentoo, Slackware/SLAX, Knoppix, CentOS, IPCop & DSL
Posts: 138

Rep: Reputation: 21
Seems like the option "errors=remount-ro" is forcing the filesystem to be mounted read-only because of errors in the file system. Try shutting down the system with the command "shutdown -Fr now" (as root or through sudo) which would force a file system check at boot time. (The -F forces check/fix, and the -r reboots the system.) This might fix the problem.
 
Old 04-12-2009, 07:56 AM   #6
Retrievil_Knievil
Member
 
Registered: Mar 2004
Location: Stavanger, Norway
Distribution: Gentoo, Slackware/SLAX, Knoppix, CentOS, IPCop & DSL
Posts: 138

Rep: Reputation: 21
That fixed the problem?
 
Old 04-12-2009, 12:16 PM   #7
macubex
Member
 
Registered: Apr 2009
Posts: 43

Original Poster
Rep: Reputation: Disabled
No, it didn't. It checked the file system upon boot up and all. But it's still shown as read-only.
 
Old 04-12-2009, 04:02 PM   #8
Retrievil_Knievil
Member
 
Registered: Mar 2004
Location: Stavanger, Norway
Distribution: Gentoo, Slackware/SLAX, Knoppix, CentOS, IPCop & DSL
Posts: 138

Rep: Reputation: 21
And it does not tell you of any errors when mounting? Have you checked the logs?

How did this happen? Is this a fresh install?

Have you tried removing the "errors=remount-ro" and replacing it with "defaults"?
 
Old 04-13-2009, 10:32 AM   #9
macubex
Member
 
Registered: Apr 2009
Posts: 43

Original Poster
Rep: Reputation: Disabled
How do I check the logs? Yes, this is a fresh install. And how do I replace "errors=remount-ro" with "defaults"? What is it?

It shows an error about some mailing system after it tries to load MTA. And a warning about some daemon..
 
Old 04-13-2009, 11:13 AM   #10
malekmustaq
Senior Member
 
Registered: Dec 2008
Location: root
Distribution: Slackware & BSD
Posts: 1,615

Rep: Reputation: 441Reputation: 441Reputation: 441Reputation: 441Reputation: 441
macubex:

Here are some tips to your questions.

==Q:"How do I check the logs"

Tip:

At the terminal enter:

sudo less /var/log/syslog
<enter password>

(a log file opens and you may examine system events at boot time, or)

dmesg | less

(similar info is displayed for your curiousity over the system)

==Q:"And how do I replace "errors=remount-ro" with "defaults"? What is it? "

Tip:

At the terminal enter:

sudo gedit /etc/fstab
<enter password>

Replace the line:

/dev/hda1 / ext3 errors=remount-ro 0 1

Into following--

/dev/hda1 / ext3 defaults 0 0

Click save and close the file. Reboot.

The fourth column containing either "defaults" or "error-remount-ro" specifies some parameters at "how" the system treats the mounted volume which certainly affect permissions.

I am not sure if under your Debian "gedit" editor is enabled but in Ubuntu or Mint it is preinstalled. So just in case command 'sudo gedit /etc/fstab' doesn't work just try another editor, say, 'sudo vi /etc/fstab' here you must read first how to use vi editor. Its very easy: all you need to learn are just few commands in vi; try 'man vi' or 'vi --help' for some basic helps.

ANOTHER WAY TO TACKLE YOUR PROBLEM

If "ownership" is what you want over a folder or file, enter:

sudo chown -R /folder_name

If "permission" to change a file is what you want, enter:

sudo chmod 775 ./file_name

To make your linux experience more enjoyable please read a good tutorial of its basic philosophy and commands. Try download a pdf tutorial for reference offline. One good tutorial for download it this:
http://www.freebookcentre.net/unix-b...heer)-PDF.html

I hope this helps.

Check back how it goes. There are other helpful users that might see this post and give you better suggestions.

Goodluck.

Malek
 
Old 05-15-2009, 07:51 AM   #11
macubex
Member
 
Registered: Apr 2009
Posts: 43

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by malekmustaq View Post
macubex:

==Q:"And how do I replace "errors=remount-ro" with "defaults"? What is it? "

Tip:

At the terminal enter:

sudo gedit /etc/fstab
<enter password>

Replace the line:

/dev/hda1 / ext3 errors=remount-ro 0 1

Into following--

/dev/hda1 / ext3 defaults 0 0

Click save and close the file. Reboot.


Malek


Thank you for your help.I did that. But the problem still remains.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
CLI How to change folder access permission for particular user sfkong Linux - Newbie 10 07-20-2008 01:34 PM
change file permission of a mouse device file permanently alexandre_fs Linux - General 5 01-09-2007 07:30 AM
Need ACCESS to change files! Every time I try to change a setting,"Permission Denied" Balarabay1 SUSE / openSUSE 2 03-06-2006 10:54 AM
how to change the file permission ?? AK prince Slackware 17 08-05-2005 01:16 PM
Cannot Change File Permission dsuratman Linux - Newbie 12 11-03-2003 02:47 PM


All times are GMT -5. The time now is 08:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration