LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-16-2006, 08:08 PM   #1
littleshark112
LQ Newbie
 
Registered: Jan 2006
Posts: 4

Rep: Reputation: 0
chainloader = (hd 0,0)+1


I have a serious issue. I installed Windows XP after a fresh (and much needed) format to my PC. I only have 1 hard drive, so I left 10 unused gigs on the end of the hard drive. I put Lycoris (recently bought by Mandriva) Linux on the end of this hard drive, and now I can't boot Windows. I went into Lycoris and added Windows XP (partition hd1, 100gb, just as big as it should be), and it is in fact the Windows partition on my hard drive, but when the boot loader comes up I get this error message.

chainloader = (hd 0,0)+1

I have not backed up any of my files, seeing as how I didn't think this would happen, so I would REALLY appreciate someones help on why the heck I get this error message when trying to boot into Windows. Lycoris boots just fine...help!!
 
Old 01-16-2006, 08:11 PM   #2
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
Can you post your grub configuration file?
 
Old 01-16-2006, 08:13 PM   #3
mr_coffee
Member
 
Registered: Jan 2006
Location: PA
Distribution: Mandriva Power Pack 2006
Posts: 146

Rep: Reputation: 15
littleshark, i'm having the same problems, but I think your windows system is fine, your MBR sounds like its screwed though. The reason i can still load windows is becuase i have Linux on a totally different harddrive then windows. Here are directions if u have a boot disk for windows. http://www.microsoft.com/resources/d...d_tro_ldau.asp

i'm sure linux guru's have a way to fix it as well with Linux. Goodluck.
 
Old 01-16-2006, 08:33 PM   #4
ylts
Member
 
Registered: Feb 2005
Location: Estonia, Tartu
Distribution: Gentoo linux
Posts: 101

Rep: Reputation: 15
My grub line for Windows:

title Win
rootnoverify (hd0,0)
chainloader +1

It works correctly since i have windows on my primary hd first partition, if you have same you can copy-paste it into your /boot/grub/grub.conf
 
Old 01-16-2006, 08:35 PM   #5
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
It's not that the MBR is screwed, it's just that the linux boot loader is installed there instead of the windows boot loader. The problem is in your /etc/grub.conf file. What you have to do is edit the config file so that grub boots the windows boot loader which then boots windows. It's called chainloading.

the windows xp section of your grub.conf file should look something like ylts assuming windows xp is on the first partition of the first hard drive:

Last edited by pljvaldez; 01-16-2006 at 08:36 PM.
 
Old 01-16-2006, 08:36 PM   #6
kevner
LQ Newbie
 
Registered: May 2005
Location: Tuscaloosa, AL, USA
Distribution: Ubuntu 5.10
Posts: 5

Rep: Reputation: 0
this is what i have....

title Microsoft Windows XP Home Edition
root (hd0,0)
savedefault
makeactive
chainloader +1


you might try that, the savedefault, makeactive part.
 
Old 01-16-2006, 11:37 PM   #7
littleshark112
LQ Newbie
 
Registered: Jan 2006
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks guys,

K, here's the deal. Of course, Lycoris has to do it's grub boot loader a different way...I'll paste it for you though! But I don't see any "chainloader" anywhere on here. In /etc/grub.conf the file simple says:


root (hd0,1)
install /boot/grub/stage1 (hd0,1) /boot/grub/stage2 0x8000 (hd0,1)/boot/grub/menu.lst
install /boot/grub/stage1 d (hd0) /boot/grub/stage2 0x8000 (hd0,1)/boot/grub/menu.lst
quit


So after looking this over, I assumed it was calling to that /boot/grub/menu.lst file, so here's the contents of that file as well:


#
# /boot/grub/menu.lst - generated by Lizard
#
# options
timeout = 5
splashimage = (hd0,1)/boot/grub/boot_splash_16_indexed.xpm.gz

default = 2

title = Lycoris Desktop/LX
root = (hd0,1)
kernel = /boot/vmlinuz-pc97-2.4.27-modular vga=788 quiet splash=silent root=/dev/hda2

title = Xandros Linux
chainloader = (hd0,5)+1

title = Windows XP
chainloader = (hd0,0)+1


So as you may be able to notice, I really have three things on my computer--Windows XP, Xandros Desktop, and Lycoris Desktop/LX. Keep in mind, NOTHING will load except Lycoris. If it helps any, Lycoris is on hda2, XP is on hda1, and Xandros is on hda6 of my partition. Yes, and my favorite part about all this is if I try to make a change to this boot list/config file it gives me a lovely "Sorry, cannot write" error message. So on top of that fact that I'm still a little sketchy on what to change, it won't let me...do you know how to fix that problem? Sorry for all the trouble, really hope you can help though!!

--Alex
 
Old 01-16-2006, 11:47 PM   #8
PipeDreams
Member
 
Registered: Dec 2005
Distribution: Mandriva 2006 x64
Posts: 161

Rep: Reputation: 30
I have several distros and xp installed using GRUB to boot.
Change your xp entry to this:
title windows
root (hd0,0)
chainloader +1

Works for me

I'm sorry.I just noticed the "="s in your grub file.You may have to add them for it to work correctly.I would try without anyway.Its less typing .None of my distros grub versions have used the = .

Last edited by PipeDreams; 01-16-2006 at 11:58 PM.
 
Old 01-17-2006, 12:14 AM   #9
littleshark112
LQ Newbie
 
Registered: Jan 2006
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks...almost! It changed at least. But I now get an "Wrong File System Format" or something like that. What's that all about?
 
Old 01-17-2006, 12:18 AM   #10
gherb
LQ Newbie
 
Registered: Jan 2006
Posts: 12

Rep: Reputation: 0
Quote:
Originally Posted by littleshark112
Thanks guys,

K, here's the deal. Of course, Lycoris has to do it's grub boot loader a different way...I'll paste it for you though! But I don't see any "chainloader" anywhere on here. In /etc/grub.conf the file simple says:


root (hd0,1)
install /boot/grub/stage1 (hd0,1) /boot/grub/stage2 0x8000 (hd0,1)/boot/grub/menu.lst
install /boot/grub/stage1 d (hd0) /boot/grub/stage2 0x8000 (hd0,1)/boot/grub/menu.lst
quit


So after looking this over, I assumed it was calling to that /boot/grub/menu.lst file, so here's the contents of that file as well:


#
# /boot/grub/menu.lst - generated by Lizard
#
# options
timeout = 5
splashimage = (hd0,1)/boot/grub/boot_splash_16_indexed.xpm.gz

default = 2

title = Lycoris Desktop/LX
root = (hd0,1)
kernel = /boot/vmlinuz-pc97-2.4.27-modular vga=788 quiet splash=silent root=/dev/hda2

title = Xandros Linux
chainloader = (hd0,5)+1

title = Windows XP
chainloader = (hd0,0)+1


So as you may be able to notice, I really have three things on my computer--Windows XP, Xandros Desktop, and Lycoris Desktop/LX. Keep in mind, NOTHING will load except Lycoris. If it helps any, Lycoris is on hda2, XP is on hda1, and Xandros is on hda6 of my partition. Yes, and my favorite part about all this is if I try to make a change to this boot list/config file it gives me a lovely "Sorry, cannot write" error message. So on top of that fact that I'm still a little sketchy on what to change, it won't let me...do you know how to fix that problem? Sorry for all the trouble, really hope you can help though!!

--Alex
I'm a newbie, and I could be off base, but I just edited my GRUB menu.lst file in text editor without a problem. I saved my original "menu.lst" as menu.orig as a backup. I was in root, if that makes a difference.

It sounds like a simple syntactical error in that file, and you may need to reintall your windows mbr as mentioned by others above.

Here's the link to the thread where I resolved my menu.lst file problem.

http://www.linuxquestions.org/questi...=403311&page=2
 
Old 01-17-2006, 12:34 AM   #11
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 14,838

Rep: Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822Reputation: 1822
Quote:
Originally Posted by littleshark112
Thanks...almost! It changed at least. But I now get an "Wrong File System Format" or something like that. What's that all about?
Try "rootnoverify (hd0,0)"
 
Old 01-17-2006, 12:11 PM   #12
littleshark112
LQ Newbie
 
Registered: Jan 2006
Posts: 4

Original Poster
Rep: Reputation: 0
Tried that...still no luck! And after rewriting my MBR using the XP disk, I now cannot even get to the GRUB boot screen, so I no longer can boot any operating system. My computer hangs after "Verifying DMI Pool". Next suggestion please?
 
Old 01-17-2006, 02:53 PM   #13
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
Try booting knoppix live CD and try this to restore grub:

sudo chroot /mnt/hda6 grub-install /dev/hda or leave off the sudo and just do this from a root terminal.

Your Lycoris CD may also have a rescue mode that would allow you to do this, but I don't really know much about Lycoris.
 
Old 01-17-2006, 07:44 PM   #14
johndoe0028
Member
 
Registered: Jun 2005
Location: CA, USA
Distribution: Gentoo
Posts: 165

Rep: Reputation: 30
I dual-booted Arch and Win2k a while ago.

Here was the windows portion of my /boot/grub/menu.lst file

# (1) Windows
title Windows 2000
root (hd0,0)
rootnoverify (hd0,0)
makeactive
chainloader +1


Substitute correct vaules for title, and root.
 
Old 09-06-2006, 05:01 AM   #15
DeconFrost7
LQ Newbie
 
Registered: Sep 2006
Posts: 2

Rep: Reputation: 0
Quote:
Originally Posted by littleshark112
Tried that...still no luck! And after rewriting my MBR using the XP disk, I now cannot even get to the GRUB boot screen, so I no longer can boot any operating system. My computer hangs after "Verifying DMI Pool". Next suggestion please?
YOU ARE A DUMB ASS... - sadly, yes. High and mighty in your thinking but stupid as they come. As I always say, think before you leap.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Chainloader (hd2,0)+1 problem Guignol Linux - Hardware 15 11-11-2005 08:31 PM
Has the dual boot problem been fixed? (chainloader) Nodscene Linux - Distributions 4 03-13-2005 06:30 PM
grub stops at chainloader +1 loading xp Bolivar Debian 5 07-07-2004 12:54 PM
GRUB giving chainloader+1 error, fixable? bathoff Linux - Newbie 1 04-23-2004 01:31 AM
Another XP Redhat ChainLoader Prob RichardSimmons Linux - General 8 03-01-2004 09:04 PM


All times are GMT -5. The time now is 04:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration