LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-08-2006, 10:01 AM   #1
trelos
LQ Newbie
 
Registered: Jan 2005
Location: Queretaro, Mexico
Distribution: debian (sarge), suse 9.3
Posts: 23

Rep: Reputation: 15
Unhappy chage xdm to gdm on initial cnfig


Hi, Im using Suse 9.3 . When I boot my computer it seems to me that xdm loads on the first graphical screen. I've managed to skip it with the following procedure: I press Ctrl + alt + Backspace (sometimes twice), then I log as root and start gdm; and work as usual.
But what I really want is to start gdm without the mentioned procedure. I've read some things about the initab, but I can't figure out what to do.
For any help THANKS.
 
Old 01-08-2006, 10:29 AM   #2
ssfrstlstnm
Member
 
Registered: Dec 2004
Location: IN, USA
Distribution: debian etch
Posts: 402

Rep: Reputation: 30
Edit /etc/X11/default-display-manager to change it.
 
Old 01-08-2006, 12:07 PM   #3
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 332Reputation: 332Reputation: 332Reputation: 332
I'm using SuSE 9.2. I noticed that I don't have the file that the previous poster suggested editing. This is how I enable or disable xdm on my machine.

log in as root
run yast2
click on system
click on run level editor
scroll down until you see xdm in the left column
highlight xdm and click on the disable button
click on the finish button
close yast
done
 
Old 01-08-2006, 03:41 PM   #4
trelos
LQ Newbie
 
Registered: Jan 2005
Location: Queretaro, Mexico
Distribution: debian (sarge), suse 9.3
Posts: 23

Original Poster
Rep: Reputation: 15
I did not find the default-display-manager on /etc/X11/. I used the run level editor and xdm no longer loads after boot. I wish I could load gdm the same way as xdm did, I mean, to automatically start gdm on the first graphical display after boot.
 
Old 01-08-2006, 04:18 PM   #5
ssfrstlstnm
Member
 
Registered: Dec 2004
Location: IN, USA
Distribution: debian etch
Posts: 402

Rep: Reputation: 30
Try creating the file /etc/X11/default-display-manager with the text:
/usr/bin/gdm
 
Old 01-08-2006, 06:49 PM   #6
trelos
LQ Newbie
 
Registered: Jan 2005
Location: Queretaro, Mexico
Distribution: debian (sarge), suse 9.3
Posts: 23

Original Poster
Rep: Reputation: 15
I created the file default-display-manager on /etc/X11/ but after rebooting, nothing changed. I thought it was because I disabled xdm in the run level editor, but after I enabled it nothing seemed to chage.

Do you have another solution for this, what should I do.
 
Old 01-08-2006, 11:41 PM   #7
ssfrstlstnm
Member
 
Registered: Dec 2004
Location: IN, USA
Distribution: debian etch
Posts: 402

Rep: Reputation: 30
Not sure if suse is the same as debian, but you can try this as root.
Look for the file /etc/init.d/gdm. If it is not there create one with this contents:
Code:
#! /bin/sh
### BEGIN INIT INFO
# Provides:          x-display-manager gdm
# Required-Start:    $local_fs $remote_fs
# Required-Stop:     $local_fs $remote_fs
# Default-Start:     2 3 4 5
# Default-Stop:      S 0 1 6
# Short-Description: GNOME Display Manager
# Description:       Debian init script for the GNOME Display Manager
### END INIT INFO
#
# Author:       Ryan Murray <rmurray@debian.org>
#
set -e

PATH=/sbin:/bin:/usr/sbin:/usr/bin
DAEMON=/usr/sbin/gdm
DEBCONF_DAEMON=/usr/bin/gdm

test -x $DAEMON || exit 0

if [ -r /etc/default/gdm ]; then
  . /etc/default/gdm
  if [ -z "$LANG" ]; then
    :
  else
    export LANG
  fi
fi

. /lib/lsb/init-functions

# To start gdm even if it is not the default display manager, change
# HEED_DEFAULT_DISPLAY_MANAGER to "false."
HEED_DEFAULT_DISPLAY_MANAGER=true
DEFAULT_DISPLAY_MANAGER_FILE=/etc/X11/default-display-manager

case "$1" in
  start)
        if [ -e "$DEFAULT_DISPLAY_MANAGER_FILE" -a "$HEED_DEFAULT_DISPLAY_MANAGER" = "true" -a "$(cat $DEFAULT_DISPLAY_MANAGER_FILE)" != "$DEBCONF_DAEMON" ]; then
                log_action_msg "Not starting GNOME Display Manager; it is not the default display manager"
        else
                log_daemon_msg "Starting GNOME Display Manager" "gdm"
                start_daemon $DAEMON
                log_end_msg $?
        fi
  ;;
  stop)
        log_daemon_msg "Stopping GNOME Display Manager" "gdm"
        set +e
        start-stop-daemon --stop --quiet --pidfile /var/run/gdm.pid \
                --name gdm --retry 5
        set -e
        log_end_msg $?
  ;;
  reload)
        log_daemon_msg "Scheduling reload of GNOME Display Manager configuration" "gdm"
        set +e
        start-stop-daemon --stop --signal USR1 --quiet --pidfile \
                /var/run/gdm.pid --name gdm
        set -e
        log_end_msg $?
  ;;
  restart|force-reload)
        $0 stop
        $0 start
  ;;
  *)
        echo "Usage: /etc/init.d/gdm {start|stop|restart|reload|force-reload}"
        exit 1
  ;;
esac

exit 0
Now create a symlink in the directory /etc/rc2.d
Code:
cd /etc/rc2.d
ln -s ../init.d/gdm S99gdm
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
XDMCP and XDM, GDM Rostfrei Linux - Networking 5 09-26-2005 04:49 PM
xdm to gdm? czon Debian 3 08-13-2005 09:12 AM
gdm, kdm, xdm daemons, which do I need? Feldon Linux - Software 5 10-16-2004 10:56 PM
how change xdm to gdm huno Linux - General 1 04-18-2004 04:09 PM
Without GDM/XDM DoubleLetter Linux - General 4 04-18-2003 06:19 PM


All times are GMT -5. The time now is 04:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration