LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-14-2006, 07:14 PM   #1
Tillus
Member
 
Registered: Dec 2004
Posts: 55

Rep: Reputation: 15
Question CGI @INC Problem


Hello, everyone!

I have just started studying HTML and Perl scripts. I have successfully assebled some of the easiest examples in my book. The trouble starts when I try to run the script as a cgi-script. The terminal return something like "Can't find cgi.pm @INC".

I have searched for cgi.pm, but it seems I don't have it on my system. I do have the cgi-bin, cgi-src and something called Apache though. It would really mean a lot to me if someone could shed some light on this. Especially since I can't find the first thing on CGI and Linux on the Internet. (Beginners tutorials and such)

Do I need to install something? (I thought Linux was a server by default). Do I perhaps have the wrong installation type? I'm using Red Hat 9.0.


Lots of love
Tillus

Last edited by Tillus; 03-14-2006 at 07:23 PM.
 
Old 03-14-2006, 07:24 PM   #2
spooon
Senior Member
 
Registered: Aug 2005
Posts: 1,755

Rep: Reputation: 49
You are needing the "CGI" Perl module. Try "locate CGI.pm" to see if you can find it on the system. This usually comes with Perl but it might be separate or something, depending on your system. If you have CPAN, you can try this on the command line to install it: "cpan -i CGI"

Last edited by spooon; 03-14-2006 at 07:27 PM.
 
Old 03-14-2006, 07:44 PM   #3
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,240

Rep: Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324
Alternately (as root):
perl -e shell -MCPAN
then
cpan> install CGI
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
CGI to work out side of cgi-bin? crashedspine Linux - Newbie 13 09-02-2004 09:49 PM
my CGI problem... FreakFish Linux - Networking 2 04-30-2004 09:49 AM
perl problem? apache problem? cgi problem? WorldBuilder Linux - Software 1 09-17-2003 08:45 PM
cgi problem jstu Programming 2 12-26-2002 11:28 PM
http://www.burstnet.com/cgi-bin/ads/ad7954a.cgi/3980/RETURN-CODE rverlander LQ Suggestions & Feedback 1 06-07-2002 08:35 AM


All times are GMT -5. The time now is 05:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration