LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-20-2012, 04:53 PM   #1
bop-a-nator
LQ Newbie
 
Registered: Sep 2012
Location: North East USA
Distribution: at work: Red Hat Enterprise Linux Server release 5.8 (Tikanga); at home: what do you recommend?
Posts: 24

Rep: Reputation: Disabled
certain words in the man pages appear to be invisible


Hi, I have a new Linux box, and certain words in the man pages appear to be invisible

FTP(1) BSD General Commands Manual FTP(1)

NAME
INVISIBLE - Internet file transfer program

INVISIBLE
INVISIBLE [INVISIBLE] [host]

If I highlight it and copy it to a document I can see that INVISIBLE really is something there.

I also get these odd ‚ characters like on this line too in the display:

Restrains ftp from attempting ‚auto-login‚

I think it may be a some "new to me" setting that I could change, however, I am a bit at at loss on what to search for as I am still learning my way around Linux.

Thank you very much for your help, it would be nice to be able to "see" all the words.
 
Old 09-20-2012, 06:26 PM   #2
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,260

Rep: Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328
Which tool are you using to read the man pages? The man cmd itself should be fine, but its possible your environment is not setup correctly.
Please post the out put of of these cmds
Code:
env

set

cat /etc/*release*

uname -a
You can usually find man pages on the net as well eg http://linux.die.net/man/
 
Old 09-21-2012, 09:25 AM   #3
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,517

Rep: Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039
It may be helpful if you were to edit your LQ profile adding your location (country, region) and what distribution you're using -- might get better answers.

In addition to what @chrism01 indicated to open a terminal and enter
Code:
locale
That should display something like this (if, of course, you're in the US):
Code:
LANG=en_US
LC_CTYPE="en_US"
LC_NUMERIC="en_US"
LC_TIME="en_US"
LC_COLLATE=C
LC_MONETARY="en_US"
LC_MESSAGES="en_US"
LC_PAPER="en_US"
LC_NAME="en_US"
LC_ADDRESS="en_US"
LC_TELEPHONE="en_US"
LC_MEASUREMENT="en_US"
LC_IDENTIFICATION="en_US"
LC_ALL=
Hope this helps some.
 
Old 09-21-2012, 12:05 PM   #4
bop-a-nator
LQ Newbie
 
Registered: Sep 2012
Location: North East USA
Distribution: at work: Red Hat Enterprise Linux Server release 5.8 (Tikanga); at home: what do you recommend?
Posts: 24

Original Poster
Rep: Reputation: Disabled
Here is the output from the settings - certain things blanked out:

$ env
HOSTNAME=xxxxxxxxxxxxxxxxxx
SHELL=/bin/bash
TERM=xterm
HISTSIZE=500
SSH_CLIENT=xxxxxxxxxxxxxxxxxxxxxxxx
SSH_TTY=/dev/pts/5
USER=XXXXXXXXXXXXXXXX
LS_COLORS=no=00:fi=00:di=00;34:ln=00;36i=40;33:so=00;35:bd=40;33;01:cd=40;33;01r=01;05;37;41:mi= 01;05;37;41:ex=00;32:*.cmd=00;32:*.exe=00;32:*.com=00;32:*.btm=00;32:*.bat=00;32:*.sh=00;32:*.csh=00 ;32:*.tar=00;31:*.tgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.zip=00;31:*.z=00;31:*.Z=00;31:*.gz =00;31:*.bz2=00;31:*.bz=00;31:*.tz=00;31:*.rpm=00;31:*.cpio=00;31:*.jpg=00;35:*.gif=00;35:*.bmp=00;3 5:*.xbm=00;35:*.xpm=00;35:*.png=00;35:*.tif=00;35:
MAIL=/usr/mail/xxxxxxxxxxxxxxxxxxxxxx
PATH=/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/sbin@/usr/loca/bin:/usr/openwin/bin::/usr/ucb:/usr/lib/font
EXINIT=set showmode tabstop=4
INPUTRC=/etc/inputrc
PWD=xxxxxxxxxxxxxxxxxxxxxxxxxxx
EDITOR=/usr/bin/vi
LANG=en_US.UTF-8
PS1=$(uname -n)($USER):$PWD$
SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
SHLVL=1
HOME=xxxxxxxxxxxxxx
LOGNAME=xxxxxxxxxxxxxx
VISUAL=/usr/bin/bi
CVS_RSH=ssh
SSH_CONNECTION=xxxxxxxxxxxxxxxx
LESSOPEN=|/usr/bin/lesspipe.sh %s
G_BROKEN_FILENAMES=1
_=/bin/env
OLDPWD=/etc
----------------------
$ set
BASH=/bin/bash
BASH_ARGC=()
BASH_ARGV=()
BASH_LINENO=()
BASH_SOURCE=()
BASH_VERSINFO=([0]="3" [1]="2" [2]="25" [3]="1" [4]="release" [5]="x86_64-redhat-linux-gnu")
BASH_VERSION='3.2.25(1)-release'
COLORS=/etc/DIR_COLORS.xterm
COLUMNS=80
CVS_RSH=ssh
DIRSTACK=()
EDITOR=/usr/bin/vi
EUID=XXXXXXX
EXINIT='set showmode tabstop=4'
GROUPS=()
G_BROKEN_FILENAMES=1
HISTFILE=/XXXXXXXXXXX/.bash_history
HISTFILESIZE=500
HISTSIZE=500
HOME=XXXXXXXXXXXXXXX
HOSTNAME=XXXXXXXXXX
HOSTTYPE=x86_64
IFS=$' \t\n'
INPUTRC=/etc/inputrc
LANG=en_US.UTF-8
LESSOPEN='|/usr/bin/lesspipe.sh %s'
LINES=24
LOGNAME=XXXXXXXXXXX
LS_COLORS='no=00:fi=00:di=00;34:ln=00;36i=40;33:so=00;35:bd=40;33;01:cd=40;33;01r=01;05;37;41:mi =01;05;37;41:ex=00;32:*.cmd=00;32:*.exe=00;32:*.com=00;32:*.btm=00;32:*.bat=00;32:*.sh=00;32:*.csh=0 0;32:*.tar=00;31:*.tgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.zip=00;31:*.z=00;31:*.Z=00;31:*.g z=00;31:*.bz2=00;31:*.bz=00;31:*.tz=00;31:*.rpm=00;31:*.cpio=00;31:*.jpg=00;35:*.gif=00;35:*.bmp=00; 35:*.xbm=00;35:*.xpm=00;35:*.png=00;35:*.tif=00;35:'
MACHTYPE=x86_64-redhat-linux-gnu
MAIL=/usr/mail/XXXXXXXXXXXX
MAILCHECK=60
OLDPWD=/etc
OPTERR=1
OPTIND=1
OSTYPE=linux-gnu
PATH=/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/sbin@/usr/loca/bin:/usr/openwin/bin::/usr/ucb:/usr/lib/font
PIPESTATUS=([0]="0")
PPID=5129
PS1='$(uname -n)($USER):$PWD$ '
PS2='> '
PS4='+ '
PWD=XXXXXXXXXXXXXX
SHELL=/bin/bash
SHELLOPTS=braceexpand:hashall:histexpand:interactive-comments:monitor:vi
SHLVL=1
SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
SSH_CLIENT=XXXXXXXXXXXXXXX
SSH_CONNECTION='XXXXXXXXXXXXXXXXXX'
SSH_TTY=/dev/pts/5
TERM=xterm
UID=XXXXXX
USER=XXXXXXXXX
VISUAL=/usr/bin/bi
_=env
consoletype=pty
----------------------
$ cat /etc/*release*
cat: /etc/lsb-release.d: Is a directory
Red Hat Enterprise Linux Server release 5.8 (Tikanga)
-----------------------

$ uname -a
Linux XXXXXXXX 2.6.18-308.el5 #1 SMP Fri Jan 27 17:17:51 EST 2012 x86_64 x86_64 x86_64 GNU/Linux
--------------

All the entires you asked about under locale I believe are ok they are all: en_US.UTF-8
 
Old 09-21-2012, 02:00 PM   #5
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,517

Rep: Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039
One you might want look at is
Code:
VISUAL=/usr/bin/bi
The b is right next to the v, eh?

From your description of the problem it sounds like you don't have a font installed; the "invisible" stuff is the bold font where the visible stuff is the "regular" font (the one you see in an open terminal, xterm, window).

You might open an xterm and look in the preferences for appearance and try selecting a different font (a good one might be Courier 10 Pitch).

Hope this helps some.
 
Old 09-21-2012, 03:35 PM   #6
bop-a-nator
LQ Newbie
 
Registered: Sep 2012
Location: North East USA
Distribution: at work: Red Hat Enterprise Linux Server release 5.8 (Tikanga); at home: what do you recommend?
Posts: 24

Original Poster
Rep: Reputation: Disabled
I use putty, so you are thinking it is one of my putty settings? This the whole color and bold options are all new to me - in my particular environment the UNIX boxes were never set up with any of this. As for the VISUAL=/usr/bin/bi (this is a new variable to me too - the SA set that up and since I'd not seen it before I didn't question it - though I did look after you mentioned this and don't see anything called bi in the /usr/bin directory, so think you are correct there - typo. So I changed it logged off/on echoed back to make sure it was now vi and checked the man pages and they still look the same. I did go out and read about the VISUAL variable and it said something about leaving EDITOR unset and setting VISUAL to vi -e Which is leading me to more reading...that said set VISUAL and EDITOR to the same thing...so more research...
 
Old 09-21-2012, 04:11 PM   #7
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,517

Rep: Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039
Not to be stupid, but what the heck are you using PuTTY for? Are you connecting to another box with it and that's where you're having trouble?

PuTTY is for connecting to another system, not for a local system (you simply open an X terminal locally); it's almost exclusively used on Windows machines to connect to a Unix/Linux system and have a terminal window to work in.

And, yeah, if you're using PuTTY, that's why you're having trouble with manual pages. Check you settings (and, sorry, I don't have any idea what settings to check -- don't use Windows for anything). Most likely something to do with fonts but I've no idea what to look for, sorry.

If you've got a Linux box sitting in front of you and you're running KDE or Xfce, you can open an X terminal from the "System" menu and pick "Terminal." If you're using GNOME, you might be able to right-click on the screen and open a terminal (you can also do that in Xfce). Might want to give that a try.

Hope this helps some.
 
Old 09-21-2012, 05:24 PM   #8
bop-a-nator
LQ Newbie
 
Registered: Sep 2012
Location: North East USA
Distribution: at work: Red Hat Enterprise Linux Server release 5.8 (Tikanga); at home: what do you recommend?
Posts: 24

Original Poster
Rep: Reputation: Disabled
Ok I use my PC running Windows 7 - Linux is not on my PC it is on a server that I need to log into just as the UNIX is on a separate box
- I use Putty on my PC to connect to the UNIX box, so when they said here's the new Linux box - I just used Putty to connect to it too.
I really didn't know if there was another way, there isn't anybody who knows anything for me to ask, so I worked with what I had.
Is there something better? I basically just need to get to the box so I can get into the directory structure. I'm happy to check out anything
that is free with SSH capability and I can download. I welcome any suggestion as I mentioned Linux is a whole new area. I'm really learning quite a bit
in this forum.
 
Old 09-21-2012, 05:54 PM   #9
bop-a-nator
LQ Newbie
 
Registered: Sep 2012
Location: North East USA
Distribution: at work: Red Hat Enterprise Linux Server release 5.8 (Tikanga); at home: what do you recommend?
Posts: 24

Original Poster
Rep: Reputation: Disabled
Ahh tronayne you did send me in a new direction - appears yes Putty is valid for what I am doing searching on the web
- first instruction was download Putty. So I poked around more from a Putty perspective and found someone else experience this issue,
also referencing fonts, so poked though Putty settings under Putty settings Window/Colours/Options controlling use of colors
there was a check box "Bolded text is a different colour" it was checked I unchecked it and now I can see the "invisible" words
as black bolded words. Thank you all for your help with this, sometimes it just takes someone to say something that makes you look
at it a different way!
 
Old 09-22-2012, 08:53 AM   #10
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,517

Rep: Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039Reputation: 1039
All righty then, glad you've got it solved.

For future questions it is a good idea to mention what you're using when you have a problem. The "default condition" is a keyboard, mouse and monitor (more or less) connected directly to a computer sitting right next to you that you have complete control over. The behavior of your setup is radically different from that and had we known we'd more than likely been able to help out much, much quicker with lot less back-and-forth, eh?

I'm not being critical, just making a suggestion -- you've come the the right place for answers to questions and problems (and most everybody here is more than willing to help). Just let us know what you've got to work with and what you need to do and somebody will step up and try help out. This isn't a closed club and you're more than welcome to come on in, sit right down, put your feet up and feel at home.
 
Old 09-23-2012, 12:26 PM   #11
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958Reputation: 1958
While not directly related to the OP, I had a similar problem a while back. Perhaps it will help someone if they come across this.

When root, man pages had some syntax highlighting show up as black, on a black background. I still have no idea what causes it, but I finally found a workaround. Perhaps there are more elegant ways about it, but this works for me.

I just added the following LESS_TERMCAP settings to my bashrc.

Code:
LESS_TERMCAP_mb=$'\e[01;31m'     # blinking text begin (bright red)
LESS_TERMCAP_md=$'\e[01;36m'     # bold text begin (bright cyan)
LESS_TERMCAP_us=$'\e[01;36;04m'  # underline text begin (bright cyan, underlined)
LESS_TERMCAP_so=$'\e[01;34m'     # standout-mode begin (bright blue)

LESS_TERMCAP_me=$'\e[0m'         # blinking/bold end
LESS_TERMCAP_ue=$'\e[0m'         # underline text end
LESS_TERMCAP_se=$'\e[0m'         # standout-mode end

export ${!LESS_TERMCAP*}	 # export all LESS_TERMCAP values (do not quote)
Now less knows which colors to use for these text bits.

Last edited by David the H.; 09-23-2012 at 12:57 PM. Reason: corrected mistake
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
man pages help vijaya_svk Linux - Newbie 4 07-14-2008 02:51 PM
C man pages sono2 Programming 4 09-12-2005 02:24 AM
C++ man pages Guest1234 Ubuntu 0 05-11-2005 03:45 AM
What do you mean by MAN pages? inspectreo Linux - Newbie 2 05-08-2005 03:12 PM
How do I know where the man pages are? narik Linux - General 1 06-15-2004 02:22 PM


All times are GMT -5. The time now is 05:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration