LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   centos5 both 32bit glibc and 64 glibc exist, how to delete the 32bit version (http://www.linuxquestions.org/questions/linux-newbie-8/centos5-both-32bit-glibc-and-64-glibc-exist-how-to-delete-the-32bit-version-4175456656/)

zousheng 04-03-2013 03:45 AM

centos5 both 32bit glibc and 64 glibc exist, how to delete the 32bit version
 
Hi,

When i tried to install a package via rpm, it mentioned glibc (64bit) is needed, but 32bit and 64bit glibc exist, don't know how to deal with this, after running yum install glibc or yum remove glibc, it doesn't work. anyone can help? thank in advance.

gangadhar402 04-03-2013 04:55 AM

Hi,


see these threads
https://www.centos.org/modules/newbb...topic_id=39018
http://www.centos.org/modules/newbb/...33301&forum=37
http://unix.stackexchange.com/questions/tagged/glibc


hope these helpful

zousheng 04-03-2013 09:17 AM

Thanks very much, now I know why it failed and succeeded in another machine, my centos version is 5.7, and another version is 6, so glibc 2.10+ installed by default, and yum update glibc in centos 5.7 won't update it to the glibc2.10+, glibc2.7 is the latest version it can upgrade.

BRs,


All times are GMT -5. The time now is 07:15 PM.