LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-22-2009, 07:27 PM   #1
shussain44
LQ Newbie
 
Registered: May 2009
Posts: 4

Rep: Reputation: 0
Question centos5.1 won't recognise eth1 nic card


hello , i have installed centos5.1, it won't recognise eth1 network device. when i install centos5.3, it does recognise the device which i use private network. same thing happen when i use older version of oracle enter prise linux. i use giga bythe pci network card from intellinet. i also tried another nic card from us robotis with same result. in the intellenet help file it says following which i don't under stand the task. any one has any idea. i am trying to install oracle rac in two node thanks in advance

1. This driver supports RealTek RTL8169s/8110s Gigabit Ethernet driver for Linux kernel 2.4.x.
2. Installation steps:
(1)Compiling r8169.c using 'Makefile'.
"make"
<NOTE>Please remember to ASSIGN "NEW_INCLUDE_PATH" in Makefile according to linux kernel.
(2)Move r8169.o to the directory "/lib/modules/<kernel>/kernel/drivers/net".

"cp r8169.o /lib/modules/<kernel>/kernel/drivers/net"

where <kernel> represents the kernel version, say 2.4.18-3 in Red Hat 7.3
 
Old 05-23-2009, 11:50 AM   #2
jamescondron
Member
 
Registered: Jul 2007
Location: Scunthorpe, UK
Distribution: Ubuntu 8.10; Gentoo; Debian Lenny
Posts: 961

Rep: Reputation: 69
Sure, did you download a tarball of the driver? Untar it, edit Makefile, find the line starting with
NEW_INCLUDE_PATH
and change it's value to whatever the output of uname -r is (Well, almost- mine is 2.6.26-2-686 so I'd change to 2.6.26-2).
Then just use make to build it. Of course, you'll need the build-essential package.

After this, find the file "r8169.o" and move it to where it says.

Easy.
 
Old 05-23-2009, 07:44 PM   #3
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.9, Centos 7.3
Posts: 17,357

Rep: Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367Reputation: 2367
If Centos 5.3 works, use that; its free and will always be more up to date.
 
Old 05-24-2009, 09:33 AM   #4
shussain44
LQ Newbie
 
Registered: May 2009
Posts: 4

Original Poster
Rep: Reputation: 0
centos5.1 won't recognise eth1 nic card

Quote:
Originally Posted by chrism01 View Post
If Centos 5.3 works, use that; its free and will always be more up to date.
Thanks for the help. I am building 2 node RAC cluster following jeff hunter's blog which use centos 5.1. I tried using 5.3 but getting following error while mounting second node.

[root@linux2 /]# mount -t ocfs2 -o datavolume,nointr -L "oracrsfiles" /u02
mount.ocfs2: Transport endpoint is not connected while mounting /dev/sdb1 on /u02.

(8519,1)2net_connect_expired:1585 ERROR: no connection established with node 0 after 30.0 seconds, giving up and returning errors.
(8914,1):dlm_request_join:901 ERROR: status = -107
(8914,1):dlm_try_to_join_domain:1049 ERROR: status = -107
(8914,1):dlm_join_domain:1321 ERROR: status = -107
(8914,1):dlm_register_domain:1514 ERROR: status = -107
(8914,1)cfs2_dlm_init:2024 ERROR: status = -107
(8914,1)cfs2_mount_volume:1133 ERROR: status = -107
-----------------
[root@linux1 ~]# cat /etc/hosts
# Do not remove the following line, or various programs
# that require network functionality will fail.
27.0.0.1 localhost.localdomain localhost
public Network -(eth0)
192.168.2.100 linux1


Currently i am trying with CENTOS4 . if it failed then i will try to run the make command and use 5.1.

i have following file in the instalation cd.
Makefile, R8169.

priviously i copied these 2 file in the /tmp folder and then try to run the make command. I am new bie in linux. Please let me know whether i need to copy somewhere else and then try to run the command.
 
Old 05-24-2009, 09:35 AM   #5
shussain44
LQ Newbie
 
Registered: May 2009
Posts: 4

Original Poster
Rep: Reputation: 0
centos5.1 won't recognise eth1 nic card

Quote:
Originally Posted by jamescondron View Post
Sure, did you download a tarball of the driver? Untar it, edit Makefile, find the line starting with
NEW_INCLUDE_PATH
and change it's value to whatever the output of uname -r is (Well, almost- mine is 2.6.26-2-686 so I'd change to 2.6.26-2).
Then just use make to build it. Of course, you'll need the build-essential package.

After this, find the file "r8169.o" and move it to where it says.

Easy.
what is tarball of the driver?
 
Old 05-24-2009, 05:01 PM   #6
shussain44
LQ Newbie
 
Registered: May 2009
Posts: 4

Original Poster
Rep: Reputation: 0
"centos5.1 won't recognise eth1 nic car

Hi James,
my kernel version is [root@linux1 src]# uname -r
2.6.18-53.el5

there are three file in comes with the installation cd but they are for linux 2.4X

Makefile R8169.C README.TXT

following is my current makefile
---
# Makefile for a basic kernel module

CC=gcc
MODCFLAGS := -O6 -Wall -DMODULE -D__KERNEL__ -DLINUX
NEW_INCLUDE_PATH=-I /usr/src/linux-2.6.18-53/include/

r8169.o: r8169.c /usr/include/linux/version.h
$(CC) $(MODCFLAGS) $(NEW_INCLUDE_PATH) -c r8169.c

clean:
rm *.o -f
-----------------------------------
i copied all the file to /tmp/ETH1
i type make i got following error
make: *** no rule to make target 'r8169.c' needed by 'r8169.0'. stop

Also there are only two directory no linux
[root@linux1 ETH1]# cd /usr/src
[root@linux1 src]# ls
kernels redhat


What am i doing wrong. thanks in advance

Last edited by shussain44; 05-24-2009 at 05:03 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
wont recognise NIC -dell gx 755 -enterprise 4 -help! toffyapple Linux - Networking 5 04-21-2009 02:06 AM
howto acess intrnet thru eth1(wireless card)in winXP via briging in linux(eth0-eth1) labhesh_popli Linux - Wireless Networking 1 09-21-2006 01:11 AM
Activate NIC or eth1 or 0 michshelly Slackware 7 08-17-2006 12:33 AM
How to disable eth1 (wireless nic card) at startup? exitsfunnel Linux - Wireless Networking 4 02-27-2005 11:27 PM
NIC drivers: eth1:9? axlotl Linux - Networking 3 09-19-2003 12:02 PM


All times are GMT -5. The time now is 07:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration